Diese Seite verwendet Cookies, um die Navigation auf unserer Website zu verbessern. Durch Weiternutzung unserer Seite stimmst du der Verwendung von Cookies zu. Weitere Details dazu und Einstellungsmöglichkeiten findest du in unseren Cookie-Richtlinien und unserer Datenschutzerklärung.Schließen

PostgreSQL / Pokern in VM Ware

    • mabla
      mabla
      Bronze
      Dabei seit: 11.02.2007 Beiträge: 1.526
      Also,

      bei VirtualBox sollte das Netzwerk funktionieren, da ich auf Windows ins Internet komme.
      Jetzt habe ich bei in der "/etc/postgresql/8.3/main/pg_hba.conf" am Ende "host all all 10.0.2.0 10.0.2.2 md5" hinzugefügt, da die VirtualBox die IP "10.0.2.15" hat.
      Was muss ich denn bei dem Holdemmander als IP eingeben um auf den PostgreSQL Server zu verbinden?
      127.0.0.1 get nicht, staht aber bei Linux im Netzwerk Fenster.
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 37.513
      Das müsste die IP des "Wirts" PCs sein. Also 10.0.2.?. Du musst in deinem Linux nachschauen auf welche IP der Virtual Network Adapter eingestellt ist (kenne die Details nicht so genau, daher drücke ich das etwas schwammig aus).
      Ich würde mal vermuten, dass das in den Verbindungsdaten angezeigt wird.
    • Maldehyde
      Maldehyde
      Bronze
      Dabei seit: 21.04.2005 Beiträge: 604
      Original von mabla
      Also,

      bei VirtualBox sollte das Netzwerk funktionieren, da ich auf Windows ins Internet komme.
      Jetzt habe ich bei in der "/etc/postgresql/8.3/main/pg_hba.conf" am Ende "host all all 10.0.2.0 10.0.2.2 md5" hinzugefügt, da die VirtualBox die IP "10.0.2.15" hat.
      Was muss ich denn bei dem Holdemmander als IP eingeben um auf den PostgreSQL Server zu verbinden?
      127.0.0.1 get nicht, staht aber bei Linux im Netzwerk Fenster.
      Ein Ausschnitt aus meiner pg_hba.conf:

      code:
      # IPv4 local connections:
      host    all         all         127.0.0.1/32          trust
      host    all         all         192.168.58.6/24       trust
      


      192.168.58.6 ist meine VM, 127.0.0.1 ist localhost, damit ich unter Linux auch die Verwaltungstools nutzen kann.
      Anstatt md5 nehme ich 'trust', obs mit md5 auch geht weiss ich nicht.

      Im HM solltest du nicht localhost (127.0.0.1) angeben, das ist immer die eigene IP. Sondern die IP der Netzwerkkarte des Hosts.
      Bei mir wäre das z.B. 192.168.58.5 .
    • mabla
      mabla
      Bronze
      Dabei seit: 11.02.2007 Beiträge: 1.526
      Wenn ich ifconfig eingeben, kommt das raus:

      code:
      ath0      Link encap:Ethernet  Hardware Adresse 00:1c:f0:cf:a8:a3  
                inet Adresse:192.168.1.108  Bcast:192.168.1.255  Maske:255.255.255.0
                inet6-Adresse: fe80::21c:f0ff:fecf:a8a3/64 Gültigkeitsbereich:Verbindung
                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
                RX packets:2373 errors:0 dropped:0 overruns:0 frame:0
                TX packets:2303 errors:0 dropped:0 overruns:0 carrier:0
                Kollisionen:0 Sendewarteschlangenlänge:0 
                RX bytes:2469220 (2.4 MB)  TX bytes:399043 (399.0 KB)
      
      eth0      Link encap:Ethernet  Hardware Adresse 00:1f:d0:56:ea:e6  
                UP BROADCAST MULTICAST  MTU:1500  Metrik:1
                RX packets:0 errors:0 dropped:49017751856 overruns:0 frame:0
                TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
                Kollisionen:0 Sendewarteschlangenlänge:1000 
                RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
                Interrupt:254 
      
      lo        Link encap:Lokale Schleife  
                inet Adresse:127.0.0.1  Maske:255.0.0.0
                inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
                UP LOOPBACK RUNNING  MTU:16436  Metrik:1
                RX packets:645 errors:0 dropped:0 overruns:0 frame:0
                TX packets:645 errors:0 dropped:0 overruns:0 carrier:0
                Kollisionen:0 Sendewarteschlangenlänge:0 
                RX bytes:111901 (111.9 KB)  TX bytes:111901 (111.9 KB)
      
      wifi0     Link encap:UNSPEC  Hardware Adresse 00-1C-F0-CF-A8-A3-00-00-00-00-00-00-00-00-00-00  
                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
                RX packets:16083 errors:0 dropped:0 overruns:0 frame:1013
                TX packets:2612 errors:0 dropped:0 overruns:0 carrier:0
                Kollisionen:0 Sendewarteschlangenlänge:199 
                RX bytes:4138001 (4.1 MB)  TX bytes:506303 (506.3 KB)
                Interrupt:21 
      


      und bei Windows (VirtualBox) bei ipconfig:

      code:
      Windows-IP-Konfiguration
      
              Hostname. . . . . . . . . . . . . : desktop
              Primäres DNS-Suffix . . . . . . . :
              Knotentyp . . . . . . . . . . . . : Unbekannt
              IP-Routing aktiviert. . . . . . . : Nein
              WINS-Proxy aktiviert. . . . . . . : Nein
      
      Ethernetadapter LAN-Verbindung:
      
              Verbindungsspezifisches DNS-Suffix:
              Beschreibung. . . . . . . . . . . : Ethernetadapter der AMD-PCNET-Famili
      e
              Physikalische Adresse . . . . . . : 08-00-27-A4-CC-26
              DHCP aktiviert. . . . . . . . . . : Ja
              Autokonfiguration aktiviert . . . : Ja
              IP-Adresse. . . . . . . . . . . . : 10.0.2.15
              Subnetzmaske. . . . . . . . . . . : 255.255.255.0
              Standardgateway . . . . . . . . . : 10.0.2.2
              DHCP-Server . . . . . . . . . . . : 10.0.2.2
              DNS-Server. . . . . . . . . . . . : 10.0.2.3
              Lease erhalten. . . . . . . . . . : Sonntag, 2. November 2008 14:30:15
              Lease läuft ab. . . . . . . . . . : Montag, 3. November 2008 14:30:15
    • Kilania
      Kilania
      Bronze
      Dabei seit: 23.04.2007 Beiträge: 7.880
      Du hast NAT aktiviert, oder? Das kann nicht gehen... Erklärte ich glaub schonmal..

      Du musst auf bridged Networking umstellen, sonst hast du imo keine Chance deine VM zu erreichen.

      Und achja, falls sich daran noch immer nichts geändert hat, dann hats bridged Networking unter VirtualBox in sich, da genügt einfach aktivieren nichtmal, du findest zu dem Thema aber gute Wikiartikel.
    • 1
    • 2