postgres 8.4 dienst nach deinstallation

    • Huaba
      Huaba
      Silber
      Dabei seit: 29.09.2009 Beiträge: 301
      hi,

      also ich hab folgendes problem.
      hab gerade den rechner neu aufgesetzt und hm neuinstalliert. als erstes ging auch alles doch dann meldete hm einen fehler (glaub irgendwas mit stream konnte nicht geöffnet werden)
      naja hab mir gedacht einfach alles wieder runter und neu drauf.
      hab dann ein paar verschiedene postgres ausprobiert (8.3/8.4).
      jetzt bin ich soweit das wieder alles herunten ist nur der postgres 8.4 dienst ist noch unter dem user postgres vorhanden wobei der user eigentlich nicht mehr existiert.

      beim starten der hm installation erkennt er das postgres schon installiert ist was ich auf den dienst zurückschließe. wollte eigentlich alles sauber über den complete installer von hm machen was mir jetzt nicht möglich ist.

      deinstalliert wurde alles laut anleitungen hier im forum.
      windows 7 64 bit

      hoffe ihr könnt mir weiterhelfen. probier jetzt schon 2 tage daran rum ;(
      mfg
  • 18 Antworten
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.825
      Du kannst versuchen Postgresql 8.4 mit Revo zu deinstallieren: http://faq.holdemmanager.com/questions/126/Using+Revo+Uninstaller+

      Aber vielleicht reicht es auch die aktuelle 8.4 Version einfach nochmal in ein anderes Verzeichnis zu installieren. Dazu musst du die separate Installation von http://www.postgresql.org nehmen.

      Bei Windows 7 64 Bit gehen übrigens manchmal nur die 8.2. Installer:
      http://wwwmaster.postgresql.org/download/mirrors-ftp/binary/v8.2.20/win32/postgresql-8.2.20-1.zip
    • Huaba
      Huaba
      Silber
      Dabei seit: 29.09.2009 Beiträge: 301
      mit dem unistaller kann ich leider nichts machen da nur mehr der dienst vorhanden ist.

      die 8.4 version lässt sich auch nicht mehr installieren: error A service (postgresql 8.4) allready exists

      kann ich die 8.2 version einfach installieren und hm sagen das er mit dem service arbeiten soll?
      wenn ja macht es einen unterschied was ich vorher installiere?
    • Huaba
      Huaba
      Silber
      Dabei seit: 29.09.2009 Beiträge: 301
      so hab den dienst mit dem microsoft resource kit (delsrv) deinstalliert und die 8.2er version draufgepackt.
      beim datenbank restore kommt jetzt der fehler:
      Error
      ---------------------------
      Could not find PostgreSQL installation directory

      naja da ich die hände noch habe werde ich sie neu importieren jedoch hatte ich das schonmal wobei da dann vermutlich der nächste fehler kommt den ich hier poste ;)
      naja daumen drücken und schonmal danke nestrak

      edit:
      und da ist er schon der fehler. habe ein paar hände importiert und dem hm neugestartet. noch bevor sich die hm-gui öffnet:
      ---------------------------
      An error occurred when retrieving the player list: Datenausnahme.
      ---------------------------

      dannach macht er kurz irgendein optimize und spuckt den gleichen fehler nochmal aus. die paar hände die ich importiert habe waren nie im hm-sessiontab zusehen.

      edit2:
      so hab dann wieder alles runter und es nochmal mit dem complete installer von hm probiert also postgres 8.4
      da bin ich gerade beim restoren wobei dort der fehler nicht kommt jedoch der restore auch nicht fertig wird. (keine prozessorauslastung)
      werde den restore trotzdem noch laufen lassen dannach werde ich die hände aus dem archiv importieren und hoffen das es da funkt.
      wenn das alles nicht funktioniert bin ich mit meinen latein am ende und werde entweder nochmal aufsetzten oder vorher noch die postgres 9.0 probieren.
      mittlerweile kann ich sagen das ich jeden fehler denn ich hatte wieder reproduzieren kann
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.825
      Wie hast du denn das Backup erstellt und wie versuchst du das zu restoren?
      Das geht nicht mit allen Datenbankversionen und vor allem nicht von einer neueren in eine ältere Postgres Version.
    • Huaba
      Huaba
      Silber
      Dabei seit: 29.09.2009 Beiträge: 301
      bin gerade dabei alle hände zu importieren. (dauert noch eine gefühlte ewigkeit ;)
      aber es scheint alles zu funktionieren.
      kann sein das es am alten die 8.3 version war und ich deshalb den fehler bekomme haben als ich auf 8.2 restoren wollte aber mit der 8.4 hat der restore ebenfalls nicht funktioniert (kein fehler aber auch keine cpu auslastung)
      hab mit der hm-funktion restored werde aber in zukunft beides machen. also mit hm und mit pgAdmin.
      sieht bis jetzt gut aus. mit einem kleinen testimport hat es gefunkt.
    • Huaba
      Huaba
      Silber
      Dabei seit: 29.09.2009 Beiträge: 301
      ach nach 1,4 Mio importierter hände dann das:

      ---------------------------
      Holdem Manager
      ---------------------------
      The following error occurred when running this report: Datenausnahme.
      ---------------------------
      OK
      ---------------------------

      bin mit meinem latein am ende. irgendwo während dem import scheint etwas falsch zu laufen. werde da noch einiges zum rumdoktoren haben ;(
      jeder tipp gerne gesehen.
      nach dem neustart von hm ist auch der testimport wieder weg zu sein und es sieht so aus als ob die datenbank komplett leer ist
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.825
      Das deutet aber auf ein tiefer liegendes Problem hin. Vielleicht hat dein Rechner bzw. die Festplatte einen Fehler?

      Ich würde auf alle Fälle mal chkdsk und eine Hardware Diagnose laufen lassen.
    • Huaba
      Huaba
      Silber
      Dabei seit: 29.09.2009 Beiträge: 301
      also ich hab mal chkdsk und hardware diagnose sowie noch ein paar andere tools drüberlaufen lassen. keine fehler gefunden.

      was mich ja stutzig macht ist das die test imports ja super funktionieren mit allen stats und session ergebnissen.
      für mich als laien sieht es halt so aus das irgendwo beim großen import eine hand oder file ist welche das problem verursacht. werd mal versuchen die datei einzugrenzen und außerdem die anderen funktionen von hm auszuprobieren (hud)
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.825
      Kann ich mir eigentlich nicht vorstellen aber versuch es mal.
    • Huaba
      Huaba
      Silber
      Dabei seit: 29.09.2009 Beiträge: 301
      also das ganze wird jetzt immer seltsamer.

      hab jedes monat einzeln importiert in jeweils eine eigene datenbank. bis auf einmal immer das selbe. beim auswählen des namens kommt beim session tab der fehler.
      jedoch im report tab sind die korrekten werte drin auch graph und hände sind vorhanden. nach dem ich dann eine neue datenbank erstellt habe und dann wieder in die alte wechsle ist ein random name bei der liste drin und wenn ich dann meinen namen wieder auswähle funktioniert alles ?(

      werde es morgen nochmal mit einen full import aller hände probieren. trotzdem will mir nicht in meinen schädel was/wie/warum es so ist wie es ist.

      hardwarefehler schließe ich daher aus und denke doch eher an windows 7 64bit mit hm und anscheinend da noch kein anderer solche probleme gemeldet hat auch irgendwo ein leak bei mir ;(
    • Huaba
      Huaba
      Silber
      Dabei seit: 29.09.2009 Beiträge: 301
      man das ist einfach alles schrott. will einfach nicht richtig funktionieren.

      also nochmal der versuch ob irgendwer eine lösung weiß.

      also hände von 1 monat hm archiv importiert. lauter pokerstarshände. ich wähle den spielernamen aus und sehe unter dem reporttab alle hände und korrekten werte beim wechsle auf den session tab kommt der fehler:

      ---------------------------
      Holdem Manager
      ---------------------------
      The following error occurred when running this report: Datenausnahme.
      ---------------------------

      nach einem neustart des holdemmanager funktioniert dann alles auch der sessiontab.
      daraufhin das nächste monat importiert. im reporttab sind auch wieder die korrekten werte drin und im sessiontab stehen nur die hände vom vorhergehenden monat. nach dem neustart von hm funktioniert dann nur der reporttab und im sessiontab kommt wieder der fehler datenausnahme und es werden keine werte mehr angezeigt.

      hab dann noch hände von fulltilt importiert welche nach einen neustart einwandfrei funktionieren.

      edit: wenn ich den vorgang refresh öfters wiederhole mit meinen stars nick kommt nach dem 4ten mal ein anderer fehler:

      ---------------------------
      The following error occurred when running this report: Backend sent unrecognized response type:
      ---------------------------

      edit2: das problem scheint sich nur auf pokerstars hände zu begrenzen und auch nur auf meinen user da es bei den anderen namen funktioniert


      ich hab echt keine ahnung was ich noch probieren soll. kann das mit der anzahl der importierten hände von einen pokernamen zusammenhängen?
      soll ich die postgres 8.2 nochmal probieren?
      liegt es eher an postgres oder doch am hm?
      oder doch an einen hardwarefehler wobei ja bei kleinen imports alles funktioniert.
      thx
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.825
      Dein Rechner ist kaputt - eine andere Erklärung dafür habe ich nicht.
      An postgres oder HM kann das nicht liegen sonst hätten andere auch die Probleme.
    • Huaba
      Huaba
      Silber
      Dabei seit: 29.09.2009 Beiträge: 301
      hm. das hört man nicht gern ;(

      meinst du es liegt an der festplatte? bringt eine installation auf einer anderen partition und vielleicht auch anderen port etwas?
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.825
      Einen Versuch ist es wert aber ich vermute eher ein RAM Problem da es erst bei großen Datenmengen bzw. unter Last auftritt.
    • Huaba
      Huaba
      Silber
      Dabei seit: 29.09.2009 Beiträge: 301
      nach langen herumspielereien funktioniert es endlich wieder.
      keine ahnung was im endeffekt der fehler war aber schlußendlich hat es mit einer neuen installation des complete installer von hm funktioniert.

      einzige grund denn ich mir vorstellen kann denn ram scheint es nicht gewesen zu sein ist ein gestriges update von microsoft .net 4.0
      könnte da ein zusammenhang bestehen?
      naja bin happy und kann wieder grinden :)
      danke für die geduld und tipps nestrak.
      mfg
    • Huaba
      Huaba
      Silber
      Dabei seit: 29.09.2009 Beiträge: 301
      X( X( X(
      ach das gibts ja nicht. wieder back mit ähnlichen prob.

      also der import und alles drumherum hat ja super geklappt und ich konnte auch 2 tage ohne probleme grinden.
      dann kommt plötzlich wieder der fehler beim start von holdem manager. habe aber zuvor keinen import oder ram auslastung gehabt.
      hab dann mir mal gedacht ich mach einen datenbankoptimize da kommt dieser fehler.
      ---------------------------
      ERROR: 57014: canceling statement due to user request

      dannach startet der postgres 8.4 wieder nicht da er ständig auf wird gestartet ist.
      beim versuch des manuellen start des dienstes kommt:

      Dienste
      ---------------------------
      Der Dienst "postgresql-8.4 - PostgreSQL Server 8.4" auf "Lokaler Computer" konnte nicht gestartet werden.

      Fehler 1053: Der Dienst antwortete nicht rechtzeitig auf die Start- oder Steuerungsanforderung.

      vielleicht hast ja noch ideen nestrak?
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.825
      Dein Rechner hat ein Problem oder du benutzt irgendeine Firewall-, Sicherheits-, Tuning-,Registry Cleaning oder was auch immer Software die sich nicht mit Postgresql verträgt.
    • Huaba
      Huaba
      Silber
      Dabei seit: 29.09.2009 Beiträge: 301
      thx a lot
      hab es ja mit deaktivierter zonealarm probiert aber ich musste sie anscheinend deinstallieren.
      thx thx thx