[DONE] Problem mit PostgreSQL

    • vishy
      vishy
      Bronze
      Dabei seit: 01.02.2005 Beiträge: 285
      Hallo liebe Leute,
      ich habe leider ein paar Probleme bei der Installation von PostgreSQL. Ich muss vorausschicken, dass ich sicherlich kein versierter Computerfachmann bin.
      Die Installation vom Elephanten verläuft problemlos. Die Installation von Postgre beginnt nach der Eingabe der Daten im Elephanten und läuft bis zur folgenden Stelle im Installationsfenster problemlos durch: Activating procedural languages...
      Es erscheint ein weiteres kleines Fenster mit dem Titel "Error" und folgender Fehlermeldung:
      Failed to connect to the database. Procedural languages files are installed, but are not activated in any databases.

      Klicke ich dann auf ok erscheint ein weiteres Fenster mit dem Titel "Error" und folgender Fehlermeldung:
      could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "127.0.0.1! and accepting TCP/IP connections on port 5432?

      Es scheint irgendetwas mit den Ports zu tun zu haben. Internet läuft ansonsten einwandfrei. Es handelt sich um ein Laptop mit Vista 32 bit. Auf dem Desktop-PC unter Windows 7 läuft alles einwandfrei.

      Vielen Dank schon einmal im Voraus!

      Gruß, vishy
  • 3 Antworten
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Hallo vishy,

      schau dir bitte mal folgendes an. (Ich zitiere eine älteren Post von mir).

      Original von mrk1988

      Du suchst dir das Notepad über das Startmenü, machst einen Rechtsklick darauf und führst es als Administrator aus.

      Dann klickst du im Notepad auf Datei -> Öffnen und navigierst zu folgendem Pfad.

      C:\Windows\System32\drivers\etc\ .. dann musst du noch einstellen, dass man nicht nur .txt Dateien sieht sondern alle Dateien:



      Hast du das gemacht, wählst du die Datei "hosts" aus. Diese Datei hat keine Dateiendung.

      In dieser Datei fügst du folgende Zeile ein:

      code:
       127.0.0.1       localhost 



      Die Datei müsste dann ungefähr so aussehen:

      code:
      # Copyright (c) 1993-2006 Microsoft Corp.
      #
      # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
      #
      # This file contains the mappings of IP addresses to host names. Each
      # entry should be kept on an individual line. The IP address should
      # be placed in the first column followed by the corresponding host name.
      # The IP address and the host name should be separated by at least one
      # space.
      #
      # Additionally, comments (such as these) may be inserted on individual
      # lines or following the machine name denoted by a '#' symbol.
      #
      # For example:
      #
      #      102.54.94.97     rhino.acme.com          # source server
      #       38.25.63.10     x.acme.com              # x client host
      
      127.0.0.1       localhost
      ::1             localhost
      


      Jetzt speicherst du ab und startest deinen PC neu. Danach sollte die Verbindung zur Datenbank klappen.
      Bitte um Feedback.
    • vishy
      vishy
      Bronze
      Dabei seit: 01.02.2005 Beiträge: 285
      Hallo mrk1988,

      mit Deinem Tip war das Problem ruckzuck behben und es läuft alles einwandfrei.

      Besten Dank dafür!

      Viele Grüße

      vishy
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Alles klar - dann mach ich hier mal zu. :)