[DONE] Probleme nach Update

    • DarkDoener
      DarkDoener
      Bronze
      Dabei seit: 12.04.2011 Beiträge: 108
      Hallo,

      ich hatte im Mai den Elephant und damit auch postgreSQL installiert. Nun habe ich seit dem 29.5 diesen nicht mehr benutzt. Als ich ihn dann gestern benutzen wollte, funktionierte die Verbindung mit der Datenbank nicht mehr -->Neuinstallation des Elephants. Danach ist mir das neue Bild mit Sonnenhut aufgefallen. Demnach vermute ich, dass es ein Update gegeben hat.

      In der Meldung steht, dass man sich versichern soll, ob PostgreSQL richtig läuft. Da ich seit dem letzten Start des Elephants nichts daran verändert habe, deinstallierte ich es laut der Foren-Anweisung.--> zuerst per Systemsteuerung-->dann per Programm(hier frage ich mich ob dies wirklich seine Arbeit macht, denn beim ausführen blinkt nur ein mal kurz die cmd auf und das wars), bei der Neuinstallation wird jedoch gemeldet:

      "Das angegebene Datenverzeichnis ist nicht leer. Wenn eine bestehende Datenbank gleicher Hauptversionsnummer besteht, muß niocht neu initialisiert werden. Bei bestehender Datenbank mit unterschiedlicher Hauptversionsnummer ist ein Backup der alten und erstellen einer neuen Dantenbank erforderlich."
      Allerdings habe ich kein Backup der alten Datenbank.

      Wenn ich den DB-Guide([Guide] Datenbank Probleme) befolge, scheitere ich beim Übergang von Schritt 1 zu 3, denn es wird gemeldet:"Der Name für den Dienst ist ungültig."

      Also zusammengefasst: postgreSQL deinstalliert, aber anscheinend nicht vollständig, denn die Installation funktioniert nicht.

      Hoffentlich kann mir jemand helfen!
  • 5 Antworten
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Hallo DarkDoener,

      schau mal ob unter C:\Programme\postgreSQL (oder ähnliches Verzeichnis) alles entfernt wurde. Schau ebenfalls unter Start -> Ausführen -> cmd -> Enter -> "net user", welche Benutzer noch auf deinem System installiert sind. (So kannst du überprüfen ob die .bat Datei die du ausgeführt hast funktioniert hat).

      PostgreSQL sollte komplett vom System entfernt sein - danach kannst du es neu installieren - bitte um kurzes Feedback ob es denn geklappt hat.
    • DarkDoener
      DarkDoener
      Bronze
      Dabei seit: 12.04.2011 Beiträge: 108
      Benutzerkonten für \\Mein-PC

      -------------------------------------------------------
      Administrator Guest (mein)Benutzerkonto

      Der Befehl wurde erfolgreich ausgeführt

      -->lässt sich immer noch nicht installieren
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Ok, du findest definitiv nichts mehr auf deiner Festplatte im Zusammenhang mit postgreSQL? Übrig gebliebene Ordner, Dateien, etc.?

      z.B. unter Start -> Ausführen -> %localappdata% -> Enter
    • Larres
      Larres
      Bronze
      Dabei seit: 07.09.2009 Beiträge: 2.402
      Hallo DarkDoener,

      ist das Issue hier für Dich noch relevant? Andernfalls müßten wir den Thread hier als erledigt betrachten und schließen.

      Danke,
      L
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Ohne weiteres Feedback ist es wohl nicht mehr relevant und ich schließe diesen Thread daher jetzt auch.