postgre 8.4 installationsprobleme

    • fartingape
      fartingape
      Bronze
      Dabei seit: 12.08.2008 Beiträge: 984
      Hi,

      ich möchte grad auf einem neuen rechner HM und postgre 8.4 istallieren. ich haben den oneclickinstaller genutzt. bei den einstllungen habe ich nix geändert.
      kurz vor ende sagt er:
      "problem running post-install step. installation may not complete correctly.
      the database cluster initialisation failed.

      what to do?
  • 9 Antworten
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.835
      Lad dir mal Postgresql 8.4 von http://www.postgresql.org runter und versuch das zu installieren. Falls das nicht geht nimm mal die neueste 9.x.
      Evtl. auch mal in einem anderen Pfad wie c:\postgresql versuchen.

      Wenn auch das fehlschlägt solltest du zumindest eine aussagekräftigere Fehlermeldung bekommen und dann poste bitte auch eine genaue Beschreibung deines Systems.
    • fartingape
      fartingape
      Bronze
      Dabei seit: 12.08.2008 Beiträge: 984
      Original von netsrak
      Lad dir mal Postgresql 8.4 von http://www.postgresql.org runter und versuch das zu installieren. Falls das nicht geht nimm mal die neueste 9.x.
      Evtl. auch mal in einem anderen Pfad wie c:\postgresql versuchen.

      Wenn auch das fehlschlägt solltest du zumindest eine aussagekräftigere Fehlermeldung bekommen und dann poste bitte auch eine genaue Beschreibung deines Systems.
      Hey.

      also 8.4 bringt nach wie vor die gleiche fehlermeldung. habe auch firewall ausgemacht und andres verzeichnis getestet.
      bei version 9.0.4 sagt er mir am ende der installation : " a non fatal error occured whilst loading database modules. please check the installation log in : ...appdata\local\temp for details.

      drücke ich ok, führt er die installation normal zu ende.

      starte ich dann den HM sagt er, er kann nicht zu 127.0.0.1 verbinden. habe keine antivir software etc. uac ist auch aus.

      wenn ich dann versuche zu connecten, sagt er mir, er kann den service net starten.

      mein system:

      medion

      win 7 32 bit

      dual core t4500 @ 2,3 ghz 2.3ghz

      4gb ram

      danke für die hilfe
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.835
      Dann guck mal in den Windows Diensten in der Systemsteuerung nach - ist da ein Postgresql Dienst und läuft dieser?

      Die Angabe in der Fehlermeldung ist übrigens eine Datei die du mit einem Texteditor öffnen kannst. Vielleicht steht da noch mehr drin.
    • fartingape
      fartingape
      Bronze
      Dabei seit: 12.08.2008 Beiträge: 984
      Original von netsrak
      Dann guck mal in den Windows Diensten in der Systemsteuerung nach - ist da ein Postgresql Dienst und läuft dieser?

      Die Angabe in der Fehlermeldung ist übrigens eine Datei die du mit einem Texteditor öffnen kannst. Vielleicht steht da noch mehr drin.
      bei dem dienst steht, dass er gestartet wird. immer wenn ich in manuel starte kommt die fehlermeldung, dass der dienst zu lange zum reagieren braucht.
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.029
      Zufällig W7 ??
    • fartingape
      fartingape
      Bronze
      Dabei seit: 12.08.2008 Beiträge: 984
      Original von Kick4Ass
      Zufällig W7 ??
      mein system:

      medion

      win 7 32 bit

      dual core t4500 @ 2,3 ghz 2.3ghz

      4gb ram


      (siehe oben)
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.029
      Ok, überlesen Sorry.

      Tja, es gibt W7 System wo man Postgres nicht installiert bekommt. Genau die Fehlermeldung taucht dann auf.

      Gilt nur für Version bis 8.4 / 9.x hab ich noch nicht getestet.

      einzige mir bekannte Abhilfe ist das W7 neu zu installieren, KEINE Updates machen und sofort nachdem W7 läuft Postgres zu installieren.

      Danach kann man die Updates installieren und das W7 so einstellen wie man es haben will.

      Ist mir bisher bei 2 von 10 Rechner passiert, ich hab den Grund dafür nicht finden können.

      Es könnte auch sein das sich eine 8.3 Version installieren läßt.

      Bevor Du das versuchst, sicherstellen das Alle alten Postgres Installationen wirklich Deinstalliert und gelöscht sind. Anleitungen dazu findest Du hier im Forum.

      Revo Uninstaller ist dabei sehr hilfreich, gibs kostenlos. Google hilft.

      Grüße

      Kick
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.835
      Ich würde eine 8.2 empfehlen, die geht fast immer:

      http://wwwmaster.postgresql.org/download/mirrors-ftp/binary/v8.2.21/win32/postgresql-8.2.21-1.zip

      Zip Datei vollständig in ein temporäres Verzeichnis entpacken und dann von dort installieren.
    • fartingape
      fartingape
      Bronze
      Dabei seit: 12.08.2008 Beiträge: 984
      Original von netsrak
      Ich würde eine 8.2 empfehlen, die geht fast immer:

      http://wwwmaster.postgresql.org/download/mirrors-ftp/binary/v8.2.21/win32/postgresql-8.2.21-1.zip

      Zip Datei vollständig in ein temporäres Verzeichnis entpacken und dann von dort installieren.
      hat geklappt thx