Fehlermeldung beim Installieren

    • slevink23
      slevink23
      Bronze
      Dabei seit: 08.02.2011 Beiträge: 3.676
      Immer wenn ich den Elephant installiert habe, erstelle ich eine Datenbank und will dann Postgresql installieren. Dann kommt eine Fehlermeldung die sagt ich solle eine Logdatei angucken. In der steht folgendes:


      The files belonging to this database system will be owned by user "SYSTEM".
      This user must also own the server process.

      The database cluster will be initialized with locale German_Germany.1252.
      The default text search configuration will be set to "german".

      initdb: directory "C:/Program Files/PostgreSQL/8.3/data" exists but is not empty
      If you want to create a new database system, either remove or empty
      the directory "C:/Program Files/PostgreSQL/8.3/data" or run initdb
      with an argument other than "C:/Program Files/PostgreSQL/8.3/data".


      Früher lief der Elephant halbwegs stabil, bis ich ihn einmal anhatte und meinen PC durch Stecker ziehen ausgemacht hatte. Habe das Gefühl dadurch hat der Elephant Schaden erlitten.

      Bitte um Hilfe


      Wenn ich nun den Elephant starte und sage ich will kein Postgresql installieren, dann gebe ich meine Daten ein und es kommt die FehlerMeldung:
      Es kommte keine Verbindung zum Datenbankserver aufgebaut werden!

      Erweiterte Informationen:
      Failed to establish a connetion to 127.0.0.1
  • 1 Antwort
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.836
      Also in dem Log steht kein Fehler drin, sondern nur dass bereits eine Datenbankserver Installation existiert.
      Ich würde erstmal versuchen das vorhandene Postgresql wieder zum Laufen zu bringen:


      1. Rechner neu starten - das kannst du vermutlich überspringen.
      2. Wenn das nichts hilft versteckte Systemdatei postmaster.pid im Postgresql data Verzeichnis löschen (dazu muss in den Windows Ordneroptionen versteckte Dateien anzeigen aktiviert und Systemdateien ausblenden deaktiviert sein). Danach Rechner nochmal neu starten.

      3. Nächster Versuch: in den Windows Diensten (unter Systemsteuerung->Verwaltung oder über Start -> ausführen->services.msc) die Anmeldeart des Postgresql Dienstes unter “Anmelden” auf “Lokales Systemkonto” umstellen und nochmal neu starten.

      4. Wenn es jetzt immer noch nicht geht scheint ein größeres Problem vorzuliegen. Weitere Tipps im Postgresql Link in meiner Signatur unter Troubleshooting oder bei Holdemmanager in der FAQ: http://faq.holdemmanager.com/questions/91/Can%27t+Connect+%7B47%7D+Failed+to+Start+PostgreSQL+