Probleme mit Database - Need Help!

  • 4 Antworten
    • Krupsinator
      Krupsinator
      Moderator
      Moderator
      Dabei seit: 24.05.2010 Beiträge: 13.186
      Hi nasenbaer,

      ich verschieb dich mal ins PostgreSQL-Unterforum. Da wird dir hoffentlich kompetent weitergeholfen ;)

      Gruß Krupsinator
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.823
      Für den Anfang kannst du erstmal folgendes versuchen:
      Postgresql Probleme?

      1. Rechner neu starten
      2. Wenn das nichts hilft versteckte Systemdatei postmaster.pid im Postgresql data Verzeichnis löschen (dazu muss in den Windows Ordneroptionen versteckte Dateien anzeigen aktiviert und Systemdateien ausblenden deaktiviert sein). Danach Rechner nochmal neu starten.

      3. Nächster Versuch: in den Windows Diensten (unter Systemsteuerung->Verwaltung oder über Start -> ausführen->services.msc) die Anmeldeart des Postgresql Dienstes unter "Anmelden" auf "Lokales Systemkonto" umstellen und nochmal neu starten.

      4. Wenn es jetzt immer noch nicht geht scheint ein größeres Problem vorzuliegen. Weitere Tipps im Postgresql Link in meiner Signatur unter Troubleshooting oder bei Holdemmanager in der FAQ: http://faq.holdemmanager.com/questions/91/Can%27t+Connect+%7B47%7D+Failed+to+Start+PostgreSQL+
    • nasenbaer1988
      nasenbaer1988
      Bronze
      Dabei seit: 22.11.2007 Beiträge: 48
      Hab schon des öfteren neu gestartet, jedoch leider erfolglos.

      Im postgresql/8.3/data ordner ist nur ne postmaster.opts datei und keine postmaster.pid datei, soll ich jene trotzdem löschen?

      Gruß
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      Original von nasenbaer1988
      Hab schon des öfteren neu gestartet, jedoch leider erfolglos.

      Im postgresql/8.3/data ordner ist nur ne postmaster.opts datei und keine postmaster.pid datei, soll ich jene trotzdem löschen?

      Gruß
      Nein auf keinem Fall.

      Wenn ich mir Deinen 2ten Screen so ansehe sieht es mir aber nach einer Fehlbedienung aus.

      und zwar deswegen weil da die Fehlermeldung von PT3 sagt "Unable to create...."

      Wenn Du eine neue DB erstellen willst, darf die natürlich nicht den Namen haben der schon vorhanden ist.

      Da ich aber annehme das Du nur zu einer bestehenden verbinden willst, musst Du nach meiner Meinung im ersten Screen die DB markieren und dann als "Set Default" markieren.

      Kann sein das ich falsch liege, hab PT lange nicht mehr genutzt.

      Grüße

      Kick