PostgreSQL Deinstallation Anleitung als Patch für Windows 7

    • Shrik
      Shrik
      Bronze
      Dabei seit: 12.10.2008 Beiträge: 49
      Hallo,
      könntet ihr hier vom Support mal so nett sein und die PostgreSQL Deinstallation Anleitung als patch so gestalten, das sie auch im Editor von Windows 7 zu erkennen ist. Bei mir sieht das so aus: PK  p‰>9·½¥”ë Ì  Remove_PostgreSQL_Total.CMD­TÁŽÚ0½Wê?LWÊ¥*p¯´t“JH e Û½ !/ g\PùÙ^øŒ:
      TvËHQ${æ½7olwqž;pôñCwœ àó•cûÃÞ C|…1n…³‘ó!cLîg”mß
      âfaœ¤wãþhÒÿ1Ü&È`å¬õaKÚd ¬Eø‰¼A3ÏÉxP’†ÄPàm† |%Ïóõ<ª„[}ò"ª` ÁQ@Àš~]²Fj7ÅžGlP¤Ä* ­xÈ> ©yù„ñ?„—03”
      (p'R_”võ xô‚­JŸáâoÎuÞ±$ _t@
      +^³ yál°
      CÇ…²Èk4Ò ñá"¬ò»V{º02˜À*8Þ+'CÚ­ýÛžö7s$ð²$Š­†ðDh+
      ŠÄoݺzÚå§ÿõ¯E´ÞG˜oHeØ /÷2×ý åbCuðèYÑRÄJ¶ì¶\„«©‘¾j;»^ŽãS8{L“ñí¯½lýöÊÑ &¨x!ªDЉ“ûd’4ò¸Ð†¡“Bçn¢ô·XÄlVMc·, ¹Ú‡gCö¬-)CšFbõ|EÓ­‘´,{]9;=Z}ó~šƒø‹X#v«â»±è£&ù?PK   p‰>9·½¥”ë Ì   Remove_PostgreSQL_Total.CMDPK   I $


      Problem ist, ich bekomme das komplette löschen von Postgre SQL nämlich nicht hin. Erst normal deinsatlliert; dann habe ich es als admin im cmd mit: net user postgres / delete probiert. Antwort: Der Benutzername konnte nicht gefunden werden; Programm C Ordner Posgre SQL manuell gelöscht. Weiß ehrlich gesagt nicht mehr weiter. Gestern habe ich es irgendwie hin bekommen... aber dann war die Datenbank zu alt...? Heute habe ich mich den ganzen Tag durch das Forum gesucht und immer wieder auf dieselbe Verlinkung gestoßen...:http://de.pokerstrategy.com/home/959
      Das Problem ist, dass das bei mir und Windows 7 leider nicht klappt. (Siehe oben)

      Grüsse
  • 21 Antworten
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      Moin Shrik,

      Ich kann Dir versichern das es so wie beschrieben einwandfrei klappt. Ich weiß nicht was Du da gemacht hast, aber bei mir sieht die Datei im Editor so aus :

      @echo on
      @REM ********************************************************************************
      @REM
      @REM NAME : Remove_PostgreSQL_Total.CMD
      @REM
      @REM DESCRIPTION : Entfernt vollständig alle Verzeichnisse und Einträge die durch
      @REM die De-Installation von PostgreSQL nicht entfernt wurden.
      @REM
      @REM Diese Datei darf erst nach der De-Installtion von PostgreSQL
      @REM gestartet werden. Sie muß von dem User ausgeführt werden, unter
      @REM dem die Installation von PostgreSQL erfolgte. Normalerweise ist
      @REM das der Administrator unter Windows.
      @REM
      @REM Die Verzeichnisse beziehen sich auf eine PostgreSQL-Standard-
      @REM Installation!
      @REM
      @REM ********************************************************************************

      @REM -------------------------------------------------------------
      @REM Benutzerkonto, unter dem der PostgreSQL-Datenbankserver läuft
      @REM -------------------------------------------------------------

      @set WIN_USER=postgres

      @REM ================================================================================

      NET USER %WIN_USER% /DELETE

      rmdir /S /Q "%SystemDrive%\Dokumente und Einstellungen\%USERNAME%\Anwendungsdaten\PostgreSQL"
      rmdir /S /Q "%SystemDrive%\Dokumente und Einstellungen\%WIN_USER%"
      rmdir /S /Q "%ProgramFiles%\PostgreSQL"


      Dir ist klar das Du das Zip File erst entpacken,, musst um dann das File im Editor zu sehen ??

      Grüße

      Kick
    • Shrik
      Shrik
      Bronze
      Dabei seit: 12.10.2008 Beiträge: 49
      Hallo,
      habs verstanden... hatte ihn nicht entpackt... ABER hab mich jetzt daran gehalten und es ist wie folgt:
      speichern und doppelklicken. Soweit verstädlich dann schreibt er aber: Das System kann die angegebene Datei nicht finden. (im cmd)
      Wenn ich den Elephant installiere wird postgressql
      1. nicht mit installiert---Heißt ja es ist nicht richtig deistalliert....
      2. wenn ich den Elephant starte kommt: Die Verbindung zur Datenbank konnte nicht hergestellt werden! Bitte stellen Sie sicher, das Postgre SQL läuft und die Einstellungen korrekt sind.

      Und wenn ich im Elephant eine neu Datenbank erstellen möchte schreibt er: Database Error: Failed to establish a connection "localhost"
      Do you want to open databasesettings to check the configuration?

      Ende vom Lied
      Ich habe es als admin im cmd mit net user postgres /delete gelöscht:
      Benutzername nicht vorhanden...
      Dann habe ich es mit dem Patch probiert:
      Das System kann die angegebene Datei nicht finden

      Und manuell hab ich es auch probiert... nichts klappt

      Grüsse
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      Original von Shrik
      Hallo,
      habs verstanden... hatte ihn nicht entpackt... ABER hab mich jetzt daran gehalten und es ist wie folgt:
      speichern und doppelklicken. Soweit verstädlich dann schreibt er aber: Das System kann die angegebene Datei nicht finden. (im cmd)
      Wenn ich den Elephant installiere wird postgressql
      1. nicht mit installiert---Heißt ja es ist nicht richtig deistalliert....

      Das ist soweit richtig


      Ab hier brauchst Du nicht weitermachen weil es eine logische Folge von oben ist. Ohne Postgres keine DB



      2. wenn ich den Elephant starte kommt: Die Verbindung zur Datenbank konnte nicht hergestellt werden! Bitte stellen Sie sicher, das Postgre SQL läuft und die Einstellungen korrekt sind.

      Und wenn ich im Elephant eine neu Datenbank erstellen möchte schreibt er: Database Error: Failed to establish a connection "localhost"
      Do you want to open databasesettings to check the configuration?

      Ende vom Lied

      Ab hier kann ich Dir nicht mehr folgen ??



      Ich habe es als admin im cmd mit net user postgres /delete gelöscht:
      Benutzername nicht vorhanden...
      Dann habe ich es mit dem Patch probiert:
      Das System kann die angegebene Datei nicht finden

      Und manuell hab ich es auch probiert... nichts klappt

      Grüsse
      1) Postgres ganz normal deinstallieren über Windows.

      2) Datei entpacken und einfach auf C: legen.

      3) Sicherstellen das Du Admin an dem Rechner bist oder die Datei (die entpackte) als Admin ausführen.

      Rechner neu booten und mal bitte in CMD folgenden Befehl eingeben "Net User" die Ausgabe mal bitte posten.

      Grüße

      Kick
    • Shrik
      Shrik
      Bronze
      Dabei seit: 12.10.2008 Beiträge: 49
      Hallo,

      also hat alles leider nicht geklappt. Aber vielleicht liegt es daran im cmd steht wenn ich net user eingebe:
      Administrator elephant, elephant123, elephant12345, elephant1234567

      Meine Schuld. Wie kann ich da Ordnung rein bringen? Vielleicht klappts deswegen nicht...

      Grüsse

      Shrik
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      Original von Shrik
      Hallo,

      also hat alles leider nicht geklappt. Aber vielleicht liegt es daran im cmd steht wenn ich net user eingebe:
      Administrator elephant, elephant123, elephant12345, elephant1234567

      Meine Schuld. Wie kann ich da Ordnung rein bringen? Vielleicht klappts deswegen nicht...

      Grüsse

      Shrik
      Nu haben wir es ;)

      Bitte lesen : Klick und dann die CMD entsprechend anpassen

      Also so

      WIN_USER=elephant

      Hast Du nur einen User da drin ?? Weil Administrator und sonst nur ele ?? Oder arbeitest Du immer als Admin ??

      Grüße



      Kick
    • Shrik
      Shrik
      Bronze
      Dabei seit: 12.10.2008 Beiträge: 49
      ?
    • Shrik
      Shrik
      Bronze
      Dabei seit: 12.10.2008 Beiträge: 49
      ähm, ok soll ich die überflüssigen jetzt löschen? Also ich habe jetzt gelesen, wie ich befehle im cmd mit net user bearbeite... aber was ist nochgleich mein Ziel?
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      Die ganzen Ele Dinger löschen. Ich gehe mal davon aus das Du Postgres damals mit dem Ele zusammen installierst hast und nicht einzeln.

      Grüße



      Kick
    • Shrik
      Shrik
      Bronze
      Dabei seit: 12.10.2008 Beiträge: 49
      AHHHHHH ok, ok habs gecheckert.....jeden einzelnen im Editor eingeben speichern und doppelklicken und dada...

      herzlichsten Dank :f_biggrin:
    • Shrik
      Shrik
      Bronze
      Dabei seit: 12.10.2008 Beiträge: 49
      Es tut mir wirklich leid, aber habe alles gelöscht. Und wenn ich jetzt net user eingebe stehen nur das Gast konto und Administrator da.... also müsste postgres doch endlich deinstalliert sein, oder????

      Also warum wird Postgre SQL jetzt nicht mitinstalliert, wenn ich den elephant installiere?? ?(

      Grüsse
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      KA.. ich kenne den Ele nicht.

      Schon mal versucht Postgres alleine zu installieren ??

      Hier ist die Version 9.4 für Windows zu finden Klick

      Aber merke Dir die User / Passwörter, die brauchst Du dann für den Ele

      Grüße



      Kick
    • Shrik
      Shrik
      Bronze
      Dabei seit: 12.10.2008 Beiträge: 49
      Ok

      danke dafür

      Mfg
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      Und nu merk Dir das für die Zukunft.

      Nicht das Du in 3 Monaten wieder fragst ;)

      Grüße

      Kick
    • SaveTheVinyl
      SaveTheVinyl
      Silber
      Dabei seit: 22.09.2006 Beiträge: 2.103
      ich raff es leider nicht so ganz. Ich klicke auf bearbeiten der Datei nachdem ich sie entpackt habe. Dann entferne ich bei "@set WIN_USER=postgres" das postgres und füge was ein ? Einerseits steht in der Anleitung den Benutzernamen eingeben. Andereseits steht "Nie" den eigenen Benutzernamen eingeben. ?(
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      Original von SaveTheVinyl
      ich raff es leider nicht so ganz. Ich klicke auf bearbeiten der Datei nachdem ich sie entpackt habe. Dann entferne ich bei "@set WIN_USER=postgres" das postgres und füge was ein ? Einerseits steht in der Anleitung den Benutzernamen eingeben. Andereseits steht "Nie" den eigenen Benutzernamen eingeben. ?(
      Lasse das Script so wie es ist.

      Diese Änderung war nur für OP gedacht, weil er da einiges zermüllt hatte.

      Grüße



      Kick
    • SaveTheVinyl
      SaveTheVinyl
      Silber
      Dabei seit: 22.09.2006 Beiträge: 2.103
      ok wenn ich das skript so lasse wie es ist und es per doppelklick ausführe erscheint für eine halbe sekunde dieses schwarze eingabefenster.

      Die restlichen postgres sachen sind nicht gelöscht und ich kann nicht lesen was in dem schwarzen eingabefenster steht, da es nur für den bruchteil einer sekunde sichtbar ist jedesmal wenn ich euer skrips ausführe.
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      Dann hast Du evtl. Postgres nicht im Standard Modus installiert.

      Hau mal paar Infos raus, damit man nicht immer raten muss ;)
    • SaveTheVinyl
      SaveTheVinyl
      Silber
      Dabei seit: 22.09.2006 Beiträge: 2.103
      -Betriebssystem: Win 7

      -Postgres Version: 8.4

      Konnte über HM nicht mehr mit Datenbank connecten. Auch per PgAdmin nicht.
      -Deswegen deinstallation über Systemsteuerung.

      -Dann Skript runtergeladen. Nichts bearbeitet da ich nicht weiß welchen Benutzernamen ich angegeben habe. Ich vermute ich habe ihn nicht verändert.
      ( Kann ich mich absichern und irgendwo auslesen was mein Benutzername war? )

      -Wenn ich das skript ausführe sehe ich für den bruchteil einer Sekunde das Eingabefenster.


      wie kann ich weiterhelfen bzw. was für Infos brauchst Du ?
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      1) Wenn Du per PgAdmin nicht auf die DB kommst läuft der Dienst Postgres nicht.
      Das ist aber kein Grund den gleich zu Deinstallieren, dann dafür kann es mehrere Günde haben. Themen dazu findest Du haufenweise hier im Forum, oder im HM Forum.

      2) Da Du das Script schon ausgeführt hast, wird es Dir sicher schon was gelöscht haben, also ist nicht sicher ob Deine Installation nun noch ok ist.

      3) Wenn Du Postgres als Standard installierst hast, sollte das Script laufen.

      4) Führst Du das Script als Admin aus ??

      5) Poste mal bitte eine Ausgabe des Befehls " Net User" auf CMD Ebene.
    • 1
    • 2