Datenbank nicht erreichbar

    • toffel
      toffel
      Bronze
      Dabei seit: 24.12.2006 Beiträge: 30
      Beim öffnen des Elephants wurde ich aufgefordert eine neue DB zu erstellen. Alsi ch dies tun wollte kam die Info das kein Verbindung zum Datenbankserver aufgebaut werden konnte...und das eine vorhandene Verbinfung vom Remotehost geschlossen wurde

      weiß da jeman Rat? In der Vergangenheit hat es immer einwandfrei funktioniert...

      Beste Grüße
  • 18 Antworten
    • Silicernium
      Silicernium
      Bronze
      Dabei seit: 22.12.2009 Beiträge: 3.203
      Hallo Toffel!

      Hört sich für mich nach einem Problem mit Postgre an. Schaue doch bitte einmal, ob Postgre überhaupt läuft. Wenn nicht, dann starte den Dienst händisch.

      Dann berichte doch einmal bitte, ob er läuft, ob du ihn nicht starten kannst usw.
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Hallo toffel,

      schau außerdem mal nach, ob in C:\Programme\postgreSQL eine postmaster.pid Datei existiert. Falls sich postgreSQL über Systemsteuerung -> Verwaltung -> Dienste nicht mehr starten lässt, lösch diese Datei mal.
    • Raffnixxxx
      Raffnixxxx
      Global
      Dabei seit: 21.01.2011 Beiträge: 33
      Hallo,

      ich nutze seit einiger Zeit euren Elephant und habe nun schon das zweite mal ein Problem damit, wenn ich ihn öffne kommt das

      "Die Verbindung mit der Datenbank konnte nicht hergestellt werden! Bitte stellen Sie sicher, das PostgreSQL läuft und die Einstellungen korrekt sind."

      beim ersten mal habe ich alles deinstalliert dann wieder alles neu installiert dadurch habe ich aber fast 10000 Hände verloren alles stand wieder auf Null.

      Jetzt wenn der Elephant dann geöffnet ist sehe ich auch wieder keine Hände, Daten...
      Wenn ich das "Datenbankmanagment" aufrufe sehe ich auch keine eingetragene Datenbank ich bekomme angezeigt eine neue Datenbank anzulegen.

      Was muss ich machen um wieder an meine Daten zu kommen?

      Ich habe auch die Antwort hier von Silicernium gesehen, wie kann ich sehen ob der PostgreSQL läuft...?

      MfG Raffi
    • Silicernium
      Silicernium
      Bronze
      Dabei seit: 22.12.2009 Beiträge: 3.203
      Original von Raffnixxxx
      ...

      Ich habe auch die Antwort hier von Silicernium gesehen, wie kann ich sehen ob der PostgreSQL läuft...?

      MfG Raffi
      Hallo!

      Ich hoffe/vermute, dass du nicht wieder alles deinstallieren musst.

      Drücke doch einfach einmal Strg+Alt+Entf, dann solltest du den Taskmanager öffnen können. Dort dann einfach den Dienst Postgre suchen. Dann wirst du wahrscheinlich sehen, dass der Dienst beendet ist.

      Wenn dem so sein sollte, dann halte einmal nach einer Datei namens Postmaster.pid ausschau. Wenn du diese Datei zum Beispiel unter dem Pfad C:\Programme\postgreSQL\data
      Diese löscht du dann einfach und versuchst den Dienst erneut zu starten.

      Wenn du das gemacht hast, melde dich einfach noch einmal. :)
    • Raffnixxxx
      Raffnixxxx
      Global
      Dabei seit: 21.01.2011 Beiträge: 33
      Original von Silicernium
      Original von Raffnixxxx
      ...

      Ich habe auch die Antwort hier von Silicernium gesehen, wie kann ich sehen ob der PostgreSQL läuft...?

      MfG Raffi
      Hallo!

      Ich hoffe/vermute, dass du nicht wieder alles deinstallieren musst.

      Drücke doch einfach einmal Strg+Alt+Entf, dann solltest du den Taskmanager öffnen können. Dort dann einfach den Dienst Postgre suchen. Dann wirst du wahrscheinlich sehen, dass der Dienst beendet ist.

      Wenn dem so sein sollte, dann halte einmal nach einer Datei namens Postmaster.pid ausschau. Wenn du diese Datei zum Beispiel unter dem Pfad C:\Programme\postgreSQL\data
      Diese löscht du dann einfach und versuchst den Dienst erneut zu starten.

      Wenn du das gemacht hast, melde dich einfach noch einmal. :)
      Hi,

      wenn du mir helfen könntest wäre ich dir sehr dankbar!

      Ich habe den Dienst im Taskmanager gefunden Status steht auf "beendet" und dahinter Gruppe "nicht zutreffend" wenn ich ihn dann über rechtsklick starten will sagt er mir

      "Der Vorgang konnte nicht beendet werden.
      Zugriff verweigert"

      Was mache ich nun? Im Programm finde ich es so nicht wie du das andere beschrieben hattest.
      "Postmaster.pid" findet mein Rechner nicht und nach C:\Programme\postgreSQL... habe ich keinen Ordner mit "data" nur 6 andere brauchst du die Namen zur hilfe?

      MfG Raffi
    • Silicernium
      Silicernium
      Bronze
      Dabei seit: 22.12.2009 Beiträge: 3.203
      Hallo!

      Hmm, lasse den Taskmanager offen, gehe links unten auf das Windows Symbol und klicke da drauf. Dann auf alle Programme. Du suchst dort den Ordner Postgre, klickst ihn an und dort solltest du dann Start service finden. Mache das und schaue, was passiert.

      Bei meinem Pfad habe ich den Fehler gemacht, dass du erst auf die Version des Dienstes gehen musst. C:\Programme\postgreSQL\8.3 und dann auf Data.

      Aber wenn dein Rechner diese Datei sowieso nicht findet, wird sie wohl nicht vorhanden sein.

      Sehr komisch auf jeden Fall das Problem. Versuche diese Punkte noch einmal und dann sehen wir morgen mal weiter, ob uns nicht noch etwas einfällt. :)
    • Raffnixxxx
      Raffnixxxx
      Global
      Dabei seit: 21.01.2011 Beiträge: 33
      Hi,

      da ging garnichts mehr mit dem PostpreSQL er war beendet und ließ sich auch keinem weg wieder öffnen ich hab ihn jetzt deinstaliert :(

      Jetzt muss ich mein elephant auch erst wieder deinstalieren, oder kann ich so jetzt den PostpreSQL wieder neu instalieren?

      Danke auf jeden Fall für deine hilfe!

      MfG Raffi
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.031
      Original von Raffnixxxx
      Hi,

      da ging garnichts mehr mit dem PostpreSQL er war beendet und ließ sich auch keinem weg wieder öffnen ich hab ihn jetzt deinstaliert :(

      Jetzt muss ich mein elephant auch erst wieder deinstalieren, oder kann ich so jetzt den PostpreSQL wieder neu instalieren?

      Danke auf jeden Fall für deine hilfe!

      MfG Raffi

      Warum seit ihr immer so schnell mit De-Installieren ???

      Auch wenn es nun zu spät ist, die Datei Postmaster.pid ist eine versteckte Datei und liegt im Postgres Verzeichnis. Wenn Dein Explorer also nicht richtig eingestellt ist wird er die nie finden.

      Da mal dazu. Nun zum nächsten.

      Wie hast Du den Postgres De-installiert ?? Ist auch der User Postgres entfernt worden ??

      Sonst klappt das nicht mit einer neuen Installation.

      Wenn Du Glück hast, kann man Postgres so installieren das Du eine Chance hast Deine evtl. noch vorhandenen Daten wieder einzubinden.

      Weitere Infos dazu findest Du im Postgres Forum.

      Grüße

      Kick
    • Raffnixxxx
      Raffnixxxx
      Global
      Dabei seit: 21.01.2011 Beiträge: 33
      Original von Kick4Ass
      Original von Raffnixxxx
      Hi,

      da ging garnichts mehr mit dem PostpreSQL er war beendet und ließ sich auch keinem weg wieder öffnen ich hab ihn jetzt deinstaliert :(

      Jetzt muss ich mein elephant auch erst wieder deinstalieren, oder kann ich so jetzt den PostpreSQL wieder neu instalieren?

      Danke auf jeden Fall für deine hilfe!

      MfG Raffi

      Warum seit ihr immer so schnell mit De-Installieren ???

      Auch wenn es nun zu spät ist, die Datei Postmaster.pid ist eine versteckte Datei und liegt im Postgres Verzeichnis. Wenn Dein Explorer also nicht richtig eingestellt ist wird er die nie finden.

      Da mal dazu. Nun zum nächsten.

      Wie hast Du den Postgres De-installiert ?? Ist auch der User Postgres entfernt worden ??

      Sonst klappt das nicht mit einer neuen Installation.

      Wenn Du Glück hast, kann man Postgres so installieren das Du eine Chance hast Deine evtl. noch vorhandenen Daten wieder einzubinden.

      Weitere Infos dazu findest Du im Postgres Forum.

      Grüße

      Kick
      Hi,

      joar das ist komplett deinstalliert, ob der User dadurch gelöscht ist weiß ich nicht.

      Habe ich dadurch wieder alles gelöscht? Kann ich meine alten Daten nicht wiederherstellen weil ich Post... deinstalliert habe?

      Ich finde keinerlei Daten zu PostpreSQL.

      Gruß Raffi
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Hallo,

      durch das deinstallieren von postgreSQL hast du deinen /data/ Ordner und damit auch deine Datenbank verloren.

      Der User "postgres" sollte im optimal Fall auch gelöscht werden, damit er während einer neuen postgreSQL Installation wieder angelegt werden kann.

      Wenn der User bestehen bleibt, kann auch einfach ein anderer Benutzername während der Installation von postgreSQL gewählt werden - schön ist diese Lösung dann aber nicht.
    • Raffnixxxx
      Raffnixxxx
      Global
      Dabei seit: 21.01.2011 Beiträge: 33
      Original von mrk1988
      Hallo,

      durch das deinstallieren von postgreSQL hast du deinen /data/ Ordner und damit auch deine Datenbank verloren.

      Der User "postgres" sollte im optimal Fall auch gelöscht werden, damit er während einer neuen postgreSQL Installation wieder angelegt werden kann.

      Wenn der User bestehen bleibt, kann auch einfach ein anderer Benutzername während der Installation von postgreSQL gewählt werden - schön ist diese Lösung dann aber nicht.
      Hi,

      ich bin seit Tagen am tüfteln und weiß absolut nicht mehr weiter ich habe PostgreSQL mehmals komplett wie erklärt gelösch/deinstaliert.
      Ich habe den Elephant mehrmal deinstaliert alle Daten die mit Elephant oder PostgreSQL zu tun haben sind auch alle gelöscht/deinstaliert.

      Aber jedes mal wenn ich den Elephant dann wieder instalieren möchte kommt mitlerweile wenn ich meine Datenbank anlegen möchte nach dem ich mein Passwort eingegen habe und auf "OK" klicke dies,

      "Es konnte keine Verbindung zum Datenbankserver aufgebaut werden!
      Erweiterte Informationen:
      Failed to establish a connectiono `127.0.0.1`."

      Ich kann einfach keine neue Datenbank anlegen, was muss ich tun?

      Oder könnte es an ein anderem Problem liegen?

      MfG Raffi
    • Hoogi81
      Hoogi81
      Bronze
      Dabei seit: 30.12.2007 Beiträge: 7
      Hallo Leute,

      ich bin mit dem Elephant noch blutiger Anfänger, allerdings habe ich wie die Jungs oben auch Datenbankprobleme.

      Bei mir zeigt der Elephant die gespielten Hände nicht mehr in der graphischen Übersicht an.

      Ich habe mir die obigen Hilfestellungen bereits zu Herzen genommen und ausgeführt. Ich habe sowohl die Postmaster.pid datei gelöscht als auch über den Taskmanager den postgre Dienst gefunden (Status: wird ausgeführt). Ich habe postgre sogar manuell gestartet.

      Meine gespielten Hände werden weiterhin auch in der Handhistory gespeichert, allerdings werden die Hände nicht mehr beim Überblick angezeigt.

      Mir ist nur aufgefallen, dass der Elephant seit dem pokerstars Update vom 09.01. nicht mehr funktioniert.

      Ich habe diesen Thread schon mehrfach aufmerksam gelesen, aber alle Hilfestellungen haben bei mir noch nichts gebracht. Von einer Deinstallation habe ich erstmal abgesehen

      Hat jemand eine Idee?

      Gruß

      Björn
    • Silicernium
      Silicernium
      Bronze
      Dabei seit: 22.12.2009 Beiträge: 3.203
      Na ja, wenn der Elephant seit dem Update nicht mehr funktioniert, dann musst du einfach den Elephant updaten. Hier (<-- Klick mich) der Link dahin.
    • Hoogi81
      Hoogi81
      Bronze
      Dabei seit: 30.12.2007 Beiträge: 7
      Original von Silicernium
      Na ja, wenn der Elephant seit dem Update nicht mehr funktioniert, dann musst du einfach den Elephant updaten. Hier (<-- Klick mich) der Link dahin.
      Super,

      das war ja einfach. Warum bin ich nicht selber drauf gekommen? :-)
      Aber ich habe ja gesagt, dass ich blutiger Anfänger beim Elephant bin. Ich fange erst jetzt an, mich vernünftig mit dem Pokern und den Tools auseinanderzusetzen.

      Vielen Dank für den Tipp.

      Gruß

      Björn
    • Silicernium
      Silicernium
      Bronze
      Dabei seit: 22.12.2009 Beiträge: 3.203
      Original von Hoogi81
      Original von Silicernium
      Na ja, wenn der Elephant seit dem Update nicht mehr funktioniert, dann musst du einfach den Elephant updaten. Hier (<-- Klick mich) der Link dahin.
      Super,

      das war ja einfach. Warum bin ich nicht selber drauf gekommen? :-)
      Aber ich habe ja gesagt, dass ich blutiger Anfänger beim Elephant bin. Ich fange erst jetzt an, mich vernünftig mit dem Pokern und den Tools auseinanderzusetzen.

      Vielen Dank für den Tipp.

      Gruß

      Björn
      Ist doch nicht schlimm, man kann ja nicht alles wissen. Und gerade als Anfänger ist es oftmals besser einmal mehr zu fragen. :)

      Viel Spaß weiterhin.
    • Raffnixxxx
      Raffnixxxx
      Global
      Dabei seit: 21.01.2011 Beiträge: 33
      Hallo,

      ich habe auch seit Tagen ein Problem mit dem Elephant habe weiter oben auch mein letztes Ergebnis erleutert könnte mir vielleicht nochmal jemand mit meinem Problem versuchen zu helfen?

      MfG Raffi
    • Silicernium
      Silicernium
      Bronze
      Dabei seit: 22.12.2009 Beiträge: 3.203
      Hallo!

      Kann es sein, dass dieser Post dir weiter hilft?

      Ansonsten in der Suche auch einmal: Failed to establish innerhalb der Pokersoftware suchen. Es gibt schon einige Threads mit diesem Thema.

      Beim Löschen von Postgre, hast du dich da an diesen Thread gehalten? Ansonsten kann es sein, dass du es nicht richtig gelöscht hast.
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Original von Raffnixxxx
      Hallo,

      ich habe auch seit Tagen ein Problem mit dem Elephant habe weiter oben auch mein letztes Ergebnis erleutert könnte mir vielleicht nochmal jemand mit meinem Problem versuchen zu helfen?

      MfG Raffi
      Hallo Raffnixxxx,

      ich habe dir wegen diesem Problem eine Anfrage im Community Modul gesendet:
      http://de.pokerstrategy.com/community/

      Sobald du meine Freundschaftsanfrage akzeptiert hast, lasse ich dir meine Kontaktinformationen zukommen und schau mir das Problem via Remotesoftware an.

      Bis dahin bitte keine neuen Threads / Tickets etc. erstellen.