Postgres Datenbank nach format nicht mehr verwendbar ?!

    • Forstning
      Forstning
      Bronze
      Dabei seit: 26.05.2007 Beiträge: 1.727
      Hey, ich habe heute alles neu aufgesetzt. Nach 6 Stunden installieren und machen und tun wollte ich eigentlich pokern. also postgres installiert und festgestellt dass 9.2. irgendwie nicht installieren will. also 9.1 probiert. aber genau wie 8.4 und 8.3 sagte mir der installer, dass meine vorgelegte datenbank nicht kompatibel ist.

      er sagt es wäre "catalog version " also ohne versionsnummer ?! es gibt ja irgendwie möglichkeiten die datenbank per upgrade zu erweitern und für 9.1.x kompatibel zu machen (wenn meine bisherigen schlüsse zur fehlerquelle überhaupt richtig waren)

      leider habe ich abgesehen vom nerd abc keine ahnung von computern. hilfe!



      #edit#
      oh gott, scheinbar gibts keine möglichkeit aus der RC1 datenbank noch irgenwas zu machen, also brauche ich einen RC1 installer falls den noch wer hat.

      #edit2#
      nach nun 5 stunden geb ichs einfach auf. ich hab noch backups aus 2009 2010 und 2011. wenn mir nun ein wenig fehlt isses auch egal, ich probier garnicht erst die alten hände vor der großen pause einzulesen. der restart ist nun also mit ner quasi leeren datenbank. :)
  • 1 Antwort
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.029
      Moin Forstning,

      Bissi wirr was Du da schreibst, muss gestehen so ganz kann ich Dir nicht folgen.

      Falls Du mit "vorgelegter Datenbank" ein Backup meinst, dann musst Du für ein Restore die gleiche Version von Postgres installieren.

      Ansonsten melde Dich bitte einfach nochmal

      Grüße

      Kick