PostgreSQL neu installieren..

    • zehet
      zehet
      Bronze
      Dabei seit: 25.04.2008 Beiträge: 307
      hallo

      ich habe dummerweise mein altes postfreSQL deinstalliert (wollte eigentlich performance verbessern) und bin leider unfähig das neue zu installieren...

      mein problem ist ich habe kein passwort mehr...

      die passwörter, die in den anderen themen gepostet wurden funktionieren leider nicht...

      und noch eine frage: ich habe die neuste version (?) 9.1.2.1 heruntergeladen in den anderen themen wird aber immer von 8.3 oder 8.4 gesprochen... ich hatte vorher auch 8.3 ist das ein problem?

      aja und obwohl ich alles deinstalliert habe ist noch immer ein alter ordner da mit 8.3..

      wie ihr seht bin ich nicht gerade bewandert auf diesen gebiet...
      bin für jede hilfe dankbar
      thx
  • 16 Antworten
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      Hallo zehet,

      Du solltest die gleiche Version installieren die Du schon hattest, sonst wird es DB Probleme geben.

      Die Neuinstallation wird wohl deswegen verhindert weil der User Postgres noch vorhanden ist. Der muss erst mal weg.

      Den noch vorhandenen Ordner 8.3 kannst Du evtl. wieder einbinden und hättest somit wieder Deine alte DB.

      Anleitungen findest Du hier im Thread, sei so nett und suche Dich da mal durch.

      Grüße



      Kick
    • zehet
      zehet
      Bronze
      Dabei seit: 25.04.2008 Beiträge: 307
      so ich hab jetzt ein paar sachen vom forum versucht:

      1. die standardpasswörter funktionieren leider nicht...

      2. Download "Remove_PostgreSQL_Total.zip" kann ich leider nicht auf bearbeiten klicken weil bei mir erscheint nur Explorer bzw. öffnen und nicht bearbeiten...

      3. als Administrator öffnen (wichtig)
      - im PSQL-Verzeichnis "pg_hba.conf" öffnen
      - recht weit unten gibts eine kleine Liste wo an den Zeilenenden "md5" steht
      - dieses "md5" dann in "trust" ändern
      - speichern
      ... kann ich leider auch nicht weil beim versuch zu speichern bekomm ich folgende meldung:
      "stellen sie sicher, dass Pfad-Dateiname richtig sind"

      könnt ihr mir da weiter helfen...

      thx
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.825
      Deinstallier Postgres über die normalen Windows Funktionen (Programme hinzufügen / entfernen).

      Dann machst du als Administrator eine Eingabeaufforderung auf (rechte Maustaste auf das Icon -> Ausführen als Administrator) und dort gibst du folgendes ein:

      net user postgres /delete

      Danach kannst du Postgresql mit einem neuen Password neu installieren.
    • zehet
      zehet
      Bronze
      Dabei seit: 25.04.2008 Beiträge: 307
      also erstens habe ich wenn ich mit der rechten maustaste das icon angeklickt habe nicht die möglichkeit gehabt als administrator zu öffnen
      ich habe es dann mit run und dann cmd gmacht...
      was sollte nach eingabe dieses befehls dort stehen? bei mir ist dann immer sowas wie:
      NET USER
      benutzername kennwort domain
      benutzername kennwort optionen domain
      benutzername delete domain
      benutzername times all

      ich habe jetzt die ganzen klammern weggelassen...
      allerdings war der order danach noch immer vorhanden...
      ich hab sie jetzt nochmals gelöscht...
      jetzt ist kein ordern mehr vorhanden allerdings lässt sich das neue 8.3 noch immer nicht installieren weil das passwort incorrect ist...
      ;(
      äußerst ärgerlich X(

      bitte helft mir nochmal danke
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      Hi Zehet,

      erst unter ausführen CMD eingeben, dann geht ein schwarzes Fenster auf.

      der Befehl lautet : net user postgres /delete

      Also genauso eingeben und Return drücken.

      Als Kontrolle ob alles geklappt hat gibst Du dann bitte

      Net user

      ein und dann Return

      In der Ausgabe sollte dann NICHT mehr Postgres vorhanden sein.

      Ich lade gleich noch mal ein Pic dazu. Da steht der User Postgres noch drin.

      [img][IMG]https://img705.imageshack.us/img705/1593/netuserausgabe.jpg[/IMG] Uploaded with ImageShack.us[/img]

      Hoffe das hilft Dir

      Grüße



      Kick
    • zehet
      zehet
      Bronze
      Dabei seit: 25.04.2008 Beiträge: 307
      leider nein...




      hab ich jetzt noch irgendwelche andere möglichkeiten??

      möchte bald wieder mit tracker zocken :)
    • zehet
      zehet
      Bronze
      Dabei seit: 25.04.2008 Beiträge: 307
      hab das leider nicht geschafft mit imageshark hochladen ich hoffe du kannst es mit dem link ansehen..
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      Jo Passt,

      2 Fragen wie sieht die Ausgabe von " Net User " aus ??

      Welches Windows ist das ??

      Im Zweifel machen wir das mal mit Teamviewer und Skype
    • zehet
      zehet
      Bronze
      Dabei seit: 25.04.2008 Beiträge: 307
      Windows Vista business
      dann kommt:

      Administrator Gast postgres

      der befehl wurde erfolgreich ausgeführt...


      ja das wäre super wann geht es bei dir am besten? oder kann ich jetzt noch was anderes machen?

      vielen dank nocheinmal
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      Original von zehet
      Windows Vista business
      dann kommt:

      Administrator Gast postgres

      der befehl wurde erfolgreich ausgeführt...


      ja das wäre super wann geht es bei dir am besten? oder kann ich jetzt noch was anderes machen?

      vielen dank nocheinmal
      Moin Zehet,

      Ok Der Löschbefehl wird nicht ausgeführt. Hat Vista ( Habe ich nie benutzt) sowas wie ein UAC ??

      Wenn ja stelle das bitte mal ganz runter, den es sieht so aus als wenn Dein Admin Account irgendwie eingeschränkt ist.

      Dann bitte den User wieder versuchen zu löschen.

      Ich werde morgen so ab 14 Uhr hier sein. adde mich mal im Com zum Austausch der Skype Daten.

      Grüße

      Kick
    • zehet
      zehet
      Bronze
      Dabei seit: 25.04.2008 Beiträge: 307
      hab das mit dem uac gemacht leider mit dem selben ergebnis

      hab dich in der comm geadded

      thx
    • CiccceR
      CiccceR
      Bronze
      Dabei seit: 19.05.2009 Beiträge: 575
      Hi, ich hab postgresql komplett gelöscht (über windowssearch war nichts mehr zu finden),dann postgres8.4 neu installiert,seltsammerweise wurde ich bei der Installation nach einem Passwort gefragt,postgrespass ging nicht,also habe ich postgres eingegeben und die Installation funktionierte.
      Wenn ich mich jetzt über pgadmin in den Datenbankserver einloggen will,funktioniert kein Passwort. ???
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.825
      Es gibt 2 Passwörter, einmal für den Windows Benutzer postgres und zum Anderen für den Postgresql Benutzer postgres.
      Normalerweise sind diese identisch, können aber je nach Installation auch unterschiedlich sein.

      Entweder hast du also da irgendwie unterschiedliche Passwörter vergeben oder deine Serververbindungsdaten im pgadmin stimmen nicht, d.h. pgadmin will sich mit einem nicht mehr vorhandenen Server verbinden. Du kannst da mal versuchen einen neuen Server manuell einzurichten.

      Evtl. hilft dir das hier auch weiter: http://faq.holdemmanager.com/questions/82/Password+Issues+%28PostgreSQL%29
    • CiccceR
      CiccceR
      Bronze
      Dabei seit: 19.05.2009 Beiträge: 575
      Ich möchte noch einmal nachfragen.Der Sachverhalt ist vorhanden,nachdem ich diese Änderungen aus dem Link vorgenommen habe. Ohne diese hätte ich postgres garnicht installieren können.Na gut ,es ist wie es ist,das System läuft ja. Ich hätte mich halt gerne einloggen können,damit ich die Möglichkeit habe meine Datenbank zu pflegen.Was mich auch noch wundert,daß ich laut Taskmanager 5 postgress.exe mit unterschiedlichen Volumen am laufen habe,obwohl ich außer HM keine Daten verwalte.
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.825
      Mehrere postgres.exe ist normal, pro Datenbank Abfrage wird ein neuer Prozess gestartet.

      Das mit dem Anmelden in pgadmin musst du irgendwie hinkriegen. Welchen Link genau meinst du,
      poste am besten mal deine Einstellungen für den Server in pgadmin.
    • CiccceR
      CiccceR
      Bronze
      Dabei seit: 19.05.2009 Beiträge: 575
      "Einstellungen in PGadmin" war das richtige Stichwort,dort habe ich nämlich gar nichts eingetragen,nachdem ich über deinen Link das Passwort zurückgesetzt habe!
      Jetzt hab ich noch ein klitzekleines Problem:
      Server
      -localhoast
      -datenbanken(1)
      -hier wird nur postgres als Datenbank angezeigt.
      Wie füge ich jetzt die HM-daten ein?



      Hab`s selber hinbekommen. Nochmals vielen Dank für deine Unterstützung!
      Grüße,C.