Installationsprobleme

    • Seidelino
      Seidelino
      Bronze
      Dabei seit: 05.05.2009 Beiträge: 78
      Ich brauche unbedingt Hilfe!

      Ich habe seit 2 Monaten ohne Probleme den Elephant benutzt. Vor 2 Tagen gab es dann Probleme mit der Datenbank. Der elephant konnte nicht mehr einwandfrei gestartet werden weil er die Datenbank nicht mehr gefunden hat.

      Ich habe dann wie im forum beschrieben in der eingabeaufforderung nach pgsql gesucht. Nix gefunden. Deshalb also konnte die Datenbank nicht geöffnet werden.

      Also habe ich probiert es zu starten: net start pgsql-8.3 Dann kam als Antwort System Fehler 5.

      Also habe ich elephant samt pgsql entfernt. Ich habe auch versucht die Reste von pgsql mit der Remove_PostgreSQL_Total Datei zu entfernen. Dann versucht den elephant neu zu installieren und wieder taucht der pgsql-dienst in der eingabeaufforderung nicht auf. Starten lässt er sich auch nicht. Also habe ich versucht ihn manuell zu installieren:

      Immer weiter und next geklickt. Als PW immer elephant benutzt. Bei dem Fenster: "Datenbank cluster initialisieren" kommt dann wenn ich auf weiter klicke folgende Mitteilung:

      Das Angegebene Datenverzeichnis ist nicht leer. Wenn eine bestehende Hauptversionsnummer besteht muss nicht neu installiert werden. Ein Backup der Alten und Erstellen einer neuen ist erforderlich.

      Nun zu meinen Fragen:
      Hat jemand ne Idee warum der Elephant urplötlich nach 2 Monaten nicht mehr funzt?
      Wie komme ich bei der pgsql Installation weiter?

      Ich bin am Ende mit meinen Künste und ziemlich angenervt dass ich es nicht alleine geschafft habe. Deshalb schonmal im vorraus danke für jede Hilfe.
  • 6 Antworten
    • Seidelino
      Seidelino
      Bronze
      Dabei seit: 05.05.2009 Beiträge: 78
      Ok ich bin ein stück weiter gekommen...
      ich konnte psql (erfolgreich) installieren.
      Leider startet der Dienst nicht: Wieder derselbe Fehler:

      Systemfehler 5, Zugriff verweigert?
      Habe ich einen Fehler bei der Installation gemacht?
    • Seidelino
      Seidelino
      Bronze
      Dabei seit: 05.05.2009 Beiträge: 78
      Ok es lag wohl an den Administratorrechten...
      also diesmal mit administratorrecht probiert und wieder net start pgsql-8.3 eingegeben. Diesmal kam eine andere Fehlermeldung:

      PostgreSQL Database Server 8.3 konnte nicht gestartet werden. Der Dienst hat keinen Fehler gemeldet.

      Was bedeutet das nun?
      Warum kann ich es immernoch nicht starten?
      Hat jemand schonmal denselben Fehler gehabt?
    • Seidelino
      Seidelino
      Bronze
      Dabei seit: 05.05.2009 Beiträge: 78
      Ich komm nicht weiter... kann denn niemand helfen?
      Soll ich evtl woanders posten? Oder noch ne Woche warten?
    • Seidelino
      Seidelino
      Bronze
      Dabei seit: 05.05.2009 Beiträge: 78
      Die Win7 Ereignisanzeige zeigt für den pgsql-fail folgendes an:

      2012-01-24 17:14:32 GMT FATAL: bogus data in lock file "postmaster.pid": ""

      Wisst ihr nun warum pgsql nicht starten kann?
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 37.008
      Lösch die Datei mal
    • Seidelino
      Seidelino
      Bronze
      Dabei seit: 05.05.2009 Beiträge: 78
      Erstmal vielen Dank für deine Antwort.

      Ich habe die postmaster.pid nicht finden können.

      Habe dann postgres und elephant erneut deinstalliert.

      Bei der Neuinstallation musste ich den sekundäre konto-dienst starten. Außerdem habe ich die benutzerkontensteuerung kurzzeitig ausgeschaltet. Damit habe ich endlich die Installation vollendet.
      Jetzt läuft postgres wieder und der elephant scheinbar auch. Mal sehen wie lange noch :f_grin:

      Bei der erstellen der Datenbank wurde ich noch darauf hingewiesen dass ich eine veraltete Datenbank verwende. Install-datei habe ich aus dem elephant ordner genommen. Aber jetzt funzt es ja erstmal.
      Gott sei dank, 5 Tage rumprobieren sind endlich vorbei.

      topic kann geschlossen werden