[DONE] Keine Verbindung zum Datenbank server

    • Pottloch
      Pottloch
      Bronze
      Dabei seit: 27.02.2012 Beiträge: 11
      Hallo! habe das Problem das das programm bei mir leider nicht automatisch eine datenbank erstellt. habe mir auch das installationsvideo angeschaut und da blobbt ein fenster auf in dem er erkennt das keine datenbank vorhanden ist und eine neue erstellt. dieses fenster ist bei mir nicht aufgegangen. die version von dem video ist auch älter als die aktuelle.
      Die fehlermeldung das das passwort nicht zu dem mir eingegebenen user nicht funktioniert ist klar, da ich ja noch gar keinen user + passwort erstellen konnte.
      es ist mir auch nicht gelungen das passwort zurückzusetzen. ich finde auch die eingabezeile für "net user" nicht.
      Ich habe den elephant auch mehrfach gelöscht un neu installiert funktioniert aber auch nicht. Postgres ist installiert. kann aber nur den admin öffnen in dem ich mich nicht zurecht finde...
      Ich habe mit der Fehlerbehebung jez sicher schon mehr als 3-4h befasst und
      ich komme ums verrecken nicht drauf wie ich dieses problem lösen kann :(
      ich bitte um hilfe! vielen dank!

      Wenn den elephant starte kommt bei mir folgende Fehlermeldung:

      Es konnte keine Verbindung zum Datenbankserver aufgebaut werden! ereiterte informationen: FATAL: 28000: password authenticationfailed for user "elephant0815"



      Vielen dank schonma für die Hilfe. LG
  • 4 Antworten
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Hallo Pottloch,

      mach folgendes:

      Öffne den Editor mit Administratorrechten (Rechtsklick -> Als Administrator ausführen...), klick im Editor auf "Öffnen" und navigiere zum Installationspfad von postgreSQL. (C:\Programme\postgreSQL\8.3\data)

      Du öffnest die Datei "pg_hba.conf" (während der Dienst beendet ist) und änderst "md5" in der Datei zu "trust". Das machst du 2 mal (gibt 2 Einträge), danach speicherst du die Datei und startest postgreSQL neu.

      Eine Anmeldung beim Dienst ist dann mit dem korrekten Benutzernamen möglich - es spielt dann keine Rolle mehr welches Passwort du eingibst.


      Lass mich wissen ob das funktioniert hat.
    • Pottloch
      Pottloch
      Bronze
      Dabei seit: 27.02.2012 Beiträge: 11
      Vielen dank schonmal für die antwort bis hier hin. Das eine Problem ist nun Gelöst. Allerdings blobbt nun ein neues Fehler:

      Es konnte keine Verbindung zum Datenbankserver aufgebaut werden!

      Ereiterte Informationen:

      Von der Übertragungsverbindung können keine Daten gelesen werden: Eine vorhandene Verbindung wurde vom Remotehost geschlossen. "

      dann sagter es konnte keine datenbank erstellt werden.
      nochma probiert dann hieß es mein nutzer sei nicht vorhanden...


      habe mir mal (da ja der elephant eingestellt wird) die test version vom HM2 geladen der funktioniert, auch wenn er schon 2 mal abgestürtzt ist.
      Würde aber gern solange wie es möglich ist den kostenlosen service des elephant nutzen.
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Stell sicher, dass der Dienst gestartet ist. Zum einen über den Taskmanager (psql Prozess), zum anderen über die Systemsteuerung -> Verwaltung -> Dienste.
    • Pottloch
      Pottloch
      Bronze
      Dabei seit: 27.02.2012 Beiträge: 11
      ok wird morgen ausprobiert. und feedback kommt dann direkt