[HEM] failed to establish a connection

    • boooobby05
      boooobby05
      Bronze
      Dabei seit: 13.07.2007 Beiträge: 1.400
      Hi,

      ich kann plötzlich HM1 nicht mehr starten, weil er keine connection zum server hinbekommt. Wenn ich das unter pg admin versuchen, erscheint diese Fehlermeldung:

      Server doesn't listen
      The server doesn't accept connections: the connection library reports
      could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "127.0.0.1" and accepting TCP/IP connections on port 5432?
      If you encounter this message, please check if the server you're trying to contact is actually running PostgreSQL on the given port. Test if you have network connectivity from your client to the server host using ping or equivalent tools. Is your network / VPN / SSH tunnel / firewall configured correctly?
      For security reasons, PostgreSQL does not listen on all available IP addresses on the server machine initially. In order to access the server over the network, you need to enable listening on the address first.
      For PostgreSQL servers starting with version 8.0, this is controlled using the "listen_addresses" parameter in the postgresql.conf file. Here, you can enter a list of IP addresses the server should listen on, or simply use '*' to listen on all available IP addresses. For earlier servers (Version 7.3 or 7.4), you'll need to set the "tcpip_socket" parameter to 'true'.
      You can use the postgresql.conf editor that is built into pgAdmin III to edit the postgresql.conf configuration file. After changing this file, you need to restart the server process to make the setting effective.
      If you double-checked your configuration but still get this error message, it's still unlikely that you encounter a fatal PostgreSQL misbehaviour. You probably have some low level network connectivity problems (e.g. firewall configuration). Please check this thoroughly before reporting a bug to the PostgreSQL community.

      Hab auch das aktuellste Update. Den server den ich ansprechen möchte ist 127.0.0.1 und die Port-Number ist 5432
  • 2 Antworten
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      Da läuft Dein Postgres nicht.

      Ich verschieb mal ins richtige Forum


      Lösung siehe auch post von Netsrak

      Postgresql Probleme? 1. Rechner neu starten

      2. Wenn das nichts hilft versteckte Systemdatei postmaster.pid im Postgresql data Verzeichnis löschen (dazu muss in den Windows Ordneroptionen versteckte Dateien anzeigen aktiviert und Systemdateien ausblenden deaktiviert sein).

      Danach Rechner nochmal neu starten.

      3. Nächster Versuch: in den Windows Diensten (unter Systemsteuerung->Verwaltung oder über Start -> ausführen->services.msc) die Anmeldeart des Postgresql Dienstes unter “Anmelden” auf “Lokales Systemkonto” umstellen und nochmal neu starten.

      4. Wenn es jetzt immer noch nicht geht scheint ein größeres Problem vorzuliegen. Weitere Tipps im Postgresql Link in meiner Signatur unter Troubleshooting oder bei Holdemmanager in der FAQ: http://faq.holdemmanager.com/questions/9...art+PostgreSQL+
    • boooobby05
      boooobby05
      Bronze
      Dabei seit: 13.07.2007 Beiträge: 1.400
      cool danke :) . Punkt 2 hat funktioniert!

      Edit: seh grad wie ich mit bisl suchen auch selber hätte drauf kommen können. Aber trotzdem danke =) .