HM2 startet PostgreSQL nicht

    • falloutchrischi
      falloutchrischi
      Bronze
      Dabei seit: 29.11.2011 Beiträge: 60
      hi ,

      hab folgendes Problem seit gestern startet der HM2 nicht mehr weil er keine Verbindung mit der Datenbank herstellen kann. Ursprünglich war es eine elephant datenbank die ich dann nach Anweisungen aus dem forum zum HM2 importiert habe. Das ganze funktionierte auch alles super seit 3 wochen jetzt schon oder so.
      Deshalb hab ich elephant deinstalliert und auch danach funktionierte alles wunderbar. Jetzt hatte ich gestern beim aufräumen des PC den Ordner der Datenbank ausversehen mit gelöscht , also hab ich heute eine System widerherstellung durchgeführt aber auch das hat nicht geholfen.


      folgende Punkte habe ich schon probiert , klappt alles nicht :

      1. Rechner neu starten
      2. Wenn das nichts hilft versteckte Systemdatei postmaster.pid im Postgresql data Verzeichnis löschen (dazu muss in den Windows Ordneroptionen versteckte Dateien anzeigen aktiviert und Systemdateien ausblenden deaktiviert sein). Danach Rechner nochmal neu starten.

      3. Nächster Versuch: in den Windows Diensten (unter Systemsteuerung->Verwaltung oder über Start -> ausführen->services.msc) die Anmeldeart des Postgresql Dienstes unter “Anmelden” auf “Lokales Systemkonto” umstellen und nochmal neu starten.

      zu dem habe ich versucht die Datenbank Manuell zu starten aber auch das Funktioniert nicht also irgendwie kann sie einfach nicht mehr gestartet werden weder automatisch , noch manuell.

      bei der ereignisanzeige kommt folgender fehler immer wieder :
      2012-04-05 09:41:26 GMT FATAL: could not select a suitable default timezone
      2012-04-05 09:41:26 GMT DETAIL: It appears that your GMT time zone uses leap seconds. PostgreSQL does not support leap seconds.

      wenn einer eine idee hat wäre super.
      danke
  • 9 Antworten
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.030
      Moin falloutchrischi,

      Würde mal tippen das Du Postgres gekillt hast. Ich hab bisher auch noch nie versucht über einen Wiederherstellungspunkt auf ein älteren Stand zurück zu kommen.

      Die Frage ist ja nun was überhaupt noch da ist.

      Weißt Du Deine Postgres Version ?? Dann könnte man mal versuchen die nochmals zu installieren und die vorhandenen Daten einzubinden.
    • falloutchrischi
      falloutchrischi
      Bronze
      Dabei seit: 29.11.2011 Beiträge: 60
      ja hab 8.3 , oh man wird ja immer bunter ..:D
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.030
      bei der ereignisanzeige kommt folgender fehler immer wieder : 2012-04-05 09:41:26 GMT FATAL: could not select a suitable default timezone 2012-04-05 09:41:26 GMT DETAIL: It appears that your GMT time zone uses leap seconds. PostgreSQL does not support leap seconds.


      Das sagt mir rein nichts. Hört sich aber nach Problem mit der Uhrzeit an.

      Bitte warte mal mit Installationsorgien, vielleicht hat ein Kollege da noch einen Tip
    • falloutchrischi
      falloutchrischi
      Bronze
      Dabei seit: 29.11.2011 Beiträge: 60
      ok dann warte ich nochmal ein wenig ..
    • falloutchrischi
      falloutchrischi
      Bronze
      Dabei seit: 29.11.2011 Beiträge: 60
      Soo nun gibt es ein neues Problem ..hab mir gedacht das ich einfach alles lösche und neu installiere einige hände hab ich ja im HM2 archive und andere in der Partypokerhistory , so also hab ich Postgres komplett deinstalliert und auch alles was da bei der deinstallation nicht weggeht. Bei der suche zeigt er keine dateien mehr an also müssten ja alle weg sein. Zur Sicherheit hab ich die Postgres Remove Anwedung hier aus dem Forum durchgeführt.

      Nun wollte ich HM2 neu installieren und gleichzeitig die datenbank , jetzt sagt er mir aber jedesmal wenn die installation der datenbank fast fertig ist das postgreSQL nicht installiert werden konnte ...

      HILFE.
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.030
      Benutzt Du die Version 8.4 ??

      Da gibt es bei einigen Rechner Probleme.

      Lösungsmöglichkeiten :

      Version 8.3 versuchen

      oder die Version mal in ein anderes Verzeichnis installieren
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.836
      Vermutlich hast du noch einen Postgres Benutzer auf deinem Rechner (der wird automatisch bei der Installation mit angelegt) und die HM2 Postgresql Installation erkennt das Passwort nicht.

      Mach mal als Administrator eine Command Box auf und gib folgendes ein:
      net user postgres /delete

      Danach versuch bitte nochmal Postgresql zu installieren.
      Am besten lädst du dir dazu Postgresql 8.4 von http://www.postgresql.org runter.
    • falloutchrischi
      falloutchrischi
      Bronze
      Dabei seit: 29.11.2011 Beiträge: 60
      Alles schon passiert. Hab die datenbank 8.4 jetzt auch installiert und HM2 auch nochmal neu , nun starte ich HM2 und dann kommt die meldung HM2 funktioniert nicht mehr und wird beendet ..Weiß auch nicht was da los ist datenbank geht aber jetzt.
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.836
      Ok, ich denke da machen wir in dem anderen Thread weiter bzw. per Mail.