update 1.2.0 -> 1.2.5