PSQL Postgres

    • MoneyBall
      MoneyBall
      Bronze
      Dabei seit: 25.06.2012 Beiträge: 9
      Hallo,

      ich habe ein Problem und zwar habe ich ausversehen mit einem Tuning-Programm das Programm Postgres deaktiviert. Ich konnte es leider nicht mehr re-aktivieren und habe das Tuningprogramm mittlerweile deinstalliert.


      Starte ich nun das Programm Psql wird gefragt, ob der Server auf dem "localhost"
      läuft.

      Wo kann ich dies nachprüfen und den Server wieder zum Laufen bringen?



      Beste Grüße,

      MoneyBall
  • 15 Antworten
    • klausschreiber
      klausschreiber
      Bronze
      Dabei seit: 30.07.2006 Beiträge: 5.773
      Hallo MoneyBall,

      ich vermute, du hast den postgres Dienst beendet. Wenn das der Fall ist, musst du in die Systemsteuerung, dort die Computerverwaltung aufrufen und dort auf "Dienste". Dort in der Liste müsste dann der postgres Dienst zu finden sein. Wenn du den anklickst, müsstest du links auf "den Dienst starten" klicken können.
      Damit postgres wieder automatisch beim Start mitgestartet wird. musst du einen Rechtsklick auf den postgres Eintrag machen und im aufpoppenden Menü auf "Eigenschaften". Dort müsste irgendwo der Unterpunkt "Starttyp" sein, wo vermutlich "Deaktiviert" oder "Manuell" eingestellt ist.

      Gruß,
      klausschreiber
    • Danjo99
      Danjo99
      Bronze
      Dabei seit: 26.06.2009 Beiträge: 4.644
      Hallo zusammen,

      hab ein Problem mit Postgres, hm2 läuft nicht mehr seit ein paar Tagen da postgres nicht richtig läuft.

      Daraufhin habe ich gerade hier den thread gefunden und es so versucht wie hier beschrieben, das Problem ist der Dienst steht auf "wird gestartet"und "automatisch", kann ihn hier aber weder starten noch beenden, ich befürchte da ist was anderes kaputt, hat evt. jemand einen Tip wie ich weiter vorgehen könnte.

      Danke schonmal
    • superpit
      superpit
      Silber
      Dabei seit: 27.05.2006 Beiträge: 1.941
      Original von Danjo99
      Hallo zusammen,

      hab ein Problem mit Postgres, hm2 läuft nicht mehr seit ein paar Tagen da postgres nicht richtig läuft.

      Daraufhin habe ich gerade hier den thread gefunden und es so versucht wie hier beschrieben, das Problem ist der Dienst steht auf "wird gestartet"und "automatisch", kann ihn hier aber weder starten noch beenden, ich befürchte da ist was anderes kaputt, hat evt. jemand einen Tip wie ich weiter vorgehen könnte.

      Danke schonmal
      schau mal ob der Dienst "Sekundaere Anmeldung" osä gestartet ist. Den braucht es naemlich.

      pit
    • Danjo99
      Danjo99
      Bronze
      Dabei seit: 26.06.2009 Beiträge: 4.644
      Danke für den tip pit, aber leider hat es nicht geholfen, in der zeit wo das postgres lief, zeigte der taskmanager mindestens 6 oder 7 mal postgres an, jetzt nur noch 1 zeile mit minimaler speicherauslastung.

      Und der hm2 sagt keine verbindung und kriegt postgres auch nicht gestartet über den wizard
    • buschips
      buschips
      Moderator
      Moderator
      Dabei seit: 25.10.2010 Beiträge: 13.466
      Mehrere Instanzen von Postgres sind normal.

      The first thing to try is to restart the PostgreSQL service. The simplest way to accomplish this is by restarting your computer. Some Windows users can also try stopping the service manually by selecting Start -> Programs -> PostgreSQL -> Stop Service, but this option is not always available If you are able to stop the PostgreSQL service using this method, you can attempt to search your computer for the postmaster.pid file in /Program Files/PostgreSQL/X.X/data, if this file is found you can safely delete it then restart your computer. This will often, but not always solve the problem. Do not attempt to delete the postmaster.pid file unless the PostgreSQL service has stopped. Replace X.X with the PostgreSQL version number, this is usually 8.3, 8.4, or 9.0.

      (Dienst stoppen->)Datei löschen/umbennen->Rechner neu starten
      Vielleicht löst das dein Problem.
    • Danjo99
      Danjo99
      Bronze
      Dabei seit: 26.06.2009 Beiträge: 4.644
      Ja buschips, das meinte ich ja, da jetzt nur noch eine instanz läuft weiss ich ja das etwas nicht stimmt.

      Das dumme ist nur bei den Diensten steht postgres wird gestartet, lässt sich weder starten, noch stoppen.bei rechtsklick kann ich nur auf eigenschaften gehen, sonst ist nichts anzuklicken.

      Bei eigenschaften steht wird gestartet, tut sich aber nix, keine ahnung wie ich da was stoppen soll. Würde eher sagen der dienst muss gestartet werden =)
    • buschips
      buschips
      Moderator
      Moderator
      Dabei seit: 25.10.2010 Beiträge: 13.466
      Hast du mal ausprobiert was ich dir gepostet habe?
      Hast du etwas am Rechner neu installiert? Neues Anti-Virenprogramm o.ä?
      Backup vorhanden?
    • Danjo99
      Danjo99
      Bronze
      Dabei seit: 26.06.2009 Beiträge: 4.644
      Nein, erstens hab ich die Datei Postmaster.pid nicht gefunden gestern und bin ja auch nicht sicher ob der Dienst auch wirklich aus ist, in deinem englischen zitat steht ja man soll die datei nicht löschen wenn der Dienst an ist, will halt nix falsch machen.

      Eine instanz läuft ja beim taskmanager, wenn auch nur mit wenig speicherbelegung, und da ja " wird gestartet" als Status bei Diensten stand war ich vorsichtig, werd es aber heut abend noch mal versuchen.

      Was mich stört das ich den Dienst weder starten noch stoppen kann, er hängt iwie fest.

      Wie gesagt, werd es noch mal versuchen und sag dir dann bescheid, danke bis hier schonmal ;)

      Ach ja, hatte Probleme mit dem Internet 2 tage, kam nicht rein, dann hing der computer mal und ich hab ein reset gemacht, daraufhin wollte meine firewall das ich alle programme neu bestätige, keine Plan was da los war, und seitdem läuft auch postgres nicht mehr richtig.

      Leider kein backup
    • superpit
      superpit
      Silber
      Dabei seit: 27.05.2006 Beiträge: 1.941
      Original von Danjo99
      Nein, erstens hab ich die Datei Postmaster.pid nicht gefunden gestern und bin ja auch nicht sicher ob der Dienst auch wirklich aus ist, in deinem englischen zitat steht ja man soll die datei nicht löschen wenn der Dienst an ist, will halt nix falsch machen.

      Eine instanz läuft ja beim taskmanager, wenn auch nur mit wenig speicherbelegung, und da ja " wird gestartet" als Status bei Diensten stand war ich vorsichtig, werd es aber heut abend noch mal versuchen.

      Was mich stört das ich den Dienst weder starten noch stoppen kann, er hängt iwie fest.

      Wie gesagt, werd es noch mal versuchen und sag dir dann bescheid, danke bis hier schonmal ;)

      Ach ja, hatte Probleme mit dem Internet 2 tage, kam nicht rein, dann hing der computer mal und ich hab ein reset gemacht, daraufhin wollte meine firewall das ich alle programme neu bestätige, keine Plan was da los war, und seitdem läuft auch postgres nicht mehr richtig.

      Leider kein backup
      die muss in den Ordneroptionen unter Ansicht einstellen das verstecke Dateien angezeigt werden (evlt. auch Geschuetze Systemdatein ausblenden ausschalten).

      Aber der Punkt mit deinem Firewallprogramm gibt mir viel mehr zu denken. Ich vermute mal das der Postgresport geblockt wird. Welches Firewallprogramm benutzt du denn? Kann man das Firwallprogramm zumindest temporaer mal kurz auschalten um zu gucken ob sich der Postgresdienst dann starten laesst?

      pit
    • Danjo99
      Danjo99
      Bronze
      Dabei seit: 26.06.2009 Beiträge: 4.644
      Hi Pit,

      Ich benutze zonealarm, ja kann die mal ausstellen und versuchen ob es dann läuft, aber erst heut abend oder morgen, bin heut spät zu hause.

      Meld mich dann und sag euch bescheid
    • Danjo99
      Danjo99
      Bronze
      Dabei seit: 26.06.2009 Beiträge: 4.644
      Hallo ihr,

      Habs mal ohne firewall laufen lassen und dann tut es der hm2 bzw. Postgres wieder, werd mal versuchen es freizugeben für die firewall, danke euch für die hilfe

      So jetzt ist die frage, da es mit firewall wieder nicht läuft, welche datei ich freigeben muss, sind ja einige.
    • superpit
      superpit
      Silber
      Dabei seit: 27.05.2006 Beiträge: 1.941
      Original von Danjo99
      Hallo ihr,

      Habs mal ohne firewall laufen lassen und dann tut es der hm2 bzw. Postgres wieder, werd mal versuchen es freizugeben für die firewall, danke euch für die hilfe

      So jetzt ist die frage, da es mit firewall wieder nicht läuft, welche datei ich freigeben muss, sind ja einige.
      Port 5432 TCP In und Out. Wo das in Zonelalarm gemacht werden muss, weiss ich leider aber auch nicht.

      Musste mal googeln.

      pit
    • buschips
      buschips
      Moderator
      Moderator
      Dabei seit: 25.10.2010 Beiträge: 13.466
      Oder Postgres und HM2 zu den Ausnahmen/Trusted Applications in Zonealarm hinzufügen (nutze das auch nicht):
      C:\Program Files\PostgreSQL\x.x\bin\postgres.exe (x.x refers the version of PostgreSQL on your computer)
      C:\Program Files\PostgreSQL\x.x\bin\pg_ctl.exe (x.x refers the version of PostgreSQL on your computer)
      +HM2.exe
    • Danjo99
      Danjo99
      Bronze
      Dabei seit: 26.06.2009 Beiträge: 4.644
      Iwie klappt das auch wieder nicht, hab zwar alles frei gegeben, aber trotzdem funktioniert es dann
      nicht, allerdings wenn ich die firewall kurz ausschalte, dann beides hochfahre und dann die firewall wieder anschalte, läuft es anscheinend alles ohne das es die firewall stört, ist zwar ein bisschen blöd weil es vorher anders ging, aber besser als gar nicht ;)
    • Ofcozz
      Ofcozz
      Bronze
      Dabei seit: 30.12.2007 Beiträge: 2.876
      Original von buschips
      Mehrere Instanzen von Postgres sind normal.

      The first thing to try is to restart the PostgreSQL service. The simplest way to accomplish this is by restarting your computer. Some Windows users can also try stopping the service manually by selecting Start -> Programs -> PostgreSQL -> Stop Service, but this option is not always available If you are able to stop the PostgreSQL service using this method, you can attempt to search your computer for the postmaster.pid file in /Program Files/PostgreSQL/X.X/data, if this file is found you can safely delete it then restart your computer. This will often, but not always solve the problem. Do not attempt to delete the postmaster.pid file unless the PostgreSQL service has stopped. Replace X.X with the PostgreSQL version number, this is usually 8.3, 8.4, or 9.0.

      (Dienst stoppen->)Datei löschen/umbennen->Rechner neu starten
      Vielleicht löst das dein Problem.
      ty! bei mir hats so geklappt!