HEM2 kann nicht zum postgreSQL verbinden

    • AragornOL
      AragornOL
      Bronze
      Dabei seit: 28.07.2010 Beiträge: 3.376
      Hallo zusammen,

      seit Freitag connected mein HEM 2 nicht mehr zur Datenbank. Der Versuch über "startserver" meldet Systemfehler 5 - Zugriff verweigert.

      Hat jemand hier eine Idee? Ärgerlich das WE nicht spielen zu können.

      Viele Grüße
      Thorsten
  • 13 Antworten
    • buschips
      buschips
      Moderator
      Moderator
      Dabei seit: 25.10.2010 Beiträge: 13.444
      Such mal nach postmaster.pid auf deinem Rechner (versteckte Datei).
      Ist diese bei nicht laufendem Postgres-Dienst vorhanden->löschen->Rechner neu starten->Läuft wieder?

      Ansonsten wäre interessant was sich seit dem letzten Start geändert hat. Virenscanner, Anti-Spyware/Malware-Programme o.ä. irgendwas in der Richtung installiert?
    • AragornOL
      AragornOL
      Bronze
      Dabei seit: 28.07.2010 Beiträge: 3.376
      Original von buschips
      Such mal nach postmaster.pid auf deinem Rechner (versteckte Datei).
      Ist diese bei nicht laufendem Postgres-Dienst vorhanden->löschen->Rechner neu starten->Läuft wieder?

      Ansonsten wäre interessant was sich seit dem letzten Start geändert hat. Virenscanner, Anti-Spyware/Malware-Programme o.ä. irgendwas in der Richtung installiert?
      Ich habe die Datei gelöscht und habe neugestartet. Leider kein Erfolg. Und nein...ich wusste nicht, was ich geändert habe. Habe eigentlich nur ein paar Spiele installiert...
    • Tackleberry
      Tackleberry
      Coach
      Coach
      Dabei seit: 05.05.2006 Beiträge: 1.668
      - Läuft der postgres-Dienst?
      - Kannst Du Dich mit pgAdmin auf den Datenbankserver verbinden?
      - Worüber führst Du "startserver" aus?
      - Hast Du versucht, den Serverstart als Administrator auszuführen?
      - Hast Du versucht, statt "start" die Funktion "restart server" (als Administrator) auszuführen?
    • AragornOL
      AragornOL
      Bronze
      Dabei seit: 28.07.2010 Beiträge: 3.376
      Original von Tackleberry
      - Läuft der postgres-Dienst?
      - Kannst Du Dich mit pgAdmin auf den Datenbankserver verbinden?
      - Worüber führst Du "startserver" aus?
      - Hast Du versucht, den Serverstart als Administrator auszuführen?
      - Hast Du versucht, statt "start" die Funktion "restart server" (als Administrator) auszuführen?
      - Also unter Dienste scheint er zu laufen
      - Wie geht das?
      - Über die Start....."start server"
      - Wie geht das?
      - Wie geht das?

      Man, bin ich blöd ;-)....
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      Also ich werfe mal in den Raum das es wohl kein HM Problem ist.

      Deswegen bitte von dem mal die Finger lassen.

      Dann wäre es auch gut zu wissen über welches Windows wir reden.

      "Startserver" und "Restart Server" sind eigentlich nicht nötig weil Postgres immer als Dienst installiert wird.

      Werf ich Google an kommen etliche Treffer was die Fehlermeldung betrifft.

      Tendenz scheint zu sein das es hier etwas mit Rechten ( Admin) zu tun hat.

      Evtl. mal schauen ob da was bei ist was vor kurzem an dem Rechner gemacht worden ist.

      http://answers.microsoft.com/de-de/windows/forum/windows_7-security/aktivierung-administratorkonto-unter-windows-7/11271f4c-08f8-4fea-bd7a-562db60e373e
    • AragornOL
      AragornOL
      Bronze
      Dabei seit: 28.07.2010 Beiträge: 3.376
      Original von Kick4Ass
      Also ich werfe mal in den Raum das es wohl kein HM Problem ist.

      Deswegen bitte von dem mal die Finger lassen.

      Dann wäre es auch gut zu wissen über welches Windows wir reden.

      "Startserver" und "Restart Server" sind eigentlich nicht nötig weil Postgres immer als Dienst installiert wird.

      Werf ich Google an kommen etliche Treffer was die Fehlermeldung betrifft.

      Tendenz scheint zu sein das es hier etwas mit Rechten ( Admin) zu tun hat.

      Evtl. mal schauen ob da was bei ist was vor kurzem an dem Rechner gemacht worden ist.

      http://answers.microsoft.com/de-de/windows/forum/windows_7-security/aktivierung-administratorkonto-unter-windows-7/11271f4c-08f8-4fea-bd7a-562db60e373e
      Habe Windows 8.....wie gesagt, habe ich zwei neue Spiele installiert.....HEM2 lässt sich auch nicht als Admin starten....
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      HEM2 lässt sich auch nicht als Admin starten....


      Kannst Du den andere Programme als Admin starten ?


      Also ich habe zwar kein W8, aber der Fehler deutet darauf hin das Du ein Zugriff Problem hast.

      Ich vermute mal das Du entweder nicht als Admin am Rechner bist, oder Postgres keine Admin Rechte hat.

      In der Richtung würde ich mal weiter suchen.
    • Tackleberry
      Tackleberry
      Coach
      Coach
      Dabei seit: 05.05.2006 Beiträge: 1.668
      Original von AragornOL
      - Also unter Dienste scheint er zu laufen
      - Wie geht das?
      - Über die Start....."start server"
      - Wie geht das?
      - Wie geht das?
      OK, versuch´ mal folgendes:

      "Start" - "Stop Server" - funktioniert das?

      Dann wieder "Start" - "Start Server" - RECHTSKLICK!! - "Als Administrator ausführen"

      Wenn das deaktiviert sein sollte, dann ist die Benutzerkontensteuerung ausgeschaltet. Sollte eigentlich kein Problem sein, weil dann die Einschränkungen ohnehin entfallen ...

      Dann versuch mal, Dich über pgAdmin anzumelden, das solltest Du als eigene Verknüpfung im Startmenü im Postgres-Ordner finden ...
    • AragornOL
      AragornOL
      Bronze
      Dabei seit: 28.07.2010 Beiträge: 3.376
      Original von Tackleberry
      Original von AragornOL
      - Also unter Dienste scheint er zu laufen
      - Wie geht das?
      - Über die Start....."start server"
      - Wie geht das?
      - Wie geht das?
      OK, versuch´ mal folgendes:

      "Start" - "Stop Server" - funktioniert das?

      Dann wieder "Start" - "Start Server" - RECHTSKLICK!! - "Als Administrator ausführen"

      Wenn das deaktiviert sein sollte, dann ist die Benutzerkontensteuerung ausgeschaltet. Sollte eigentlich kein Problem sein, weil dann die Einschränkungen ohnehin entfallen ...

      Dann versuch mal, Dich über pgAdmin anzumelden, das solltest Du als eigene Verknüpfung im Startmenü im Postgres-Ordner finden ...
      Der Dienst läuft schon, sagte man mir. pgAdmin verweigert sich mir, bzw. meinem default-Passwort.

      Ich habe den Dienst mal beendet und als Admin (HEM dito) gestartet. Erfolglos. Die PW wundern mich etwas. Unter dem User postgres sagt mir pgAdmin III, dass kein PW gesetzt sei.

      Das PW, dass mir der HEM 2 zeigt, funktioniert auch nicht. "Postgres" will auch nicht.
    • AragornOL
      AragornOL
      Bronze
      Dabei seit: 28.07.2010 Beiträge: 3.376
      Original von Kick4Ass
      HEM2 lässt sich auch nicht als Admin starten....


      Kannst Du den andere Programme als Admin starten ?


      Also ich habe zwar kein W8, aber der Fehler deutet darauf hin das Du ein Zugriff Problem hast.

      Ich vermute mal das Du entweder nicht als Admin am Rechner bist, oder Postgres keine Admin Rechte hat.

      In der Richtung würde ich mal weiter suchen.
      Merkwürdig. Als Administrator kann ich HEM 2 starten. Warum geht das plötzlich nicht mehr mit dem regulären Useraccount nicht mehr? Jemand eine Idee? Immerhin kann ich jetzt meine Hände retten, hoffe ich.
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      Versteh ich das richtig ?

      Du hast einen Admin Account und einen normalen User Account ?

      Im Admin läuft es und im User nicht ?
    • AragornOL
      AragornOL
      Bronze
      Dabei seit: 28.07.2010 Beiträge: 3.376
      Original von Kick4Ass
      Versteh ich das richtig ?

      Du hast einen Admin Account und einen normalen User Account ?

      Im Admin läuft es und im User nicht ?
      Ja genau. Der User-Account ist dieser neue eingeschränkte Admin-Account. Mit dem geht es nicht mehr. Mit dem richtigen Administrator-Zugriff geht es.

      Leider kann ich selbst als Administrator kein Backup ziehen. HEM 2 sagt zwar, dass er was macht, aber speichert nicht ab. Sehr merkwürdig.
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.027
      Also

      Wenn Du als User arbeitest und machst Rechts-Klick auf ein Program Icon gibt es keine Auswahl " als Admin ausführen" ?

      Wegen des Backups, welche Postgres Version benutzt Du ??

      Hast Du Postgres mit dem HM zusammen installiert oder als Einzelprodukt ?