($50 inside!)SQL connected nach Neuinstallation nicht zum Server

    • Grollas
      Grollas
      Bronze
      Dabei seit: 02.09.2010 Beiträge: 634
      Okay, da ich überhaupt nicht mehr weiter weiß, meld ich mich hier mal mit meinem Anliegen:

      Mein HM2 spackt nun seit ein paar Wochen schon rum, und nachdem das dahingehend ausufterte, dass ich nicht mal mehr ordentliche Sessionreviews machen kann, weil mir Grafiken falsch angezeigt werden, habe ich das komplette Ding runtergeschmissen.
      Backups wollte er nicht machen - warum auch immer. Habe daher das Backup über SQL gemacht und den Ordner "data" damit kopiert, in dem dann auch die wichtigen Notes, Konfigurationen etc. eingestellt sind.

      Beides neuinstalliert, SQL hat ordnungsgemäß mit Meldung den alten Data-Ordner hinzugefügt, und nun kommt mir über HM2 die Meldung "There was an error starting the service: postgresql-8.4. Please manually investigate the problem."

      Wenn ich über SQL versuche, mich zum Server zu verbinden, kommt die Fehlermeldung:
      "Datenbankverbindung herstellen... Fehlgeschlagen."

      Als zusätzliche Fehlermeldung erscheint folgendes: ... "could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "127.0.0.1" and accepting TCP/IP connections on port 5432?

      Weiß hier jemand weiter? Bin echt am Rande meiner Nerven, da ich ungerne meine wichtigen Notes verlieren will.

      Vielen Dank!

      Gruß,
      Grollas
  • 38 Antworten
    • DerHut
      DerHut
      Bronze
      Dabei seit: 14.01.2007 Beiträge: 1.270
      Das Problem hatte ich auch mal. Bei mir hat eine erneute Installation von SQL geholfen.

      Edit: Arbeitest du mit Windows? Wenn ja, starte die Programme mal beide als Admin, das beseitigt auch so manchen Fehler. Achja auch noch ganz wichtig, schau doch mal nach, ob der Port der genutzt wird nicht von deiner Firewall blockiert wird.
    • Grollas
      Grollas
      Bronze
      Dabei seit: 02.09.2010 Beiträge: 634
      Die Neuinstallation hilft nicht, das habe ich bereits versucht.

      Wenn ich allerdings neuinstalliere, und statt der alten DB einen neuen Ordner erstellen lasse, klappt es - muss also irgendwas mit den Einstellungen innerhalb der DB zu tun haben.
      Ich benutze denselben Port wie immer, der wird afaik nicht blockiert.

      Edit: Ich benutze btw auch die richtige Version von SQL, das ist bei mir 8.4.
    • DerHut
      DerHut
      Bronze
      Dabei seit: 14.01.2007 Beiträge: 1.270
      Okay, das hört sich für mich nach einem Problem mit den Ordnerrechten an. Vergleich doch mal, welche Rechte ein neu angelegter Ordner hat und welche Rechte der alte Ordner hat.
    • Grollas
      Grollas
      Bronze
      Dabei seit: 02.09.2010 Beiträge: 634
      Du meinst, unter den Eigenschaften? Das habe ich bereits überprüft und angepasst, leider immer noch keine Besserung :/
      Oder gibt es da noch andere Rechte?
    • DerHut
      DerHut
      Bronze
      Dabei seit: 14.01.2007 Beiträge: 1.270
      Ich meine die unter "Eigenschaften" --> "Sicherheit". Hast du mal Versuchshalber allen Nutzern Vollzugriff gegeben und dasdann auch vererben lassen?
    • Grollas
      Grollas
      Bronze
      Dabei seit: 02.09.2010 Beiträge: 634
      Okay, ich bin wahrscheinlich blind, aber unter den Optionen bzgl. des Servers gibt es bei mir keinen "Sicherheit"-Reiter.
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.029
      Hallo Grollas,

      Als erstes bitte sicherstellen das der Postgres Server auch läuft. Da es ein Dienst ist unter Dienste nachsehen und versuchen zu starten wenn er nicht läuft. Was wahrscheinlich ist.

      Das verstehe ich gerade nicht so ganz:

      Habe daher das Backup über SQL gemacht und den Ordner "data" damit kopiert, in dem dann auch die wichtigen Notes, Konfigurationen etc. eingestellt sind.


      Hast Du nun ein Backup oder eine Kopie ??

      Im Zweifel wenn Du ein Backup hast, einfach Postgres neu installieren als Standard, nichts einbinden oder so.

      Prüfen ob der Dienst läuft und dann das Backup einspielen.

      Gruß

      Kick
    • DerHut
      DerHut
      Bronze
      Dabei seit: 14.01.2007 Beiträge: 1.270
      Original von Grollas
      Okay, ich bin wahrscheinlich blind, aber unter den Optionen bzgl. des Servers gibt es bei mir keinen "Sicherheit"-Reiter.
      Ich meine den Ordner mit der DB. Ich hab das jetzt so verstanden, dass du deine alte DB in einem Ordner hast, den du einbindest. Diesem Ordner würde ich die Rechte geben und schauen, ob es dann klappt.
    • Grollas
      Grollas
      Bronze
      Dabei seit: 02.09.2010 Beiträge: 634
      Original von Kick4Ass
      Hallo Grollas,

      Als erstes bitte sicherstellen das der Postgres Server auch läuft. Da es ein Dienst ist unter Dienste nachsehen und versuchen zu starten wenn er nicht läuft. Was wahrscheinlich ist.
      Der Server startet nicht, da hast du Recht.
      Als Fehlermeldung erhalte ich:

      "Systemfehler 5 aufgetreten.

      Zugriff verweigert.

      The start command returned an error <2>"

      Dieselbe Meldung erhalte ich bei dem Dienst "Restart Server".

      Original von Kick4Ass
      Hast Du nun ein Backup oder eine Kopie ??

      Im Zweifel wenn Du ein Backup hast, einfach Postgres neu installieren als Standard, nichts einbinden oder so.

      Prüfen ob der Dienst läuft und dann das Backup einspielen.
      Ich habe mir eine Sicherung meiner DB angelegt - ob das nun eine Kopie oder ein Backup ist, keine Ahnung.

      Jedenfalls ist es nicht möglich, eine DB nach der Installation einfach einzubinden, das habe ich im Vorfeld schon versucht.

      Danke für eure bisherige Zuwendung, macht mir ein wenig Hoffnung ;)

      Grollas
    • Grollas
      Grollas
      Bronze
      Dabei seit: 02.09.2010 Beiträge: 634
      Original von DerHut
      Ich meine die unter "Eigenschaften" --> "Sicherheit". Hast du mal Versuchshalber allen Nutzern Vollzugriff gegeben und dasdann auch vererben lassen?
      Vollzugriff haben bei mir bereits alle User, die Rechte scheinen auch gleich zu sein...

      Gruß,
      Grollas
    • Kick4Ass
      Kick4Ass
      Moderator
      Moderator
      Dabei seit: 04.05.2007 Beiträge: 17.029
      1)
      Ich habe mir eine Sicherung meiner DB angelegt - ob das nun eine Kopie oder ein Backup ist, keine Ahnung.


      Ok dann bitte mal beschreiben wie Du es gemacht hast. Da gibt es nämlich schon einen Unterschied zwischen Kopie und Backup. Deshalb sollten wir das mal klären.

      Jedenfalls ist es nicht möglich, eine DB nach der Installation einfach einzubinden, das habe ich im Vorfeld schon versucht.


      Was kam da für eine Fehlermeldung ?

      Und nochmal so nachgefragt.

      Du hast Postgres wie de-installiert ??

      Und hast Du auch den User Postgres gelöscht ?

      Mit den Rechten würde ich mal vorsichtig sein, falsche Rechte an falscher Stelle lassen unter Umständen Dein Rechner angreifbar werden.

      Gruß

      Kick
    • buschips
      buschips
      Moderator
      Moderator
      Dabei seit: 25.10.2010 Beiträge: 13.465
      Bitte erstmal die Fragen von KickAss beantworten, wie die Kopie/das Backup aussieht. Kopie des Data-Ordner oder des kompletten Postgres-Ordners?
      Oder ein Programm (pgAdmin) zum Backup genutzt?
      Ich nehme mal an die Kopie wurde bei laufendem Postgres-Dienst gemacht?

      Gibt es eine postmaster.pid im alten data-Ordner?
      (Wer ist der Besitzer des data-Ordners?)
    • ihatewonderbras
      ihatewonderbras
      Bronze
      Dabei seit: 19.05.2014 Beiträge: 1.144
      http://forums.holdemmanager.com/manager-general/8170-postgresql-problem.html

      Dürfte die Lösung zu deiner Problemstellung beinhalten.

      BTW. als ich heute HEM mit der 8.4er Version starten wollte,
      hatte er auch Connection-Probleme.
      Nach der Installation der 9.3.4er Version funktioniert nun alles wieder.
      Nur meine Hände musste ich neu einspielen. (absoluter Laie)

      andere Option:
      postmaster.pid löschen (ist wohl eine versteckte Datei)
    • Grollas
      Grollas
      Bronze
      Dabei seit: 02.09.2010 Beiträge: 634
      Bevor ich auf die Fragen eingehe, werde ich erstmal die Ratschäge auf dem Link annehmen.

      Original von ihatewonderbras

      andere Option:
      postmaster.pid löschen
      Gilt das auch für die Datei postmaster.opts?
      postmaster.pid ist in der SQl-Version, die den kopierten DB-Ordner hat, nicht vorhanden.
    • buschips
      buschips
      Moderator
      Moderator
      Dabei seit: 25.10.2010 Beiträge: 13.465
      Original von Grollas
      Bevor ich auf die Fragen eingehe, werde ich erstmal die Ratschäge auf dem Link annehmen.

      Original von ihatewonderbras

      andere Option:
      postmaster.pid löschen
      Gilt das auch für die Datei postmaster.opts?
      postmaster.pid ist in der SQl-Version, die den kopierten DB-Ordner hat, nicht vorhanden.
      Nein. opts-Datei nicht löschen.
      Da Postgres ohne deine alte DB läuft, mache dir mal nicht allzu viel Hoffnung bei dieser Anleitung. ;)
    • ihatewonderbras
      ihatewonderbras
      Bronze
      Dabei seit: 19.05.2014 Beiträge: 1.144
      Hey, diese Option
      fand ich
      unter folgendem Link:

      http://faq.holdemmanager.com/questions/91/Can%27t+Connect+%7B47%7D+Failed+to+Start+PostgreSQL+
    • Grollas
      Grollas
      Bronze
      Dabei seit: 02.09.2010 Beiträge: 634
      Original von ihatewonderbras
      http://forums.holdemmanager.com/manager-general/8170-postgresql-problem.html

      Dürfte die Lösung zu deiner Problemstellung beinhalten.

      BTW. als ich heute HEM mit der 8.4er Version starten wollte,
      hatte er auch Connection-Probleme.
      Nach der Installation der 9.3.4er Version funktioniert nun alles wieder.
      Nur meine Hände musste ich neu einspielen. (absoluter Laie)

      andere Option:
      postmaster.pid löschen (ist wohl eine versteckte Datei)
      # Copyright (c) 1993-2009 Microsoft Corp.
      #
      # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
      #
      # This file contains the mappings of IP addresses to host names. Each
      # entry should be kept on an individual line. The IP address should
      # be placed in the first column followed by the corresponding host name.
      # The IP address and the host name should be separated by at least one
      # space.
      #
      # Additionally, comments (such as these) may be inserted on individual
      # lines or following the machine name denoted by a '#' symbol.
      #
      # For example:
      #
      # 102.54.94.97 rhino.acme.com # source server
      # 38.25.63.10 x.acme.com # x client host

      # localhost name resolution is handled within DNS itself.
      # 127.0.0.1 localhost
      # ::1 localhost


      Wenn das nach deren Anleitung NACH dem Editieren der File so aussehen soll, dann klappt das bei mir leider nicht - war nämlich schon vorher so.
      Dennoch, vielen Dank dir für den Link.

      Okay, dann können wir schonmal festhalten, dass ich keine postmaster.pid-File habe, wenn ich den kopierten DB-Ordner während der Installation einbinden lasse.

      Ich werde wegen der Fehlermeldung bzgl. des nachträglichen Reinkopierens nochmal ne Installation starten, hab die nicht mehr im Kopf.



      Original von Kick4Ass

      Und nochmal so nachgefragt.

      Du hast Postgres wie de-installiert ??

      Und hast Du auch den User Postgres gelöscht ?
      Über die Systemsteuerung ---> Programme entfernen.
      Der User Postgres wurde nicht gelöscht, nein.

      Gruß,
      Grollas
    • buschips
      buschips
      Moderator
      Moderator
      Dabei seit: 25.10.2010 Beiträge: 13.465
      Nein, die # am Anfang in den letzten beiden Zeilen wegmachen.

      Beantworte doch einfach mal wie du die Kopie vorliegen hast. Der komplette Postgres-Ordner oder nur den data-Ordner?

      Richtiger Ausgangspunkt wäre nach der Postgres-Deinstallation: Du hast unter "C:\Programme\Postgres\8.4" (oder wo auch immer Postgres installiert war) nur noch den (alten) data-Ordner vorliegen und startest dann die Postgres-Installation. War dies der Fall?
    • Grollas
      Grollas
      Bronze
      Dabei seit: 02.09.2010 Beiträge: 634
      Original von buschips
      Nein, die # am Anfang in den letzten beiden Zeilen wegmachen.

      Beantworte doch einfach mal wie du die Kopie vorliegen hast. Der komplette Postgres-Ordner oder nur den data-Ordner?

      Richtiger Ausgangspunkt wäre nach der Postgres-Deinstallation: Du hast unter "C:\Programme\Postgres\8.4" (oder wo auch immer Postgres installiert war) nur noch den (alten) data-Ordner vorliegen und startest dann die Postgres-Installation. War dies der Fall?
      Nein, nur der Data-Ordner.

      Original von buschips
      Richtiger Ausgangspunkt wäre nach der Postgres-Deinstallation: Du hast unter "C:\Programme\Postgres\8.4" (oder wo auch immer Postgres installiert war) nur noch den (alten) data-Ordner vorliegen und startest dann die Postgres-Installation. War dies der Fall?
      Ich hatte für die Neuinstallation einen neuen Ordner erstellt und den data-Ordner da reinkopiert, dann die Installation gestartet und als Pfad den Ordner angegeben.

      Btw: Ich brauche zum Ändern der oben angesprochenen Textdate Administratorrechte, hab aber grade nicht auf dem Schirm, wie ich die für alle Ordner freischalte - der Befehl über CMD "net user administrator /active:yes" wird mit der Meldung "Zugriff verweigert" quittiert :rolleyes:
      Über Eigenschaften ---> Sicherheit lässt sich auch nichts an Rechten für diese Datei ändern - jemand eine Idee?
    • 1
    • 2