Portgesql macht mich fertig

    • cubaner
      cubaner
      Bronze
      Dabei seit: 05.03.2006 Beiträge: 4.245
      zuerst hatte ich nur das problem hier:

      fehler in pokertracker



      doch dann kams faustdick! ich hab postgresql deinstalliert und neu installiert wobei es da schon probleme beim installieren gab, da ich beim 2.passwort (ich hoffe ihr versteht was ich meine!) nicht weiterkam weil passwort "falsch" wäre.
      ich nehm also den hacken oben rechts raus denk mir einen neuen namen aus und dann gings weiter.

      jetzt geht in pokertracker allerdings garnichts mehr der startet schon mit ner fehlermeldung "unable to connect to the database.....)
      ich versuch die postgrasql database functions im pt zu öffnen und wieder fehlermeldung " unable to connect to PostgreSQL to get list of databases"


      ich weiß nicht wie ich diese ganze verworrenne schei..... wieder zum laufen bringen kann, hat jemand nen vorschlag?
      bin pokermäßig damit erstmal lahmgelegt ;(


      bin dankbar für jede hilfe!!!!!!!! :D
  • 35 Antworten
    • cubaner
      cubaner
      Bronze
      Dabei seit: 05.03.2006 Beiträge: 4.245
      nicht mein error beim compressing der DB erledigt!

      machmal wird man echt wahnsinning vorm pc ;)
    • sirius
      sirius
      Bronze
      Dabei seit: 12.02.2006 Beiträge: 125
      Tja ich habe jetz genau dasselbe Problem und wenn ich versuche dass manuell zu starten gehts auch nich...kA was ich da jetz machen kann... Pokertracker-Forum auch schon gewälzt. Weiss jemand Rat??
    • yooraps
      yooraps
      Bronze
      Dabei seit: 17.06.2005 Beiträge: 353
      hallo...............also ich hab ein ähnliches Problem.......nach einer Windowsneusintallation hab ich postgres natürlich auch neu installieren müssen.....
      leider gabs auch Schwierigkeiten beim Passwort.... da kam auch die Fehlermeldung wg. falschem Passwort...Installation konnte somit nicht beendet werden.......
      das Deinstallieren und Neuinstallieren von postgres bringt leider nix......die meldung mit dem falschen Passwort kommt danach auch noch....

      ein Kollege vom Pokerstrategy-Supportteam hat mir empfohlen den support von postgres anzumailen.........(evtl. müßte man Windows nochmal neu installieren......war eine der Befürchtungen)

      Jetzt ist über eine Woche vergangen und ich hab von postgres immer noch keine Antwort erhalten auf meine Anfrage........find ich ziemlich schwach.....

      sollte es sich um keinen Einzelfall halten mit diesem Problem, schlage ich vor, daß sich jemand von PS direkt an postgres wendet, zumal sie auf einzelne Anfragen wie z.B. meine nicht reagieren...
    • Temar
      Temar
      Bronze
      Dabei seit: 14.07.2006 Beiträge: 536
      Original von yooraps
      hallo...............also ich hab ein ähnliches Problem.......nach einer Windowsneusintallation hab ich postgres natürlich auch neu installieren müssen.....
      leider gabs auch Schwierigkeiten beim Passwort.... da kam auch die Fehlermeldung wg. falschem Passwort...Installation konnte somit nicht beendet werden.......
      das Deinstallieren und Neuinstallieren von postgres bringt leider nix......die meldung mit dem falschen Passwort kommt danach auch noch....
      Ich kenne die Windows Version von Postgres nicht (nur UNIX), aber wenn alle Dateien auf der Platte sind und sich der Service starten lässt, dann gibt es keinen Grund Postgres neu zu installieren. Du kannst die Datenbank löschen und neu initialisieren.


      ein Kollege vom Pokerstrategy-Supportteam hat mir empfohlen den support von postgres anzumailen.........(evtl. müßte man Windows nochmal neu installieren......war eine der Befürchtungen)
      Windows reinstallation ist nicht nötig. Das ist keine Applikation, die sich tief ins System einhängt, sondern nur ein Service. Im schlimmsten Fall muss man Postgres neu installieren, falls Installation auf halber Strecke verreckt ist.


      Jetzt ist über eine Woche vergangen und ich hab von postgres immer noch keine Antwort erhalten auf meine Anfrage........find ich ziemlich schwach.....
      PostgreSQL ist eine freie Datenbank, die von Programmieren in ihrer Freizeit entwickelt wird. Von den Programmieren bekommst du keinen Support, da sie sonst nicht mehr zum programmieren kommen würden :-)
      Du musst dich auf die Mailing-Liste einschreiben oder einfach nur an die Mailing-Liste schreiben und sagen, dass du nicht eingeschrieben bist, damit du ein CC von den antworten bekommst. Mailing Listen gibt's hier: http://www.postgresql.org/community/lists/


      sollte es sich um keinen Einzelfall halten mit diesem Problem, schlage ich vor, daß sich jemand von PS direkt an postgres wendet, zumal sie auf einzelne Anfragen wie z.B. meine nicht reagieren...
      Die werden auch nicht auf Anfragen von PS.de antworten. Ihr müsst euch schon auf den Mailing-Listen einschreiben oder die Dokumentation lesen. Wenn du dein Problem genauer beschreibst kann ich dir vielleicht auch helfen. Habe zumindest unter UNIX einiges an Erfahrung mit Postgres. Unter Windows hab ich's allerdings noch nie installiert.

      Gruss,
      Alex
    • sirius
      sirius
      Bronze
      Dabei seit: 12.02.2006 Beiträge: 125
      Also wie gesagt mein Problem ist dass ich die Datenbanken nicht abrufen kann weil postgresql sich nicht starten lässt! 101 - sqlstate = 08001
      War auf einmal da das prob....
    • Temar
      Temar
      Bronze
      Dabei seit: 14.07.2006 Beiträge: 536
      Original von sirius
      Also wie gesagt mein Problem ist dass ich die Datenbanken nicht abrufen kann weil postgresql sich nicht starten lässt! 101 - sqlstate = 08001
      War auf einmal da das prob....
      SQLState 08001 steht für "The connection attempt to the database did not succeed.". Demnach bringt uns die Fehlermeldung net weiter, weil das wohl einfach nur bedeuted, dass die DB net läuft. Ich nehme mal, dass PockerTracker dir diese Meldung zurückgibt.

      Wie startest du denn die Datenbank? Klickst du auf irgendeinen Eintrag im Startmenü oder startest du das Ding über "Systemsteuerung->Verwaltung->Dienste"? Wenn's ein Eintrag im Startmenü ist, dann klick mal mit der rechten Maustaste drauf und lass dir die Eigenschaften anzeigen. Unter "Ziel" siehst du dann welches Programm Windows ausführt. Genau das was unter "Ziel" steht kannst du dann einfach mal über die Windows Kommandozeile starten. Dafür klickst du auf "Start->Ausführen" und tippst "cmd" ein. Es öffnet sich ein Fenster mit einem Prompt und da gibst du dann einfach mal das ein, was bei der Verknüpfung unter Ziel stand. In der Regel bekommst du dann eine eindeutigere Fehlermeldung. Wenn du dir nicht sicher bist, dann poste doch mal hier im Thread, was Windows da starten will.

      Was sich auf jedenfall lohnt ist im Eventlog nach Fehlermeldungen zu schauen. Dazu startest du "Systemsteurung->Verwaltung->Ereignisanzeige" und schaust dort unter "System" und "Anwendungen" ob du irgendwelche Fehlermeldung von postgresql siehst.

      Noch eins: Der Grund warum eine Neuinstallation von PostgreSQL nix bringt ist vermutlich der, dass die eigentliche Datenbank beim deinstallieren nicht gelöscht wird. Schliesslich willst du in der Regel ein Update der Datenbank machen und dabei nicht deine ganzen Daten verlieren. Hast du also ein falsches Passwort gesetzt, dann ändert auch eine Neuinstallation nix, da die alte Datenbank nicht überschrieben wurde.

      Vorausgesetzt, dass PostgreSQL sauber installiert wurde, kannst du im Prinzip einfach die Datenbank löschen und eine neue anlegen. Unter UNIX geht das mit "initdb" und "createdb". Gib "createdb" einfach mal testweise in der "cmd" ein und schau ob da was kommt. Ohne Parameter macht das Tool nix, sondern sollte eine Hilfe ausspucken. Wenn er das Tool im Pfad hat können wir auch dein Table Space löschen und mit initdb ne neue Postgres-Umgebung erstellen.

      Gruss,
      Alex
    • sirius
      sirius
      Bronze
      Dabei seit: 12.02.2006 Beiträge: 125
      Hi! Danke erst ma für die ausführliche Antwort!

      Also ich hab beide Möglichkeiten versucht es zu starten und neuerdings sagt er mir jetz die ganze Zeit dass es keine zulässige Win23 Anwendung wäre..Vorher hat er mir noch was anderes gesagt! Unter cmd sagt er mir das jetz auch. Wenn ich createdb im cmd eingebe geht auch nix....falsch geschrieben oder nicht gefunden blabla!
      Im Eventlog sind einige Fehlermeldungen von Postgresql: Fehlermeldung logger shutting down!
      Naja kA!

      MfG, sirius!
    • Temar
      Temar
      Bronze
      Dabei seit: 14.07.2006 Beiträge: 536
      Original von sirius
      Also ich hab beide Möglichkeiten versucht es zu starten und neuerdings sagt er mir jetz die ganze Zeit dass es keine zulässige Win23 Anwendung wäre..
      Hmm, wie wird denn PgSQL gestartet. Kannst du mal das Ziel der Verknüpfung hier posten?


      Wenn ich createdb im cmd eingebe geht auch nix....falsch geschrieben oder nicht gefunden blabla!
      Ok, dann ist das PgSQL Verzeichnis nicht im Pfad mit drin. Schau mal obs im Installationsordner von PgSQL ein Verzeichnis "bin" gibt und ob da das Tool initdb und createdb drin ist.


      Im Eventlog sind einige Fehlermeldungen von Postgresql: Fehlermeldung logger shutting down!
      Da der Logger gestartet wurde, wurde bestimmt auch ein Logfile geschrieben. Schau mal im Installationsordner oder dem Ordner mit der Datenbank nach einer "postgresql.log" Datei. Da müsste genaueres drinstehen.

      Gruss,
      Alex
    • sirius
      sirius
      Bronze
      Dabei seit: 12.02.2006 Beiträge: 125
      Man du bist ja mega fix...

      Also wenn ich Postgresql starten will: "Start>Programme>Postgresql8.0>Start Service" Ziel der Verknüpfung: C:\WINNT\system32\net.exe start pgsql-8.0

      Unter Dienste lautet die Verknüpfung: C:\Programme\PostgreSQL\8.0\bin\pg_ctl.exe runservice -N "pgsql-8.0" -D "C:\Programme\PostgreSQL\8.0\data\"

      Initdb und createdb gibbet! ßffnet sich kurz ein Dos- Fenster und schliesst sich wieder....

      Fehlermeldung im log-File is etwas länger:

      2006-07-24 21:57:37 LOG: database system was shut down at 2006-07-24 01:28:43 Westeuropäische Sommerzeit
      2006-07-24 21:57:37 LOG: could not open file "C:/Programme/PostgreSQL/8.0/data/pg_xlog/00000001000000030000005F" (log file 3, segment 95): No such file or directory
      2006-07-24 21:57:37 LOG: invalid primary checkpoint record
      2006-07-24 21:57:37 LOG: could not open file "C:/Programme/PostgreSQL/8.0/data/pg_xlog/00000001000000030000005F" (log file 3, segment 95): No such file or directory
      2006-07-24 21:57:37 LOG: invalid secondary checkpoint record
      2006-07-24 21:57:37 PANIC: could not locate a valid checkpoint record

      abnormal program termination
      2006-07-24 21:57:37 LOG: startup process (PID 1084) was terminated by signal 3
      2006-07-24 21:57:37 LOG: aborting startup due to startup process failure
      2006-07-24 21:57:38 LOG: logger shutting down
    • Temar
      Temar
      Bronze
      Dabei seit: 14.07.2006 Beiträge: 536
      Der kann seine Transaktion-Logfiles nicht finden. Da ist wohl was bein initialisieren der Datenbank schief gelaufen. Es könnte auch sein, dass er keine Rechte die Dateien zu lesen.

      Schau mal ob's die Logfiles, die er nicht öffnen kann, auf der Platte gibt oder ob die nicht da sind. Wenn die fehlen, dann müssen wir mit initdb eine neue Umgebung anlegen.

      Gruss,
      Alex
    • sirius
      sirius
      Bronze
      Dabei seit: 12.02.2006 Beiträge: 125
      Es gibt nicht ma den Ordner pg_xlog ...also ich find die files nicht!
    • Temar
      Temar
      Bronze
      Dabei seit: 14.07.2006 Beiträge: 536
      Ja dann ist da wohl was beim initialisieren der Datenbankumgebung schief gelaufen. Was du jetzt machen musst ist im Prinzip folgendes:

      1. Das Verzeichnis C:/Programme/PostgreSQL/8.0/data/ verschieben oder umbenennen.

      2. Ein neues data Verzeichnis anlegen. Dabei musst du aber wahrscheinlich die Rechte anpassen, weil die Datenbank in diesem Verzeichnis Dateien schreiben muss. PostgreSQL müsste bei der Installation einen neuen Benutzer angelegt haben, unter dessen Konto die Datenbank läuft. Am besten du schaust mal wem das alte "data" Verzeichnis gehört.

      3. Mit initdb eine neue Datenbank-Umgebung anlegen. Es kann sein, dass initdb unter Windows die Rechte des data-Verzeichnisses automatisch richtig setzt. Das weiss ich aber nicht. Das Kommando lautet "initdb -D C:/Programme/PostgreSQL/8.0/data/". Das Tool "initdb" müsste irgendwo im PostgreSQL Installationsordner rumfliegen. Vermutlich unter "bin" wenn's das gibt. Aufrufen kannst du es dann, indem du in der "cmd" vorher mit dem Kommando "cd <verzeichnisname>" in das Verzeichnis wechselst, in dem initdb liegt. Also z.B.:
      cd C:/Programme/PostgreSQL/8.0/bin
      initdb -D C:/Programme/PostgreSQL/8.0/data

      4. PockerTracker Datenbank und Benutzer anlegen. Da ich kein PT habe, weiss ich nicht wie das geht. Aber vermutlich macht er das bei der Installation oder man kann es irgendwo auswählen.

      5. Falls Datenbankzugriff nicht möglich, müssen wir u.U. noch die PostgreSQL Rechte setzen.

      Gruss,
      Alex
    • sirius
      sirius
      Bronze
      Dabei seit: 12.02.2006 Beiträge: 125
      2. Wie meinst du das mit Rechte anpassen?

      Der sacht mir wenn ich das ausführe dass der Admin nicht die Rechte Postgresql auszuführen sondern ein unpriviligierter User den Server neu starten sollen um etwaige system security compromises zu verhindern...??Wat soll dat denn?

      Also erst macht der schon alles und hinterher löscht er dann wieder alles....
    • Temar
      Temar
      Bronze
      Dabei seit: 14.07.2006 Beiträge: 536
      Original von sirius
      2. Wie meinst du das mit Rechte anpassen?

      Der sacht mir wenn ich das ausführe dass der Admin nicht die Rechte Postgresql auszuführen sondern ein unpriviligierter User den Server neu starten sollen um etwaige system security compromises zu verhindern...??Wat soll dat denn?

      Also erst macht der schon alles und hinterher löscht er dann wieder alles....
      Hehe, genau das meine ich mit Rechten. Das Problem ist folgendes: Angenommen du betreibst eine Datenbank, die nicht nur lokal auf deinem Rechner läuft, sondern von einem dritten Rechner aus abgefragt wird (das ist meistens so). Sollte in PgSQL jetzt ein Fehler sein, so könnte ein Angreifer von aussen u.U. Programme auf deinem Rechner mit den Rechten des Datenbankbenutzers ausführen. Um das zu verhindern, wird bei der Installation ein unpriviligierter Benutzer angelegt, unter dessen Konto die Datenbank dann läuft. Aus Sicherheitsgründen erlaubt es PostgreSQL einfach nicht, dass die Datenbank als Admin gestartet wird, da sonst das ganze System kompromitiert werden könnte.

      Was wolltest du denn ausführen? initdb? Oder wolltest du PostgreSQL neu starten?

      Wenn du initdb ausführen willst, dann kannst du das mit "runas" machen. Dazu musst du erstmal feststellen, wie der Datenbankbenutzer heisst. Müsstest du irgendwo unter "Systemsteuerung->Benutzer" finden. Wenn er z.B. "pgsql" heisst, dann müsste das so gehen:

      runas /user:pgsql initdb -D .....

      Oder so ähnlich (hab grad kein Windows da). "runas" liefert aber ne Hilfe, wenn du einfach nur "runas" eingibst. Da müsste dann notfalls stehen wie der "/user" Parameter genau zu verwenden ist. Aber ich glaub das war schon so, wie oben geschrieben.

      Das Problem ist jetzt aber auch, dass der PostgreSQL Benutzer unbedingt Schreibrechte auf den "data" Ordner benötigt. Sonst kann er die Datenbankumgebung garnet anlegen. Wenn du WinXP Home hast, dann arbeitest du standardmässig im "Dummy-Modus" - d.h. du kannst dir die Rechte nicht anzeigen lassen. Sehen würdest du die Rechte, wenn du mit der rechten Maustaste auf den "data" Ordner klickst und dann auf Eigenschaften gehst. Dort sollte es dann einen Reiter geben, der sich "Sicherheit" nennt. Hier kann man die Rechte setzen. Damit das geht, muss man das XP auf den erweiterten Rechte-Modus umschalten. Das geht auch irgendwo unter "Systemsteuerung->Benutzer" soweit ich das noch weiss. Hast du nicht in diesen Modus umgeschalten, dann siehst du auch das Tab "Sicherheit" nicht. Wenn dir das jetzt alles zu kompliziert werden sollte, dann hast du auch noch zwei andere Möglichkeiten:

      1. Du kopierst den alten "data" Ordner, nennst die Kopie wieder "data" und löschst den kompletten Inhalt. Vermutlich wird Windows auch im Dummy-Modus die Rechte mitkopieren. Dann probierst du das mit dem initdb nochmal.

      2. Du deinstallierst PostgreSQL und löschst den kompletten PostgreSQL Ordner unter "c:\programme" oder zumindest einen etwaigen "data" Ordner. Dann installierst du es neu. Vermutlich wird er bei der Installation die Rechte automatisch setzen. Wenn du allerdings Pech hast und es geht wieder etwas schief, weil ihm irgendwas nicht passt, dann bist du genauso weit wie vorher :-)

      Gruss,
      Alex
    • sirius
      sirius
      Bronze
      Dabei seit: 12.02.2006 Beiträge: 125
      Moin!
      Also ich habs jetz geschafft die Umgebung neu anzulegen! Schon ma gut!;) Trotzdem sagt er mir jetz weiterhin das PostgreSQL8.0 keine zulässige Win32 Anwendung wäre wenn ichs starten will!
      Meinst du ich muss nen neuen Pokertracker-User anlegen und ne neue DB starten oder werden die alten noch laufen...

      Noch ma vielen vielen Dank für die ganzen Antworten!

      MfG, sirius!
    • Temar
      Temar
      Bronze
      Dabei seit: 14.07.2006 Beiträge: 536
      Original von sirius
      Also ich habs jetz geschafft die Umgebung neu anzulegen! Schon ma gut!;) Trotzdem sagt er mir jetz weiterhin das PostgreSQL8.0 keine zulässige Win32 Anwendung wäre wenn ichs starten will!
      Hmm, wie startest du es denn? Was passiert wenn du unter "Systemsteuerung->Verwaltung->Dienste" den Dienst per Hand startest? Was steht in der Ereignisanzeige und was steht im "postgresql.log" File?


      Meinst du ich muss nen neuen Pokertracker-User anlegen und ne neue DB starten oder werden die alten noch laufen...
      Noch ma vielen vielen Dank für die ganzen Antworten!
      MfG, sirius!
      Da du eine komplett neue Datenbankumgebung angelegt hast, gibt es auch keine Benutzer mehr. Du musst also sowohl die PT Datenbank als auch den PT Benutzer neu anlegen. Passwort haben wir keins auf die DB-Umgebung gesetzt. Wenn er also nach einem Master- oder Administratorpasswort für die Datenbank fragt (zum anlegen der PT-Datenbank oder des Benutzers), dann einfach nix eingeben.

      Gruss,
      Alex
    • sirius
      sirius
      Bronze
      Dabei seit: 12.02.2006 Beiträge: 125
      [quote]Original von Temar
      Original von sirius
      Also ich habs jetz geschafft die Umgebung neu anzulegen! Schon ma gut!;) Trotzdem sagt er mir jetz weiterhin das PostgreSQL8.0 keine zulässige Win32 Anwendung wäre wenn ichs starten will!
      Hmm, wie startest du es denn? Was passiert wenn du unter "Systemsteuerung->Verwaltung->Dienste" den Dienst per Hand startest? Was steht in der Ereignisanzeige und was steht im "postgresql.log" File?

      Da steht genau das. Fehler 193: %1 ist keine zulässige Win32-Anwendung.

      Ah ja und ein postgresql.log file wird irgendwie niht merh angelegt..find ich auf jeden fall nicht.
    • Temar
      Temar
      Bronze
      Dabei seit: 14.07.2006 Beiträge: 536
      So, hat ein wenige länger gedauert, war noch essen.

      Original von sirius
      Da steht genau das. Fehler 193: %1 ist keine zulässige Win32-Anwendung.
      "%1" ist ein Platzhalter. Sowas wird bei Skripten verwendet, denen du Parameter übergeben kannst. Eigentlich sollte an dieser Stelle der Pfad zu dem Programm eingefügt werden. Das ist auf jedenfall ne sehr eigenartige Sache, denn der Link der Verknüpfung zum Starten von PgSQL zeigt direkt auf pg_ctl.exe. Zumindest hast du in einem deiner letzten Post dieses Ziel angegeben:

      C:\Programme\PostgreSQL\8.0\bin\pg_ctl.exe runservice -N "pgsql-8.0" -D "C:\Programme\PostgreSQL\8.0\data\"

      Da gibt es jetzt zwei Möglichkeiten:

      1) pg_ctl.exe ist irgendwie defekt. Das macht zwar wenig Sinn, denn %1 hat hier irgendwie nix zu suchen. Trotzdem solltest du mal testen, ob du pg_ctl.exe ohne irgendwelche Parameter in einer "cmd" starten kannst. Also einfach nur in einer "cmd" in das Verzeichnis von pg_ctl.exe wechseln und dann nur "pg_ctl" eingeben - ohne Parameter. Kommt da die gleiche Fehlermeldung, dann ist da was bei der Installation gewaltig schief gelaufen. Das sollte aber nicht passiert sein, denn wenn du installierst, dann werden vorher die Checksummen geprüft und da sollten solche krassen Fehler auffallen. Wenn du wieder die Fehlermeldung "not a valid win32 application" bekommst, dann musst du postgres neu installieren. Also deinstallieren - kompletten Installationsordner unter c:\Programme löschen und dann neuinstallieren.

      2) Der Eintrag für den PgSQL-Dienst in der Registry ist defekt. Das sollte zwar auch nicht sein, kann aber noch einigermassen einfach korrigiert werden. Du kannst den Eintrag einfach mal im Registry-Editor suchen lassen. Vermutlich ist er unter:

      HKEY_LOCAL_MACHINE\SYSTEM\ControlSet\Services\<postgres>

      Wie genau der Eintrag <postgres> heisst weiss ich nicht. Musst einfach mal schauen, ob da irgendwas mit postgres steht. Oder einfach die Registry nach pg_ctl durchsuchen lassen. Alternativ kannst du natürlich auch gleich Postgres neu installieren (Installationsordner löschen nicht vergessen) und wieder neu installieren. Trotzdem wäre es mal interessant zu erfahren, was hier schief gelaufen ist.


      Ah ja und ein postgresql.log file wird irgendwie niht merh angelegt..find ich auf jeden fall nicht.
      Hmm, macht Sinn, nachdem Windows die Datenbank ja garnicht starten kann.

      Gruss,
      Alex
    • sirius
      sirius
      Bronze
      Dabei seit: 12.02.2006 Beiträge: 125
      k! besten dank für alles...hat leider nicht sollen sein! Hab jetz alles noch ma neu gemacht...Funktioniert nu wieder! Nur hab ich leider nur von meiner einen DB nen Backup gemacht.Mist und auch das funzt natürlich nicht merh da ich ja den kompletten Postgres-Ordner gelöscht hab?!..Das is echt ärgerlich alles! Nuja...

      MfG, sirius!
    • 1
    • 2