postgreSQL

    • cubaner
      cubaner
      Bronze
      Dabei seit: 05.03.2006 Beiträge: 4.245
      servus,

      ich habe ein riesen problem! kann kein postgre sql mehr benutzen was extrem nervt in verbindung mit pokertracker!

      hatte vor ein paar tagen ne fehlermeldung beim converten einer DB und habe postgreSQL deinstalliert und dann neu installiertm, aber damit fing das größere problem erst an!

      bei der installation kann ich psql nichtmehl als service insrtallieren, da ich dummerweise das passwort und den benutzernamen der erstinstallation nichtmehr weiß. habe schon alles mögliche probiert! ...wieder deinstalliert alle reste auf der platte (incl. registry!!!) gelöscht und es geht trotzdem nichtmehr es als service zu insatallieren.

      wenn ich den hacken "als service" insatallieren rausnehm kann ich es zwar installieren aber bekomms nicht impockertracker zum laufen,da mir PT bei "postgresql database functions" sagt "Error" blabla..... "could not connect to server"....


      kann mir jemand sagen wie ich das psql wieder zum laufen bekomm? denk schon an "format C: /D:/....." und windoof sowie alle software neu drauf (was sau aufwendig wäre) in der hoffnung es dann zum laufen zu bekommen.

      bin am verzweifeln und muss jetzt acces DB`s benutzen was nich so toll ist!
  • 27 Antworten
    • Stargoose
      Stargoose
      Bronze
      Dabei seit: 17.01.2005 Beiträge: 4.077
      Du mußt PostgreSQL deinstallieren, die Verzeichnisreste löschen und dann den User "postgres" von Hand entfernen.

      From the start menu select Run and then type COMMAND to open a DOS window, then try the command:

      net user postgres /delete

      Hit ENTER after you type the command to get it to run.
      Type EXIT to close the DOS window.


      Dann sollte PostgreSQL wieder problemlos zu installieren sein.

      Nebenbei bemerkt ist das Dein dritter Post zu diesem Thema !? Hast Du DIch denn wenigstens mal an den Pokertracker Support gewandt ?
    • cubaner
      cubaner
      Bronze
      Dabei seit: 05.03.2006 Beiträge: 4.245
      War im Pokertrackerforum und hab die lösungswege von denen probiert allerdings ohne erfolg.

      ich teste mal deine idee!
      Danke für die Hilfe!!!!

      !!! HAT GEKLAPPT!!!

      Riesen dankeschön! (und sorry wegen den 3 postings, aber das problem war akkut)
    • DiWa
      DiWa
      Bronze
      Dabei seit: 05.02.2006 Beiträge: 263
      Hallo Stargoose,

      insgesamt fast zwei Wochen tagtäglich mit Pockertracker Support gesprochen und gemailt, nix klappte.

      Wollte einen letzten Versuch wagen und habe die Postgres Datei gelöscht, das Postgres Programm auf c: / Programme etc entfernt habe alle Postgresordner gelöscht.

      Nun wollte ich noch den DOS-Befehl eingeben und postgres im DOS löschen, aber nun sagt er mir dass das nicht geht und er den Benutzernamen nicht kennt.

      Kannst du mir da vielleicht helfen? Will halt nochmal alles löschen und einen letzten Versuch unternehmen, Postgres zum Laufen zu bringen.

      MfG
    • Stargoose
      Stargoose
      Bronze
      Dabei seit: 17.01.2005 Beiträge: 4.077
      Schau mal unter "Systemsteuerung -> Verwaltung -> Computer Verwaltung" und dann "System -> Lokale Benutzer und Gruppen -> Benutzer" ob der User "postgres" existiert, bzw. welcher user dem "PostgreSQL service account" zugeordnet ist. Den dann wie oben beschrieben löschen ...
    • DiWa
      DiWa
      Bronze
      Dabei seit: 05.02.2006 Beiträge: 263
      Hallo Stargoose,

      Der Ordner Lokale Benutzer.. existiert nicht bei mir unter Computer Verwaltung -> System.
      Habe diesen ganzen Ordner durchsucht, dort ist nichts zu finden von PostgreSQL, einem user oder einem Postgres Service Account.
      Und nun?
      Bin echt am Verzweifeln, habe mir das gesamte Forum bei Pockertracker durchgelesen, habe mir dem Support gemailt, 10 mal jetzt schon installiert und deinstaliert, warum funktioniert das Prigramm bei mir nicht, habe die Installation step by step gemacht ohne etwas zu verändern.

      MfG
    • Stargoose
      Stargoose
      Bronze
      Dabei seit: 17.01.2005 Beiträge: 4.077
      Welches Problem hast Du denn genau bei der Installation ? Welche Windows Version ? Festplatte als NTFS formatiert ? Welche PostgreSQL Version ?
    • quertreiber77
      quertreiber77
      Bronze
      Dabei seit: 07.12.2005 Beiträge: 18
    • CElbe
      CElbe
      Bronze
      Dabei seit: 07.03.2005 Beiträge: 859
      Stargoose dir ist auch keine Art von Lösung bekannt mit Hilfe der man auch auf FAT32 POSTgreSQL installieren kann oder ? Mir ist es nicht möglich meine Platte auf NTFS zu konvertieren.
    • Stargoose
      Stargoose
      Bronze
      Dabei seit: 17.01.2005 Beiträge: 4.077
      Original von CElbe
      Stargoose dir ist auch keine Art von Lösung bekannt mit Hilfe der man auch auf FAT32 POSTgreSQL installieren kann oder ? Mir ist es nicht möglich meine Platte auf NTFS zu konvertieren.
      Nein. Sorry.
    • Stargoose
      Stargoose
      Bronze
      Dabei seit: 17.01.2005 Beiträge: 4.077
      Original von quertreiber77
      So weit ich weiß, sollte der Fehler damit zu beheben sein, den alten User "postgres" per DOS-Befehl (siehe oben) zu löschen, und dann noch einmal neu zu installieren. Bei der Installation bitte wirklich nichts verändern / eingeben außer dem Passwort.

      Irgendwo hab ich auch mal gelesen, das ne aktivierte Firewall das Problem verursachen kann. Weiß zwar nicht wie, wär aber vielleicht nen Versuch wert, die während der Installation mal zu deaktivieren.

      Ansonsten: support@pokertracker.com
    • quertreiber77
      quertreiber77
      Bronze
      Dabei seit: 07.12.2005 Beiträge: 18
      Tach.

      Es läuft endlich, hat zwar bißchen gedauert aber es hat geklappt.
      Der DOS-Befehl hat mir dann doch geholfen.
      Das Problem war, glaube ich, daß ich schon einmal PostgreSQL installiert hatte. Ich habe es zwar damals alles deinstalliert und regcleaner drüberlaufen lassen dies war aber wohl nicht genug. Der User muß von Hand gelöscht werden.

      @DiWa

      Prüfe erstmal ob den user "postgres" gibt.
      Start > Ausführen > command eingeben DOS-Fenster öffnet sich > dann erstmal nur net user eingeben.
      Dann kannst Du sehen welche Benutzerkonten auf Deinem PC gemeldet sind. Mit sehr grosser wahrscheinlichkeit ist auch der Eintrag mit "postgres" dort zu sehen. Findest Du nichts, solltest Du Dich fragen ob Du während der Installation von PostgreSQL nicht einen anderen Account- bzw. Superuser name verwendet hast.

      Sollte der Eintag "postgres" dort zu finden sein bzw. der Account bzw. Superuser name der (vielleicht) von Dir geändert wurde dann kannst diesen Problemlos löschen.
      Der DOS-Befehl wurde hier schon mehrfach erwähnt:
      net user postgres /delete
      (WICHTIG !!! Schreibweise und Leerzeichen beachten sonst erkennt DOS den Befehl nicht.)
      Wie gesagt, solltest Du etwas während der Installation geändert haben musst Du dann den anderen Namen eingeben. Nur lösche nicht Dein eigenes Benutzerkonto !!!

      Gruß
    • NattyDread
      NattyDread
      Bronze
      Dabei seit: 10.06.2006 Beiträge: 6.656
      Ich grabe mal diesen Thread wieder aus, wiel ich ein Problem mit posgres habe und es deinstallieren möchte. Nur wie kann ich dieses Programm komplett löschen? Ich hab es irgendwie nicht in meinem Startmenü drin, weil ichs in meine Eigenen Dateien installiert hab. Und in dem Ordner von postgres ist keine Datei zur Deninstallation drin. Wie mach ich das also? ßber Systemsteuerung und Software find ichs auch nicht, aber wenn ich versuch das neu zu installieren und auch den Tipp mit 'Ausführen', und dann command und dem folgenden Befehl postgres user delete (oder so) befolge, klappt die Neuinstallation nicht. Bitte helft mir!!!
    • NattyDread
      NattyDread
      Bronze
      Dabei seit: 10.06.2006 Beiträge: 6.656
      Könnte mal bitte einer ne Lösung dazuschreiben :rolleyes:
      Ich komm echt üebrhaupt nicht weiter und für die meisten in dem Forum ist dieses Problem doch ein Witz. Bitte schriebt doch mal schnell wie das geht!!!

      DANKE!!!! :D
    • Temar
      Temar
      Bronze
      Dabei seit: 14.07.2006 Beiträge: 536
      Original von NattyDread
      Ich komm echt üebrhaupt nicht weiter und für die meisten in dem Forum ist dieses Problem doch ein Witz. Bitte schriebt doch mal schnell wie das geht!!!
      Wenn du's unter Systemsteuerung->Software net findest, dann ist was bei der Installation schief gelaufen. Postgres macht bei der Installation im Prinzip drei Dinge:

      1) Daten nach c:\Pogramme\Postgresql-xx
      2) Windows Datenbank benutzer anlegen
      3) Registry Eintrag um den Service zu starten

      Um das ganze sauber zu deinstallieren musst du also alles wieder rückgängig machen.

      1) Start->Ausführen:regedit
      Hier musst du den Key HKLM\System\CurrentControlSet\Services\pgsql-xx löschen. Damit entfernst du den Service.

      2) Alten Benutzer löschen: Start->Ausführen: cmd -> "net user postgres /DELETE"
      Der Benutzer 'postgres' kann bei dir natürlich auch anders heissen.

      3) Installationsordner c:\Programme\Postgresql-xx löschen.

      Danach solltest du Postgres wieder installieren können. Wenn nicht, dann schreib doch mal die Fehlermeldung, die angezeigt wird.

      Gruss,
      Alex
    • NattyDread
      NattyDread
      Bronze
      Dabei seit: 10.06.2006 Beiträge: 6.656
      Also ich hab alles so gemacht wie du es gesagt hast, aber ich hab unter Ausführen, regedit die Datei nicht angezeigt bekommen, also hab ich den Schritt einfach weggelassen.
      Dann hab ichs neu runtergeladen und mit der Installation begonnen. Aber SQL hat meinen Namen wiedererkannt, was aber eigentlich nicht so schlimm ist, denn das eigentliche Problem kommt nur bei der Konvertierung. Ich hab also die Installation erfolgreich abgeschlossen, und auch in PT und posgresql Settings mein Passwort bestätigt.
      Doch wenn ich jetzt auf Convert database gehe und meine Datenbank auswähle, fängt PT für 1 sec an zu konvertieren und dann kommt folgende Fehlermeldung:



      Error connecting to the default postgreSQL database:

      210 - SQLSTATE = 28000
      FATAL: password authentication failed for user "posgres"



      This could be because you have...
      1. Entered the wrong user name/password/server name/port.
      2. Not started the PostgreSQL database server.
      3. Not installed the PostgreSQL ODBC driver.
    • Temar
      Temar
      Bronze
      Dabei seit: 14.07.2006 Beiträge: 536
      Original von NattyDread
      Error connecting to the default postgreSQL database:

      210 - SQLSTATE = 28000
      FATAL: password authentication failed for user "posgres"
      Da fehlt ein 't'. Der Benutzer lautet normalerweise "postgres".


      This could be because you have...
      1. Entered the wrong user name/password/server name/port.
      Das wird es sein. Bei der Installation werden zwei Benutzer angelegt:

      1) Ein Windows Benutzer mit zufälligem Kennwort.
      2) Ein Datenbank Benutzer mit einem Kennwort welches du festlegst.

      Du musst den Login und das Passwort vom DATENBANK Benutzer eingeben. Wenn du dich oben nicht vertippt hast, dann ist das fehlende 't' vermutlich der Grund.

      Gruss,
      Alex
    • NattyDread
      NattyDread
      Bronze
      Dabei seit: 10.06.2006 Beiträge: 6.656
      Daran liegts auch nicht, weil ich
      1. Die Fehlermeldung per Hand abgeschrieben habe und mich nur vertippt habe :P . In PT ist das t drin.
      und 2. ich das von mir festgelegte Passwort verwende.

      Meine Idee wäre noch, dass es nicht erlaubt ist, ein Passwort mit ü zu verwenden. Aber warum finde ich über regedit die von dir genannte Datei nicht?

      Kannst du mir mir vielleicht nochmal helfen?

      Aber schonmal danke für die Mühe, die du dir gemacht hast :heart: :heart: :heart:
    • Temar
      Temar
      Bronze
      Dabei seit: 14.07.2006 Beiträge: 536
      Original von NattyDread
      Meine Idee wäre noch, dass es nicht erlaubt ist, ein Passwort mit ü zu verwenden.
      PT stellt doch die Spracheinstellungen auf Englisch um. Wenn es das auch mit der Tastatur macht, dann kannst du natürlich lange Umlaute eingeben.


      Aber warum finde ich über regedit die von dir genannte Datei nicht?
      Entweder, weil du vorher PostgreSQL sauber deinstalliert hast oder aber weil:
      HKLM = HkeyLocalMachine

      Sobald du Postgres drauf hast, muss es einen Eintrag in der Registry für den Service geben.

      Gruss,
      Alex
    • NattyDread
      NattyDread
      Bronze
      Dabei seit: 10.06.2006 Beiträge: 6.656
      Also ich hab jetzt diese eine Datei gefunden und nach deiner Anleitung posgres komplett deinstalliert. Aber bei der neuen Installation steht wieder mein alter Account name bei der Installation und PSQL hat sich auch das Passwort gemerkt, obwohl ich doch den User gelöscht habe. Muss man wenn man cmd -> net user postgres/delete eingibt irgendwas beachten?
    • 1
    • 2