PO auf einmal extrem langsam

    • SiMoNsayZpkR
      SiMoNsayZpkR
      Silber
      Dabei seit: 25.04.2006 Beiträge: 1.108
      Hi,

      ka was los ist, spiele den ganzen tag 8-tabling und auf einmal ist alles am laggen, meine maus zuckt mit 2fps übern bildschirm und ich kann unmöglich weiterspielen. ram-booster installiert, neu gestartet, pc-lüfter schneller gestellt, nix hat gehilfen. CPU ist total ausgelastet.
      Habe ich bei PO die magische grenze überschritten?
      Habe die datenbank in mysql 4.1 vorliegen, mit Jasmin87 tip schneller gemacht.
      Der pokeroffice Ordner im MySqlserver/data verzeichnis ist 217mb groß.

      Wenn ich das table overlay weglasse gehts, ist die perfomance wieder da.
      Habe in den perfomance settings von PO exclude always onw player stats, sowie refresh rate fürs overlay auf 5 hände gestellt.

      Brauch ich nen schnelleren cpu? Hab AMD XP 3.2 + 1gb ram und s-ata festplatte.

      kann ich alle stats von 0,5/1 in ne neue database reinkopieren?

      edit: database backup ist 38mb groß. also ~38k hände in der databse. das ist doch NIX?!
  • 15 Antworten
    • DiGiT79
      DiGiT79
      Bronze
      Dabei seit: 12.06.2006 Beiträge: 23
      ne,das is auch eigentlich NIX....

      mal versucht java upzudaten ? damit hatten einige bei solchen probleme schon gute erfahrungen...
    • umlenker
      umlenker
      Bronze
      Dabei seit: 02.03.2006 Beiträge: 32
      hatte das problem immer dann wenn ich po erst gestartet hab nachdem schon tables offen waren, auch wenn ich nicht dran gesessen bin. keine ahnung warum, aber ich öffne immer zuerst po und seitdem nie wieder ein problem gehabt
    • Mikky007
      Mikky007
      Bronze
      Dabei seit: 22.03.2006 Beiträge: 447
      @SiMoNsayZpkR

      ..mir geht es genauso! Aber manchmal geht es und manchmal nicht! Woran das liegt, hab ich noch nicht raus gefunden.
      Habe auch nach Jasmins Tip die Datenbank optimiert. Hat nichts geholfen. Teilweise war es so schlimm, dass ich über PO nur noch geflucht habe.
      Ich hab auch nur noch das Overlay laufen, ohne livetracker. Hilft aber auch nicht.
      Hab jetzt meine 500$ Rake durch und werde demnächst PT/PA antesten. Wenn die Performance besser ist werde ich darauf wechseln!

      Bei PO finde ich ich aber die Playermoves sehr, sehr hilfreich. Und den Replayer! Soll es ja bei PT/PA nicht geben. :(

      Werde mal umlenkers tip versuchen.


      edit: ach ja, im PO-Forum hab ich gelesen, dass PO Schwierigkeiten mit einem bestimmten Logitech-Maus-Treiber hat. Ich hab eine Logitech-Wireless Maus. Werde mal eine andere anschliessen und schauen, ob sich was ändert.
    • lvcc
      lvcc
      Bronze
      Dabei seit: 19.02.2006 Beiträge: 395
      Original von Mikky007
      edit: ach ja, im PO-Forum hab ich gelesen, dass PO Schwierigkeiten mit einem bestimmten Logitech-Maus-Treiber hat. Ich hab eine Logitech-Wireless Maus. Werde mal eine andere anschliessen und schauen, ob sich was ändert.
      Dann vergiß aber nicht, den Logitech-Treiber zu deinstallieren, sonst bringt dir das gar nix...


      Mike
    • SiMoNsayZpkR
      SiMoNsayZpkR
      Silber
      Dabei seit: 25.04.2006 Beiträge: 1.108
      hab ne MX510 von logitech mit den neuesten treibern.
      Habe DiGiT79's und umlenker's tip ausprobiert und heute ging 8 Tabling ohne Ruckler - extrem angenehm.
      Habe gestern, mich im upswing befindend nicht aufgehört und mich total von dem ruckeln abstressen lassen und den kompletten up innerhalb 20 min rausgehauen. freue mich auch auf PT/PA ^^
    • Mikky007
      Mikky007
      Bronze
      Dabei seit: 22.03.2006 Beiträge: 447
      Original von SiMoNsayZpkR
      Habe DiGiT79's und umlenker's tip ausprobiert und heute ging 8 Tabling ohne Ruckler - extrem angenehm.
      Ah, gut zu wissen! Werde das heute abend auch mal versuchen!


      @ Mike, yo....und klar, Treiber deinstallieren. Muss mir aber erst einmal ne neue Maus holen.
    • iccee
      iccee
      Bronze
      Dabei seit: 02.04.2006 Beiträge: 599
      hab ne neue logitech maus. die mx610.
      und die neue software von logitech (SetPoint heißt die) verbraucht doch tatsächlich auch schon beim normalen rumfahren mit der maus bis zu 20% cpu! so ein schei* stück software hab ich noch nie gesehen... (mich als programmierer bringt solch billig-schlechte software oft auf tilt...).
      mit PO hatte ich aber noch nie probleme in bezug mit der maus.

      man sollte also das programm/treiber einfach beenden (in der systray rechtsklick drauf und beenden), dann wird auch keine unnötige cpu mehr verbraucht. allerdings kann man dann nicht mehr all die 2 millionen tasten auf der maus verwenden; es funktionieren nur mehr die 'standart-tasten'.

      man kann auch den autostart von der software entfernen (per zb. msconfig oder jv16 powertools) damit der dreck nicht jedesmal bei systemstart reingeladen wird.
    • SiMoNsayZpkR
      SiMoNsayZpkR
      Silber
      Dabei seit: 25.04.2006 Beiträge: 1.108
      ok, eben hat wieder alles ENORM gelaggt
      hab jetzt Jasmin87's tip erweitert, indem ich noch mehr indexes erstellt habe, hauptsächlich die, die mit meinem overlay zusammenhängen, immoment schauts gut aus!
      habe overlay refresh auf 7 hände gestellt.
    • Mikky007
      Mikky007
      Bronze
      Dabei seit: 22.03.2006 Beiträge: 447
      wasn shice...
      Hat alles nichts gebracht. :(
      Hab diesmal PO zuerst gestartet. Am Anfang war es auch ok. Hatte mich schon gefreut. Nachher jedoch wieder.........bäh!
    • ozoon
      ozoon
      Bronze
      Dabei seit: 20.02.2006 Beiträge: 1.192
      @Mikky, versuch mal ein neues java zu installieren, adnn installiere noch po 2.11 update. vielleicht brings etwas
    • SiMoNsayZpkR
      SiMoNsayZpkR
      Silber
      Dabei seit: 25.04.2006 Beiträge: 1.108
      gestern beim kumpel gezockt der pt und ah hatte. was für ne wohltat !!!
    • Mikky007
      Mikky007
      Bronze
      Dabei seit: 22.03.2006 Beiträge: 447
      Java hab ich die neueste Version. 1.5. update 07 oder so.
      Versuch da aber nochmal zu deinstallieren und java neu aufzuspielen.
      Will ja nichts unversucht lassen. Werde berichten, falls sich was ändert. Kann ja so nicht weiter gehen.
    • Quatschy
      Quatschy
      Bronze
      Dabei seit: 13.05.2006 Beiträge: 601
      Gibts bei Java eigentlich wo ne Einstellung, das es sich imma selber updaten tut, wenn ein neues Update raus ist?
    • iccee
      iccee
      Bronze
      Dabei seit: 02.04.2006 Beiträge: 599
      ich glaub, daß ein java update nicht viel bringt, da PO mit seiner 'eigenen' java-runtime läuft (die javaw.exe mit der PO läuft steht auch im PO Programmverzeichnis), da der Programmierer so wohl bezüglich der kompatibilität auf der sicheren seite ist; so läuft nur die java-runtime version mit der er auch getestet hat.

      versucht mal nicht nur den DB Optimize sondern defragmentiert auch mal die Festplatte. es hilft nix wenn die DB optimal organisiert ist und sich ein datenfile über zig-tausend fragmente auf der platte verteilt.
      und mit zuvielen zusätzlichen Indizes würd ich auch aufpassen, weil PO ja auch nach jeder hand in die datenbank schreibt - und bei zuvielen Indizes dauert das dann noch viel länger.
    • Mikky007
      Mikky007
      Bronze
      Dabei seit: 22.03.2006 Beiträge: 447
      Bin auf PT/PA umgestiegen!
      Viel bessere Performance, so macht das wieder Spaß! Hände importieren geht auch viel schneller.
      ...nur die Player-Moves werde ich vermissen.