MS Excel: Wenn Abfrage - Bedingung: Zelle leer

    • tomsnho
      tomsnho
      Bronze
      Dabei seit: 24.11.2006 Beiträge: 7.565
      Ich möchte bei einer Excel-Tabelle, dass nur sofern eine bestimmte Zelle (in dieser Zeile) leer ist, dass dann die Formel zu tragen kommt - also konkret, falls ich in B5 nichts reinschreib, soll J5 = J4 + D5, ansonsten J5 = J4. Wie krieg ich hin dass es erkennt ob die Zelle leer ist ob da irgendwas drinsteht.

      code:
      WENN(B5="", J4 + D5, J4)
      funktioniert da mal nicht, da kommt immer eine Fehlermeldung. Gibt's irgendein Schlüsselwort oder -symbol à la "LEER" oder "VOID" oder sowas, dass man hier reinschreiben müsste?
  • 3 Antworten
    • wettongl
      wettongl
      Bronze
      Dabei seit: 14.05.2007 Beiträge: 1.000
      also ich sehe da keinen Fehler. Bin mir nicht sicher, aber hast du ein Leerzeichen zwischen den beiden "" in der Bedingung stehen?

      aber ein =WENN(B5="";D4+J5;D4) sollte eigentlich funzen. Die Formel ist so korrekt.

      Noch ne Idee:
      Damit dir B5="" auch eine Zelle als leer erkennt, darf aber auch keine Formel in B5 stehen, die als Ergebnis "" liefert ;) Denn dann ist die Zelle ja nicht leer.
    • Koenigswurst
      Koenigswurst
      Bronze
      Dabei seit: 30.12.2006 Beiträge: 261
      Habs grad auch ausprobiert, mit =WENN(B5=""; J4 + D5; J4) gehts bei mir auch. Mit B5=0 würde es auch gehen, glaub aber nicht, dass das was ändert.
    • tomsnho
      tomsnho
      Bronze
      Dabei seit: 24.11.2006 Beiträge: 7.565
      Danke für die Mühe!

      Ich Idiot hab den falschen Fehler reingestellt, hab nur einen Teil der tatsächlichen Formel
      code:
      WENN(ODER(B5="", B5="blabla"), J4+D5, J4)
      angegeben.

      Dooferweise hab ich nicht das sondern
      code:
      WENN(B5="" ODER B5="blabla", J4+D5, J4)
      geschrieben und bin davon ausgegangen dass das scheiß ODER korrekt ist und es am "" liegt :(

      Immerhin bin ich durch euren Hinweis draufgekommen dass es definitiv nicht am "" liegt sondern der Fehler wo anders liegen muss :D


      @mods: Kann nun geclost werden, Problem ist behoben =)