Problem mit T-Com Webspace und Mambo CMS

    • DonMB
      DonMB
      HeadAdmin
      HeadAdmin
      Dabei seit: 25.06.2006 Beiträge: 4.945
      Hi, ich hab ein Problem bei der Installation von einer Mambo CMS Software auf dem T-Com Webspace.
      Zunächst einmal: die Funktion phpinfo() ist bei denen standardmäßig deaktiviert und ich musste den absoluten Pfad zu meinen Dateien manuell mit

      echo $path=$_SERVER["DOCUMENT_ROOT"]


      herausfinden, was auch geklappt hat.
      Dann der "Schock", der Pfad zu meinen Dateien lautet:

      \\fe-dm01b-11.wdhs.local\WS004_001\pool101\ .... usw usw

      an den "Slashes" kann man denk schon erkennen dass hier Windows, und keine Unix Server laufen.
      Problem ist nun, wenn ich das CMS ausführen will mit dem oben angegebenen Pfad in der Konfigurationsdatei hagelt es Fehlermeldungen, u.a.

      Warning: main(): Unable to access \\f\fe-dm01b-11.wdhs.local\WS004_001\[.......]\WEB\homepage\itg-braun/includes/version.php in \\fe-dm01b-11.wdhs.local\WS004_001\pool101\[.......]\WEB\homepage\itg-braun\includes\mambo.php on line 27


      Siehe "Slashes" und "Backslashes" sind vermischt... was ja logisch ist da das Skript den absoluten Pfad übernimmt und dann plötzlich ist die Struktur wieder Unix oder was?

      Bin völlig ratlos und hab keinen Plan wie ich das installieren soll. Google hat mir auch nicht geholfen, vielleicht weiß jemand hier Rat.

      Danke schonmal.
  • 2 Antworten
    • pistenstuermer
      pistenstuermer
      Bronze
      Dabei seit: 05.10.2007 Beiträge: 1.564
      Wieso musst du da den absoluten Pfad rausfinden? Macht das das Setup-Skript nicht automatisch? Davon abgesehen würde ich Joomla nehmen, das ist Mambo, nur 100mal besser und Open Source.
    • DonMB
      DonMB
      HeadAdmin
      HeadAdmin
      Dabei seit: 25.06.2006 Beiträge: 4.945
      Mambo ist auch Open-Source und leider hab ich keine Alternative weil das eine bereits fertige Homepage ist die ich auf nen anderen Server, hier: T-Com, umziehen muss.

      Im Konfigurationsskript muss ich

      $mosConfig_absolute_path =
      $mosConfig_live_site =


      angeben was den absoluten und relativen Pfad darstellt. Wie gesagt, absoluter scheint eine Windows-Verzeichnisstruktur zu sein und der relative Pfad ist Unix !?