Absturz beim HUD nach Hand-Import

    • Reo
      Reo
      Bronze
      Dabei seit: 22.09.2006 Beiträge: 860
      Hallo,

      folgendes Problem:
      Ich habe mir hier aus dem Forum einige Hände heruntergeladen. Diese hab ich in den Elephant importiert. Dauerte mehr oder weniger lange.

      Nachdem ich das gemacht habe ist mir aufgefallen, dass ich keine Anzeigen mehr auf dem Tisch habe. Ich habe etwas in dne Einstellugnen des Elephant geschaut und gesehen, dass unter "Hud Einstellungen" der Haken bei "Hud aktivieren" nicht vorhanden ist.

      Wenn ich diesen nun aktiviere bekomme ich einen Absturz sobald ich einen Pokertisch öffne.

      Ich habe auf beiden Rechnern das gleiche Problem. Windows XP auf Laptop und Windows Vista 64-bit auf meinem Hauptrechner.

      Wo könnte das Problem liegen?
  • 7 Antworten
    • Reo
      Reo
      Bronze
      Dabei seit: 22.09.2006 Beiträge: 860
      Da ich nur noch Abstürze hatte, habe ich nun folgende Schritte durchgeführt.

      PP beendet, Elephant gestartet, DB gelöscht, neu erstellt und nochmal alle eigenen Hände importiert.

      Das ging soweit. Doch jetzt bekomme ich überhaupt kein HUD mehr.
      Wenn ich PP starte und einen Tisch öffne, so stürzt der Elephant nicht mehr ab, aber ich bekomme auch keine Anzeigen. Auch die Anzeige auf dem Dealer kommt nicht mehr.
      Ich denke, dass evtl. die Tische nicht mehr erkannt werden. Ein "HUD-Test" geht auch nicht. (in den HUD-Einstellungen). Der Haken bei "HUD aktivieren" ist natürlich drin. Auch ein- und ausschalten hilft nicht.


      Werde dann wohl jetzt erstmal ohne HUD weitermachen und weiterhin Fehler melden, wenn welche auftreten.
      Da ich aber bis Freitag noch unterwegs bin, werde ich das Testen eher eingeschränkt durchführen. Am WE bin ich wieder voll da und werde auch gerne ausführlicher auf die Fehler eingehen.
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Kannst du dich bzgl. der Freezes einfach mal an den Skype-Account wenden?

      Gruß Sebastian
    • Reo
      Reo
      Bronze
      Dabei seit: 22.09.2006 Beiträge: 860
      Ich bin bis zum Wochenende noch unterwegs, da ist das ungünstig.

      Aber ich kann mich am Freitag nochmal melden. Werde es dann nochmal ausführlich testen und dann kann ich mich an den Support werden.
      Habe eben 0.44 installiert, die DB nochmal neu eingelesen und bis jetzt geht es. Hab aber auch erst meine eigenen Hände und ein paar Tausend aus dem Forum eingelesen. Noch nicht die 1,6 Mio, die ich runtergeladen habe.
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      1.6 Mio können übrigens nen bissl dauern, PT braucht dafür aber Tage;)
    • Reo
      Reo
      Bronze
      Dabei seit: 22.09.2006 Beiträge: 860
      Ja, der Import hat ein paar Std gedauert, aber das ist nicht das Problem.
      Das Problem ist eben, dass es zu einem Absturz kommt, wenn ich einen Tisch bei PP öffne und das HUD anzeigen lassen möchte.

      Ich melde mich dazu nochmal am WE im Forum / per Skype.
    • Reo
      Reo
      Bronze
      Dabei seit: 22.09.2006 Beiträge: 860
      Hab jetzt v0.46 und habe vorher nochmal alle Daten aus der DB gelöscht.

      Der Import von 700k Händen war problemlos, also keine Abstürze des HUD.
      Werde gleich mal die anderen 900k Hände einlesen und schauen, ob es danach auch noch geht oder wieder der Absturz auftritt.

      Das Problem mit dem aktuallisieren der Daten ist ja bereits in einem anderen Thread mitgeteilt. Den habe ich natürlich weiterhin.
    • Reo
      Reo
      Bronze
      Dabei seit: 22.09.2006 Beiträge: 860
      So, hier nun mein Erfahrungsbericht.

      In der Version 0.46 passieren keine Abstürze mehr, auch wenn man knapp 1,7 Mio Hände in der DB hat. Keine Ahnung, was ihr geändert habt, aber es geht.

      Es gibt aber ein Performance-Problem mit so vielen Händen.

      Wenn ich bei PP spiele, dann funktioniert alles gut. Wenn aber die Daten aktuallisiert werden (weil neue, aktuell gespiele Hände eingelesen werden), dann laggt es ziemlich stark bei PP. Ich habe teilweise 2-3 Sek, in denen ich nichts mehr auf PP machen kann. Es werden keine Karte verteilt, keine Buttons angezeigt.
      Nach einem Lag geht es dann wieder eingermaßen, bis zum nächsten Mal ein Update der Datenbank gemacht wird.

      Da ich ja zusätzlich noch das Problem habe, dass die Daten der aktuellen Tische nur sehr unregelmäßig aktuallisiert werden, kommt es ziemlich selten vor. Wenn es aber bei jeder Hand zu diesen Lags kommt, dann wird es unspielbar.

      Da müsst ihr dringend noch was an der Performance machen. Hab ich aber auch schon in einem anderen Thread geschrieben.


      Soweit zu diesem Problem, welches nun keins mehr ist, weil der Fehler nicht mehr auftritt.