postre sql geht nicht zu installieren

  • 34 Antworten
    • LockMann
      LockMann
      Bronze
      Dabei seit: 07.02.2008 Beiträge: 2.323
      Hi,

      das gleiche Problem habe ich auch. Wenn ich eine Datenbank erstellen will kann keine Verbindung zum Datenbankserver hergestellt werden. Genauer gesagt erscheint dann immer folgender Text:

      Es konnte keine Verbindung zum Datenbankserver aufgebaut werden!

      Erweiterte Informationen:

      Faild to establish a connection to '127.0.0.1'.


      Ich bin mir zu 100% sicher, dass mein Username und mein Passwort stimmen. Es würde mich freuen, wenn mir einer eine Lösung auf das Problem geben könnte.

      Viele Grüße,
      LockMann
    • promoe
      promoe
      Bronze
      Dabei seit: 21.04.2006 Beiträge: 1.694
      Ich geh mal davon aus, dass ihr windows XP benutzt?
      Habt ihr adminrechte?
    • IronPumper
      IronPumper
      Coach
      Coach
      Dabei seit: 03.01.2008 Beiträge: 14.843
      Könntest du vielleicht mal kurz beschreiben, wie man bei Windows XP Adminrechte einstellen kann bzw. wie man herausfindet, ob man Adminrechte hat?

      Wär echt nett! :club:
    • promoe
      promoe
      Bronze
      Dabei seit: 21.04.2006 Beiträge: 1.694
      Um es erstmal einfach zu machen :D

      Wenn ihr den PC startet und windows XP hochfährt, wählt ihr nen user im willkommen screen oder startet das Betriebssystem ohne weitere Eingabe (bzw. Mausklick) sofort?
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Original von LockMann
      Hi,

      das gleiche Problem habe ich auch. Wenn ich eine Datenbank erstellen will kann keine Verbindung zum Datenbankserver hergestellt werden. Genauer gesagt erscheint dann immer folgender Text:

      Es konnte keine Verbindung zum Datenbankserver aufgebaut werden!

      Erweiterte Informationen:

      Faild to establish a connection to '127.0.0.1'.


      Ich bin mir zu 100% sicher, dass mein Username und mein Passwort stimmen. Es würde mich freuen, wenn mir einer eine Lösung auf das Problem geben könnte.

      Viele Grüße,
      LockMann
      Läuft der Prozess postgres.exe? Falls nein mal über Start -> Programme -> PostgreSQL 8.3 -> Start Service starten.

      Gruß Sebastian
    • LockMann
      LockMann
      Bronze
      Dabei seit: 07.02.2008 Beiträge: 2.323
      Hi,

      also der Prozess postgres.exe läuft bei mir nicht. Manuell kann ich den Prozess auch nicht starten, da sich im PostgreSQL 8.3-Verzeichnis nur ein tmp-Ordner befindet, der wiederum nur eine log-Datei enthält. Also existiert gar keine exe-Datei mit der ich den PostgreSQL-Service starten könnte.
      Ich vermute, dass die Installation nicht korrekt abgelaufen ist, bzw. dass PostgreSQL garnicht erst installiert wurde. Evtl. könnte es daran liegen, dass auf meinem Rechner schon "Microsoft SQL Server 2005" installiert ist.
      Meinst du das könnte der Grund sein, sprich soll ich "Microsoft SQL Server 2005" einfach mal deinstallieren und dann PostgreSQL nochmals neu installieren?

      Viele Grüße,
      LockMann
    • mchl505
      mchl505
      Bronze
      Dabei seit: 15.11.2007 Beiträge: 61
      Original von promoe
      Ich geh mal davon aus, dass ihr windows XP benutzt?
      Habt ihr adminrechte?
      ich habe windows vista....und an die anderen: Postresql geht gar nicht erst zu installieren wie soll ich dann die datei postgres.exe öffnen
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Dann hat bei euch die Installation nicht funktioniert. Am besten unsere Deinstallationsanleitung befolgen: How-To: Deinstallation von PostgreSQL und anschließend das Setup aus dem Elephant-Verzeichnis mit Administratorrechten nochmal starten (Ausführen als...)
    • promoe
      promoe
      Bronze
      Dabei seit: 21.04.2006 Beiträge: 1.694
      Ok ich kenn mich mit Windows Vista überhaupt nicht aus :)
      Ich meine aber so halb zu wissen, dass man bei Vista per se keine Adminrechte hat. Du musst mal im Netz recherchieren wie du Dir diese Rechte besorgen kannst. Ich denke mal das Prob ist, dass das Prog direkt auf die Hardware zugreifen will und ohne Adminrechte wird das etwas schwierig.
      Falls es das bei Vista noch gibt kannst auch versuchen im agesicherten Modus zu installieren. Das dürfte mit ziemlicher Sicherheit gehen, aber ob das Prog nach einmaliger Installation dann ohne Adminrechte läuft weiss ich auch nicht. Dafür müsstest Du dir wohl auch angucken wie du dir die Rechte besorgen kannst.

      Ansonsten, falls es das bei Vista noch gibt kannste mal beim control panel gucken, obs das noch sowas wie "user accounts" bzw "Benutzerkonten" gibt. Da kann man normalerweise auch sehen, was für Rechte man als user hat (at least bei XP)
    • LockMann
      LockMann
      Bronze
      Dabei seit: 07.02.2008 Beiträge: 2.323
      Also bei mir läuft der Elephant jetzt. Ich hab mir einfach PostgreSQL heruntergeladen und das dann manuell installiert. Der Elephant hat sich nicht beschwert und läuft bestens.

      Gruß,
      LockMann
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Noe warum sollte er auch ;) Wir wollten euch mit der automatischen Installation nur arbeit erspraren ;)

      Gruß Sebastian
    • GasPanic
      GasPanic
      Bronze
      Dabei seit: 02.06.2008 Beiträge: 579
      Original von LockMann
      Hi,

      das gleiche Problem habe ich auch. Wenn ich eine Datenbank erstellen will kann keine Verbindung zum Datenbankserver hergestellt werden. Genauer gesagt erscheint dann immer folgender Text:

      Es konnte keine Verbindung zum Datenbankserver aufgebaut werden!

      Erweiterte Informationen:

      Faild to establish a connection to '127.0.0.1'.


      Ich bin mir zu 100% sicher, dass mein Username und mein Passwort stimmen. Es würde mich freuen, wenn mir einer eine Lösung auf das Problem geben könnte.

      Viele Grüße,
      LockMann

      Bei mir genau das selbe. Bei der Installation von PostgreSQL kommt der oben erwähnte Fehler. Bei jeder weiteren Neuinstallation vom Elephant kommt dann aber nicht mehr die Option PostgreSQL zu installieren, sondern er will gleich das Passwort für die Datenbank haben. Das aber logischerweise nicht existiert, da die Installation ja mit der Fehlermeldung abgebrochen ist.

      Hab dann auch versucht PostgreSQL manuell zu installieren, aber da blick ich nicht so recht durch. Wie kann ich da eine Datenbank erstellen, die der Elephant dann erkennt?

      Hab Vista x64 Enterprise SP1. Admin-Rechte sind auch vorhanden.
    • LockMann
      LockMann
      Bronze
      Dabei seit: 07.02.2008 Beiträge: 2.323
      Hi GasPanic,

      es ist klar, dass die Option für eine Installation von PostgreSQL nicht mehr bei jeder Neuinstallation des Elephants zur Auswahl steht, denn beim Deinstallieren vom Elephant wird PostgreSQL nicht entfernt. Wenn du also jetzt PostgreSQL manuell installieren willst, musst du zuerst die ganzen Überbleibsel von PostgreSQL deinstallieren. Hier genau erklärt.
      Wenn du jetzt PostgreSQL manuell installieren willst, musst du einfach nur deine heruntergeladene Datei ausführen und ohne irgendwelche abweichungen von den Empfehlungen beim Setup folgen. Dann kommt irgendwann in der Installation der Punkt in dem du dir ein Username und ein Kennwort aussuchen musst, um auf den Datenbankserver zuzugreifen. Dieser Schritt ist im Prinzip genau der, den du auch bei dem automatischen PostgreSQL Setup über den Elephant gemacht hast. Hast du nun einen Benutzernamen und ein Passwort, sollte die Installation auch schon zu Ende sein und du kannst den Elephant starten. Dann wirst du auch direkt aufgefordert eine neue Datenbank anzulegen und gibst dann eben deine Kombination aus Benutzername und Passwort ein.
      Das wars auch schon.

      Gruß,
      LockMann
    • GasPanic
      GasPanic
      Bronze
      Dabei seit: 02.06.2008 Beiträge: 579
      Ich hab´s mittlerweile hinbekommen. Hatte mich eigentlich an den Deinstallationsguide gehalten, aber irgendwas hat da wohl nicht richtig funktioniert. Bei der manuellen Installation wusste ich erst nicht, was das mit dem User-Account sollte, aber das hat sich jetzt geklärt.


      Dank Dir für deine Erklärungen.
    • mchl505
      mchl505
      Bronze
      Dabei seit: 15.11.2007 Beiträge: 61
      Original von LockMann
      Also bei mir läuft der Elephant jetzt. Ich hab mir einfach PostgreSQL heruntergeladen und das dann manuell installiert. Der Elephant hat sich nicht beschwert und läuft bestens.

      Gruß,
      LockMann
      wie geht das manuell zu intallieren??

      wenn ich postresql heurnterlade is da nie ne setup datei dabei oO :_(

      Edit:

      welches von den files muss ich saugen und installieren / öffnen ??

      1)postgresql-8.3.3.tar.bz2 postgresql-8.3.3.tar.bz2 2008-06-11 17:23:35 13.4 MB

      2)postgresql-8.3.3.tar.bz2.md5 postgresql-8.3.3.tar.bz2.md5 2008-06-11 17:23:34 66 bytes

      3)postgresql-8.3.3.tar.gz postgresql-8.3.3.tar.gz 2008-06-11 17:23:34 16.7 MB

      4)postgresql-8.3.3.tar.gz.md5 postgresql-8.3.3.tar.gz.md5 2008-06-11 17:23:32 65 bytes

      Edit2:

      ich habe nr3. heruntergeladen und versucht zu installieren, aber der pc will immer das ich ein programm aussuche mit welchem die installation durchgeführt werden soll oO

      Hilfe?!?!
    • tobox
      tobox
      Bronze
      Dabei seit: 20.01.2007 Beiträge: 444
      http://ftp.de.postgresql.org/mirror/postgresql/binary/v8.3.0/win32/postgresql-8.3.0-1.zip
    • mchl505
      mchl505
      Bronze
      Dabei seit: 15.11.2007 Beiträge: 61
      manuell installieren ging auch net kam immer irgendein fehle...ich gebs langsam auf -.-

      das mit den adminrechten funktioniert bei mir auch net -__-
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Tjo du solltest schon lesen was wir schreiben... Ohne Adminrechte brauchst du die Installation gar nicht erst versuchen. Wenn du mit der rechten Maustaste auf das Setup gehst, sollte dort sowas stehen wir "ausführen als" o. ä. Das einfach mal machen und schaun obs geht...
    • mchl505
      mchl505
      Bronze
      Dabei seit: 15.11.2007 Beiträge: 61
      Ich habe jetzt die adminrechte und postgres versucht manuell zu installieren weil er das bei der installetion von elephant irgendwie nicht macht.

      Doch jetzt kommt kurz vor ende der installation diese Meldung:

      Interner Fehler bei Suche nach Benutzerkonto: Zuordnung von Kontennamen und Sicherheitserkennungen wurden nicht durchgeführt

      Warum wird bei meiner installation von elephant auch nicht postgrs automatisch installiert??

      dann noch ne frage.

      Ich hab nen neuen Pc, auf dem alten lief Elephant + Datenbank schon, soll ich vlt bei der eingabe der datenbank bei elephant einfach die alte nehemen ? geht das?
    • 1
    • 2