Was will der Elephant in der DB 'postgres'?

    • Mandos
      Mandos
      Bronze
      Dabei seit: 10.10.2006 Beiträge: 263
      Hi,

      ich versuche gerade, Elephant 0.50 mit PostgreSQL 8.1 auf meinem Linuxserver zu verbinden. Wenn ich auf "Datenbankeinstellungen testen..." klicke, meldet er eine erfolgreiche Verbindung zur Datenbank "elephant". Wenn ich jetzt jedoch auf "OK" klicke, kommt:

      FATAL: 28000: no pg_hba.conf entry for host "11.22.33.44", user "mandos", database "postgres", SSL off

      Jetzt also meine Frage, wieso will der Elephant auf die DB "postgres" zugreifen? Meines Erachtens hat er da nichts zu suchen...

      SSL-Unterstuetzung waere natuerlich cool (noch besser Kerberos-Unterstuetzung, aber da bin ich wahrscheinlich der einzige auf ganz ps.de, den das interessiert).
  • 3 Antworten
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Hi,

      ja ich denke auch das daran nicht viele intersse haben ;) . Was er genau da will kann ich dir nicht sagen, wenns dich interessiert kann ich aber mal nachfragen. Leider braucht der Elephant einen postgreSQL 8.3 Server sodass du mit deinem 8.3 wohl nicht soviel Erfolg haben wirst.

      Gruß Sebastian
    • Mandos
      Mandos
      Bronze
      Dabei seit: 10.10.2006 Beiträge: 263
      Joa, wuerd mich schon interessieren, weil ich gerne möglichst wenig von aussen zugänglich mache. Ausserdem würde mich mal interessieren welche 8.3 oder überhaupt 8.x-spezifische Features der Elephant benutzt. Ich meine...

      http://www.postgresql.org/docs/8.3/static/release-8-3.html

      ...da sind zwar schon schöne Performanceoptimierungen und so dabei, aber ich hab jetzt nichts gesehen was es irgendwie einfacher machen würde eine Anwendung wie den Elephant zu schreiben...
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Nujo ich kann dir leider nur das sagen was ich weiß. Welche Gründe da für diese Entscheidung sprechen weiß ich nicht, so tief stecke ich in den ersten Entwicklungsdetails nicht drin. Ich kann dir halt nur sagen das ich weiß, das es mit älteren Version nicht richtig funktioniert, du kannst es aber gerne probieren...

      Gruß Sebastian