Einige Probleme mit Postgres

    • esquilo
      esquilo
      Bronze
      Dabei seit: 24.03.2008 Beiträge: 406
      Hab mir grad den Elefanten runtergeladen und versucht Postgre zu installieren. Hab mir sogar das Video dabei angeschaut um ja nix falsch zu machen.
      Hab also einen Name und ein Passwort eingegeben. Dann kam kurz vor Schluss die Meldung, dass dieser Benutzername schon existiert und die Insatallation wurde abgebrochen. Habs dann einfach nochma versucht. Jetzt soll ich immer eine Datenbank angegeben (obwohl die eben noch nicht existiert) und wenn ich irgendwas eingebe oder wenn ich die "Datenbankeinstellungen teste" bekomme ich eine Meldung, nach der der Verbindungsaufbau gescheitert ist. Wie kann ich die Datenbank nun konfigurieren?
      Hab auch schon den Elefanten neu installiert aber das Problem bleibt bestehen. Hab auch schon versucht postgres zu deinstallieren, doch es ist glaube ich noch nicht mal installiert (find jedenfalls keine Dateien, die man nach dem deinstall guide finden sollte). Wie kann also eine Datenbank einrichten?

      Zu allem Überfluss finden sich jetzt auch noch in meinem Laufwerk c: 12 Dateien mit Namen "FOUND.000" forlaufend bis "FOUND.011". In den Ordner sind 1-3 .chk Dateien, hat das irgendwas mit der Installation zutun?

      ps. hab einen Router (FritzBox) muss ich da irgendwelche Ports freigeben?
  • 4 Antworten
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Nein. Bitte befolge doch einfach mal unsere Deinstallationsanleitung für PostgreSQL. Link findest du in meiner SIG.

      Anschließend gehst du ins Elephantverzeichnis und führst dort das Setup für postgreSQL mit Adminrechten durch. Danach sollte alles wie gewohnt funktionieren.

      Gruß Sebastian
    • esquilo
      esquilo
      Bronze
      Dabei seit: 24.03.2008 Beiträge: 406
      Danke für die Hilfe.
      Den deinstallationsanweisung hab ich versucht zu folgen, aber wie gesagt existieren bei mir die datein die ich löschen sollte nicht. Habs jetzt wie du gesagt hast vom Elefanzverzeichniss geladen und bin auch schon weiter gekommen aber jetz is ein neuer Fehler aufgetreten:

      Fehler betr. das Datenverzeichnis
      Das PostgreSQL Datenverzeichnis muß auf einem NTFS-Volume liegen.
      Wenn das Datenverzeichnis auf einem Volume anderen Types erstellt werden soll (was we empfohlen noch unterstützt ist), muß dort die Datenbank 'von Hand' per initdb.exe eingerichtet werden.

      Hä?
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Hast du ein FAT32 Laufwerk? Wenn ja wird das realtiv kompliziert und leider kann ich dir in der Richtung keine Tipps geben, hab selbst keinerlei Erfahrungen damit.

      Gruß Sebastian
    • esquilo
      esquilo
      Bronze
      Dabei seit: 24.03.2008 Beiträge: 406
      jo is ein FAT32 Laufwerk... an wen kann ich mich denn da wenden?