v58 - Elephant(Postgres) legt meinen Rechner lahm

    • Trigger1201
      Trigger1201
      Bronze
      Dabei seit: 19.06.2006 Beiträge: 3.852
      Hi,
      seit Version v58 liegt mein Rechner am Boden (CPU 4GHz + 2GB RAM) wenn ich den Elephant benutze und GLEICHZEITIG auf Titan spiele. Nach Beendigung von Titan funzt alles wieder.

      Ein Entfernen von v58 und Installieren von v57 brachte mir ebenfalls nicht den gewünschten Performance-erfolg. Ich komme bei meinen abgelegten Handhistories(incl. MiningDaten) auf ca. 700k eingelesene Hände und habe diese Hände sowohl in einer Datenbank_v58 als auch in einer Datenbank_v57 eingelesen.

      Folgende Probleme:
      1. Während des Spielens erscheint kein Elephant-Symbol ("letzte Hand markieren", "Spielernamen einblenden/ausblenden", etc.) am Tisch und die gespielten Hände werden nur teilweise alle paar Minuten eingelesen.
      2. Zudem werden die Daten auf dem Tisch nicht aktualisiert, da der Elephant überfordert ist.
      3. Wenn der Elephant minimiert ist in der Taskleiste, lässt er sich nicht mehr öffnen.
      4. Beende ich den Elephant während des Spielens und versuche nach Beendigung des Spielens die verbleibenden Hände, manuell einzulesen - werden mir diese als Dublikate abgelehnt. (so hatte ich letztens ca. 220Hd gespielt, aber nur 60Hd wurden vom Elephant eingelesen)
      5. Wenn ich Alt+Strg+Entf drücke, zeigt mir der WindowsTaskManager zudem 7 Prozesse mit dem Namen "postgres.exe" und eine "pg_ctl.exe" und eine Systemauslastung durch "postgres.exe" von >50%

      Ich hoffe ihr könnt mir helfen.
  • 7 Antworten
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Denke deine Probleme hängen wahrscheinlich mit der Größe der DB zusammen, hast du mal die Optimierungsmöglichkeiten im DB-Management probiert mit der 0.58er DB? Das mit den vielen postgre.exe Prozessen ist relativ normal. Versuch doch mal alle bis auf die aktuelle DB zu löschen, das könnte auch schon helfen.
    • Trigger1201
      Trigger1201
      Bronze
      Dabei seit: 19.06.2006 Beiträge: 3.852
      Ok - ich hab jetzt nur noch eine Datenbank und Optimierung hab ich auch gemacht. ABER: keine Verbesserung. Solbald ich mich an einen Tisch setze und loslegen will, verweigert der Elephant jegliche Arbeit während sich auf Titan ohne Probleme spielen lässt.
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Startest du den Elephant und Titan mit Adminrechten? Ist das Vista oder XP?
    • Trigger1201
      Trigger1201
      Bronze
      Dabei seit: 19.06.2006 Beiträge: 3.852
      Es ist XP und ich bin Admin am Rechner.
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Probier das ganze doch mal mit ner neuen Datenbank ohne die ganzen Hände, läufts dann flüssig?
    • Trigger1201
      Trigger1201
      Bronze
      Dabei seit: 19.06.2006 Beiträge: 3.852
      Bin grad am Spielen auf Titan. Mit der LEEREN Datenbank läuft's nun wieder flüssig.

      Wie gesagt, bis v54 lief's beim Spielen ohne Probleme - kein Ruckeln, Festfahren - einfach nix. v55 und v57 hatten ganz selten mal einen Hänger - fast nie länger als 5 Sekunden.
      Und v58 lief dann gar nicht mehr mit der Datenbank.

      Anmerkung:
      Ich habe die komplett im Forum erhältlichen Datenreihen vom Titan-Datamining auf FL 0,50/1 SH eingelesen zzgl. meiner selbst gespielten Hände. Da im Forum seit Ende April/Anfang Mai keine neuen Daten dazu kamen, beschränkt sich der Datenzuwachs auf meine eigenen ca. 10-15k selbst gespielten Hände.
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Also ich denke nicht, dass sich da was geändert hat in der Performance. Wirklich erklären kann ich mir das nicht. Evtl schaust du nochmal im Support vorbei und fragst mal konkret an.