Postgres und Elephant.. auf Fat32

    • DokSnyder
      DokSnyder
      Bronze
      Dabei seit: 01.11.2006 Beiträge: 42
      Servus!

      Hab hier ein Problem, und zwar will ich Postgres nicht auf meiner Win-Partition, weil da kein Platz mehr ist. Leider sind meine anderen Partitionen Fat32 und sollen das auch bleiben.

      (Hatte Postgres mal auf der NTFS-Win Partition, da lief auch alles einwandfrei.)

      Hab jetzt den Elephant installiert problemfrei, und auch Postgres installiert, mit initdb wie in http://www.postgres.de/postgresql8_win.html beschrieben.
      Leider kann ich dabei kein Passwort etc. eingeben, so dass ich keine Ahnung habe wie ich dann an die soeben erstellte Datenbank komme. Und damit findet der Elephant die leider auch nicht und ich kann die auch nicht auswählen, beziehungsweise dahin connecten.

      Der sagt immer das keine Verbindung zum Datenbankserver aufgebaut werden konnte.

      Hat da jemand nen Plan?

      Gruß
      Dok
  • 4 Antworten
    • MrKartoffelkopf
      MrKartoffelkopf
      Bronze
      Dabei seit: 26.12.2007 Beiträge: 451
      ich hab auch an dieser stelle ein problem, siehe: fehleer elephant

      Bei der Beschreibung von postsql bla hab ich an dieser stelle mein problem:

      Bei den Optionen Locale und Encoding wählen Sie aus, mit welchen lokalen Einstellungen und Zeichensätzen die Datenbank initialisiert werden soll. Arbeiten Sie hauptsächlich mit deutschen Daten, können Sie German, Germany und den Zeichensatz Latin 1 auswählen.

      fehlermeldung sagt, dass latin eins nicht zur loace germany passt
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Laut der Anleitung kannst du doch vor dem initdb das Password festlegen, das muss aufjedenfall kommen.

      MrKartoffelkopf: Ich würde die selben locales nehmen wir auf dem Screenshot.
    • DokSnyder
      DokSnyder
      Bronze
      Dabei seit: 01.11.2006 Beiträge: 42
      Ich kann zwar den Benutzernamen für den Dienst festlegen:
      http://www.postgres.de/bilder/postgresql5.png
      aber hier muss ich den Haken ja wegmachen, und damit kann ich hier ja auch nichts angeben. (Das Prog installiert ishc sonst nicht weiter.
      http://www.postgres.de/bilder/postgresql6.png
      Oder brauch ich garnicht den Namen der neuen Datenbank und ich kann nur seltsamerweise nicht connecten.
      Oder muss ich Postgres dann manuell starten neuerdings? DAmals hat das noch der Elephant gemacht.
    • MrKartoffelkopf
      MrKartoffelkopf
      Bronze
      Dabei seit: 26.12.2007 Beiträge: 451
      Original von galam
      Laut der Anleitung kannst du doch vor dem initdb das Password festlegen, das muss aufjedenfall kommen.

      MrKartoffelkopf: Ich würde die selben locales nehmen wir auf dem Screenshot.
      der screenshot zeigt keinen client an, den ich wählen soll
      auch mit den gleichen einstellungen kommt die fehlermeldung, dass PostgreSQL auf NTFS volumen sein muss