Riesenproblem mit Datenbank auf 2 Computern

    • merkabah
      merkabah
      Bronze
      Dabei seit: 03.08.2006 Beiträge: 728
      Hallo habe mir als 2. Computer einen Laptop zugelegt und wollte wie beschrieben die Datenbank auf beiden Rechnern nutzen.

      Die Anleitung lautet wie folgt:

      Folgendermaßen ist das Ganze dann einzurichten:

      Auf dem primären Rechner:

      1. Pokertracker und PostgreSQL installieren.

      2. Datenbank(en) nach PostgreSQL konvertieren.

      3. Öffnet „Start -> Programme -> PostgreSQL 8.0 -> Configuration Files -> Edit pg_hba.conf“

      4. Scrolled in der Datei bis ganz nach unten und fügt in der Sektion „IPV4 local connections“ folgende Zeile hinzu:

      host all all 192.168.10.4/24 md5

      (Hier dann natürlich nicht die Beispiel IP Adresse übernehmen, sondern die IP Adresse des primären Rechners angeben.)

      5. Öffnet „Start -> Programme -> PostgreSQL 8.0 -> Configuration Files -> Edit postgresql.conf“

      6. Ändert die folgende Zeile unter „Connections and Authentication“:

      von #listen_addresses = 'localhost' nach: listen_addresses = '*'

      7. Speichert die Datei und fertig.

      Auf dem sekundären Rechner:

      1. Installiert Pokertracker und PostgreSQL.

      2. Öffnet in Pokertracker „Utilities -> PosgreSQL Settings“ und ändert „localhost“ in die IP Adresse des primären Rechners.

      Jetzt sollten beide Pokertracker Installationen die selbe Datenbank auf dem primären Rechner verwenden können.


      Das habe ich nun gemacht. Auf meinen Laptop erhalte ich eine einwandfreie
      Verbindung zur Datenbank. Doch jetzt kann ich am primären Rechner keine
      Datenbank mehr öffnen.

      Folgende Meldung erscheint: Unable to connect to the datbase
      101 - SQLSTATE = 08001
      Could not connect to the server
      Could not connect to remote socket

      Kann mir bitte jemand helfen ?

      Vielleicht stimmen die Einträge beim primären Computer nicht ?

      Danke im voraus für Eure Hilfe.
  • 13 Antworten
    • monarco
      monarco
      Bronze
      Dabei seit: 16.09.2007 Beiträge: 2.148
      Hier hatte jemand zumindest die gleiche Fehlermeldung: http://www.pokertracker.com/forums/viewtopic.php?f=29&t=9165&hilit=sqlstate+08001+remote+socket

      Geh doch bitte mal die Tips da durch, aber backuppe deine DB vorher.
    • merkabah
      merkabah
      Bronze
      Dabei seit: 03.08.2006 Beiträge: 728
      Hab in einem älteren Forum was entedeckt.


      In der datei pg_hab.config so einen Eintrag?

      host all all 10.0.1.3 255.255.255.0 trust

      (aber je nach Ip und Subnetmask!!)

      Und dann in der postgresql.config


      listen_addresses = '*' # what IP interface(s) to listen on;
      # defaults to localhost, '*' = any
      port = 5432

      Bei mir war hier das Problem!! Hatte vor der Zeile listen_addresses eine "#" und die deaktiviert die Zeile

      Wenn das noch nicht geholfen hat, dann kanns auch entweder an dem nicht freigeschalteten Port liegen oder an der Firewall die das ganze sperrt...


      Nun meine Frage zum 1. Eintrag. Im Handbuch von Pokertracker steht
      folgendes: host all all 192.168.10.4/24 md5

      Daß ich die IP meines Computers angebe ist mir klar, was bedeutet jedoch
      nach der IP /24 md5.

      Hab sämtliche Methoden probiert, mit /24 md5 oder IP und Subnet und /trust .... funktioniert aber nach wie vor nicht.

      Vielleicht kann mir wer helfen ?

      Vielen Dank im voraus.
    • monarco
      monarco
      Bronze
      Dabei seit: 16.09.2007 Beiträge: 2.148
      Hast du Vista?
    • merkabah
      merkabah
      Bronze
      Dabei seit: 03.08.2006 Beiträge: 728
      Original von monarco
      Hast du Vista?
      Nein, auf beiden XP-Pro und Postgre SQL 8.0
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 37.193
      Postgre SQL 8.0
      Vielleicht solltest du eine aktuelle Version einsetzen?
    • merkabah
      merkabah
      Bronze
      Dabei seit: 03.08.2006 Beiträge: 728
      Original von netsrak
      Postgre SQL 8.0
      Vielleicht solltest du eine aktuelle Version einsetzen?
      So steht es in der Installationsanleitung von PS:
      Nehmt bitte unbedingt diese Version. Neuere Versionen von PostgreSQL als v8.0.3 werden von Pokertracker nicht unterstützt.
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 37.193
      Siehe z.B. hier: postgreSQL-Software - Link ist tot
    • merkabah
      merkabah
      Bronze
      Dabei seit: 03.08.2006 Beiträge: 728
      Habe nun die alte Version nach Anleitung komplett deinstalliert und die
      Version 8.3.3 installiert.

      Nun kommt folgende Meldung:

      Unable to connect to database
      999 - SQLSTATE = IM 002
      (Microsoft) (ODBC Driver Manager) Der Datenquellenname wurde nicht gefunden,
      und es wurde kein Stadardtreiber angegeben.


      Hab nun das Internet und das PS-Forum nach möglichen Lösungen durchforstet.
      Werde aber leider auch nicht schlau.

      Unter dem Punkt PG Admin III besteht eine Verbindung.
      Vielleicht stimmen nun andere Einstellungen nicht mehr (z.B. beim
      Stack-Builder)
      Muß man unter Start-Systemsteuerung-Verwaltung-Datenquellen
      auch Einstellung vornehmen ?

      Gibt es von PS keine aktuelle Installtionsanleitung ?

      Bin leider kein Datenbankexperte.

      Bin für jede Hilfe Dankbar.
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 37.193
      Du hast vmtl. nicht an den richtigen Stellen gesucht. Bei der 8.3.x muss der ODBC Treiber nachträglich installiert werden: http://www.pokertracker.com/forums/viewtopic.php?f=29&t=5669
    • merkabah
      merkabah
      Bronze
      Dabei seit: 03.08.2006 Beiträge: 728
      Original von netsrak
      Du hast vmtl. nicht an den richtigen Stellen gesucht. Bei der 8.3.x muss der ODBC Treiber nachträglich installiert werden: http://www.pokertracker.com/forums/viewtopic.php?f=29&t=5669
      Danke für Deine schnelle Rückantwort.

      Habe ich wie folgt gemacht:

      Some users have been having trouble getting PT to work with PostgreSQL 8.3 but it can be done.

      When you install v8.3.x of PostgreSQL there is an extra step needed.

      After you install 8.3 there is another window that opens called the application stack builder. If you have closed this window, you can open it again using the Start menu > Programs > PostgreSQL 8.3 > Application Stack Builder.

      On the window that opens, click the PostgreSQL Database Server 8.3 from the list and click the NEXT button.

      On the next window, check the box next to "psqlODBC v08.03...." and click NEXT.

      On the next window, select USA from the list of countries and select a mirror (I don't think it matters which) and click NEXT.

      From this point, just keep clicking NEXT or FINISH leaving everything else set to the default values until the ODBC Drivers are installed.

      Now you should be able to go into Poker Tracker, open the Utilities > PostgreSQL Settings window and choose the appropriate ODBC Entry to Use value from the list (should be PostgreSQL Unicode).


      Beim Öffnen von PT kommt nach wie vor die o.a. Fehlermeldung.
      Unter Utilities - PostgreSQL Settings - habe ich nun folgende Einstellungen:

      Port: 5432
      Server: localhost
      User Name: postgres
      PW: XXXXXXX
      ODBC Entry To Use: PostgreSQL Unicode
      Encoding: UNICODE
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 37.193
      Dann musst du jetzt noch unter Database maintenance& utilities die richtige DB als Default eintragen
    • merkabah
      merkabah
      Bronze
      Dabei seit: 03.08.2006 Beiträge: 728
      Original von netsrak
      Dann musst du jetzt noch unter Database maintenance& utilities die richtige DB als Default eintragen
      Danke für Deine Tips. Habe nun auch Deine ausführliche Anleitung gefunden.

      Wollte nun die Datenbank einbinden, wurde jedoch durch die neuerliche
      Installation von PostgreSQL gelöscht. Zum Glück hab ich vor einigen
      Tagen eine Sicherung gemacht.

      Jetzt das nächste Problem.

      Habe über PGAdminIII ein Restore des Backup gemacht. Wollte diese nun in PT2 einbinden (File - Maintaine Database Name - Add - Select an Existing
      PostgreSQL Database .. ) hier steht keine Datenbank.
      Wo finde ich diese ?

      Auch mit dem Punkt (File - Maintaine Database Name - Add - Select an Existing ODBC Data Source Name) funktioniert es nicht.

      Ich glaub ich bin wirklich zu blöd ?( :(
      Oder ich hab schon zuviel durcheinander gelesen.
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 37.193
      Select an existing postgresql database ... ist schon richtig. Damit müsste er dir alle Postgresql Datenbanken anzeigen, die du auch in pgadminIII siehst, wenn du einen Doppelklick auf den Server machst.
      Werden dir keine DBs angezeigt stimmen vmtl. deine Zugangsdaten in den Postgresql settings nicht.