PT3 - kann nicht mehr auf meine DB zugreifen

    • nekkx1
      nekkx1
      Bronze
      Dabei seit: 25.09.2007 Beiträge: 1.448
      Wollte heute PT3 starten, das hat schonmal ewig gedauert und als es dann offen war stand links am Rand: "Unable to login to database (PT3 DB1). Reason: could not connect to server: Connection is refused (0x0000274D/10061) Is the server running on host "localhost"". Woran kann das liegen? Hoffe meine DB ist nicht kaputt?
  • 16 Antworten
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 37.190
      Dein DB Server scheint nicht zu laufen.
      - Rechner schon mal neu gestartet?
      - Läuft der Postgres Dienst?

      Ach, lies dir erstmal das hier durch: PostgreSQL Einführung
    • sekundaer
      sekundaer
      Bronze
      Dabei seit: 05.11.2006 Beiträge: 2.526
      moin,
      hab hier das gleich problem, wenn ich auto-imprort starten will kommt folgende meldung

      Unable to begin feeder import process. Reason: Unable to login to database (PT3 DB). Reason: could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "localhost" and accepting TCP/IP connections on port 5432?


      jemand hilfe?
    • Ajezz
      Ajezz
      Black
      Dabei seit: 19.07.2005 Beiträge: 10.245
      Auch hier:
      Original von netsrak
      Dein DB Server scheint nicht zu laufen.
      - Rechner schon mal neu gestartet?
      - Läuft der Postgres Dienst?

      Ach, lies dir erstmal das hier durch: PostgreSQL Einführung
    • nekkx1
      nekkx1
      Bronze
      Dabei seit: 25.09.2007 Beiträge: 1.448
      Der postgres.exe Prozess scheint nicht mehr gestartet zu werden, läuft jedenfalls nicht im Taskmanager. Habs dann versucht über Systemsteuerung/Dienste manuell zu starten, aber da kam diese Fehlermeldung: "Der Dienst "PostgreSQL Database Server 8.3" auf "Lokaler Computer" konnte nicht gestaret werden.

      Fehler 1053: Der Dienst antwortete nicht rechtzeitig auf die Start- oder Steuerungsanforderung.

      Hab jetzt keine Idee was ich machen soll, kann ich das einfach neuinstallieren oder ist meine DB dann gefährdet bzw wird evtl gelöscht?
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 37.190
      Wenn du das neu installierst ist deine DB SEHR gefährdet, vorher unbedingt ein Backup machen (ach sorry, geht ja nicht).

      Vorher solltest du aber noch folgenden Versuch starten:
      - Windows Ereignisprotokoll prüfen ob dort irgendwelche Meldungen eingetragen sind
      - Im Postgresql Unterverzeichnis pg_log die aktuelle LOG Datei prüfen. Vielleicht sind darin irgendwelche Fehler?
      ansonsten:
      - Datei postmaster.pid im data Unterverzeichnis von postgresql löschen
      - Firewall / Virenscanner deaktivieren.
      - Rechner neu starten und nochmal versuchen.
    • nekkx1
      nekkx1
      Bronze
      Dabei seit: 25.09.2007 Beiträge: 1.448
      Die Datei postmaster.pid existiert bei mir nicht. Das ist der Inhalt der letzten logdatei:

      2008-09-12 14:01:32 CEST LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2008-09-12 14:01:32 CEST FATAL: the database system is starting up
      2008-09-12 14:01:32 CEST LOG: database system was interrupted; last known up at 2008-09-12 01:34:33 CEST
      2008-09-12 14:01:32 CEST LOG: database system was not properly shut down; automatic recovery in progress
      2008-09-12 14:01:32 CEST LOG: record with zero length at 3/FD4FF118
      2008-09-12 14:01:32 CEST LOG: redo is not required
      2008-09-12 14:01:32 CEST LOG: database system is ready to accept connections
      2008-09-12 14:01:32 CEST LOG: autovacuum launcher started
      2008-09-12 14:01:33 CEST LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2008-09-12 14:08:50 CEST LOG: received fast shutdown request
      2008-09-12 14:08:50 CEST LOG: aborting any active transactions
      2008-09-12 14:08:50 CEST LOG: autovacuum launcher shutting down
      2008-09-12 14:08:50 CEST LOG: shutting down
      2008-09-12 14:08:51 CEST LOG: database system is shut down

      Alle sonstigen Versuche waren erfolglos. Kann ich denn bei einer Neuisntallation von postgresql nicht die alte DB beibehalten oder was ist daran so "heikel"?
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 37.190
      Du kannst es versuchen, musst dann aber die Initialisierung des DB Clusters bei der Installation nicht durchführen, das muss irgendwo eine Einstellung sein.

      Also aus der LOG Datei geht hervor: DB Server gestartet um 14:01, runtergefahren um 14:08.
      Ist vielleicht dein Netzwerk deaktiviert/nicht aktiv? Das macht bei manchen DB Systemen auch Probleme. Du könntest mal den Microsoft Loopback Adapter als "Pseudo" Netzwerkkarte installieren.
    • nekkx1
      nekkx1
      Bronze
      Dabei seit: 25.09.2007 Beiträge: 1.448
      Ich hatte um die Zeit häufig Probleme mit Hamchi da musste ich öfters den virtuellen Netzwerkadapter aktivieren/deaktivieren. Möglicherweise ist deswegen der Schaden entstanden- Ich deinstalliere mal hamchi und dann werd ich ja sehen obs evtl wieder funktioniert.
    • nekkx1
      nekkx1
      Bronze
      Dabei seit: 25.09.2007 Beiträge: 1.448
      Also Deinstallation von hamachi hat schon mal nichts gebracht, könntest du mich vielleicht bei Skype (mein Nick ist chipsnap) adden? Weil die DB schon halbwegs wichtig und groß ist und ich die ungern löschen möchte.
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 37.190
      Nee, Online Support mache ich nicht.
      Hier nochmal ein paar Infos zu Postgres: PostgreSQL Einführung -> Sorry, hatte ich ja oben schon gepostet.

      Ansonsten solltest du vielleicht mal bei http://www.postgresql.org oder allgemein im Internet recherchieren.
    • nekkx1
      nekkx1
      Bronze
      Dabei seit: 25.09.2007 Beiträge: 1.448
      Ok danke schonmal für die Hilfe, ich werd berichten ob und wenn wie ichs hinbekommen habe.
    • Konik
      Konik
      Bronze
      Dabei seit: 05.05.2007 Beiträge: 294
      Original von nekkx1
      Ok danke schonmal für die Hilfe, ich werd berichten ob und wenn wie ichs hinbekommen habe.
      Eine Lösung gefunden?
      Stehe vor dem gleichen Problem
    • sekundaer
      sekundaer
      Bronze
      Dabei seit: 05.11.2006 Beiträge: 2.526
      PT3 hat auch nen recth guten support... hat mir geholfen....
    • rabatzmaker
      rabatzmaker
      Bronze
      Dabei seit: 06.03.2006 Beiträge: 907
      selbes problem: pt3 gestartet und bums:
      "Unable to login to database (PT3 DB): Reason: server closed the connection unexpectedly. This probably means the server terminated abnormally before or while processing the request."

      kann halt auf nix zugreifen. gestern gings noch und hab seit dem nix installiert/gelöscht/verändert am system.

      hat jemand schon ne lösung?
    • nekkx1
      nekkx1
      Bronze
      Dabei seit: 25.09.2007 Beiträge: 1.448
      Nö der Pokertrackr support ignoriert meine mails seitdem ich geschrieben habe, dass deren Lösungsvorschläge nicht funktioniert haben.
    • rabatzmaker
      rabatzmaker
      Bronze
      Dabei seit: 06.03.2006 Beiträge: 907
      Original von rabatzmaker
      selbes problem: pt3 gestartet und bums:
      "Unable to login to database (PT3 DB): Reason: server closed the connection unexpectedly. This probably means the server terminated abnormally before or while processing the request."

      kann halt auf nix zugreifen. gestern gings noch und hab seit dem nix installiert/gelöscht/verändert am system.

      hat jemand schon ne lösung?
      wenn jemand den oben beschriebenen fehler hat, ich habs folgendermaßen gelöst:

      postgresql dienst per hand neu starten über die windows-dienste. (obwohl er als gestartet eingetragen ist, einfach nicht beenden sondern neu starten).