Elephant installiert SQL nicht - LÖSUNG!

    • fando67
      fando67
      Bronze
      Dabei seit: 05.02.2006 Beiträge: 364
      Hallo

      Wenn ich den Elephant installiert habe und eine neu Datenbank anlegen will,
      kommt die Meldung: "Es kann keine Verbindung zum Datenbankserver aufgebaut werden."
      Der Grund: SQL wird nicht mit installiert.

      Bin leicht überfordert. ?(
  • 35 Antworten
    • fando67
      fando67
      Bronze
      Dabei seit: 05.02.2006 Beiträge: 364
      habe den elephant heute nochmal neu installiert. sql wurde auch mit installiert.
      aber beim anlegen der datenbank gibt es probleme. wenn ich eine neue db anlegen will, kommt die meldung: es kann keine verbindung zum datenbanksever aufgebaut werden.
      WARUM?
    • XardasPokerKing
      XardasPokerKing
      Bronze
      Dabei seit: 14.03.2008 Beiträge: 138
      Genau das gleiche Problem habe ich auch.
    • drcollosso
      drcollosso
      Bronze
      Dabei seit: 05.05.2006 Beiträge: 3.053
      Das Problem hatte ich gestern auch. Aber nach 5maligem De- und Reinstallieren hats dann irgendwie geklappt.
      Anscheinend wurde das Sql-Zeug nicht richtig installiert.

      Mein Weg zum Erfolg war:
      1. Elephanten deinstallieren
      2. Postgres deinstallieren (inklusive der Löschung dessen Nutzerkonten und über die Suchfunktion alle Postgres-Dateien (postgre*) suchen und löschen)
      3. Neustart
      4. Elephanten drauf, der dann hoffentlich auch Postgres mit installiert (was bei mir komischerweise auch nicht immer der Fall war)

      Dann gings. Bin zwar der Meinung, das auch vorher schon so gemacht zu haben, aber vielleicht hab ich den Neustart mal vergessen oder nicht alle Dateien entfernt. Was weiß ich.

      Viel Erfolg/Geduld
    • fando67
      fando67
      Bronze
      Dabei seit: 05.02.2006 Beiträge: 364
      Original von drcollosso
      Das Problem hatte ich gestern auch. Aber nach 5maligem De- und Reinstallieren hats dann irgendwie geklappt.
      Anscheinend wurde das Sql-Zeug nicht richtig installiert.

      Mein Weg zum Erfolg war:
      1. Elephanten deinstallieren
      2. Postgres deinstallieren (inklusive der Löschung dessen Nutzerkonten und über die Suchfunktion alle Postgres-Dateien (postgre*) suchen und löschen)
      3. Neustart
      4. Elephanten drauf, der dann hoffentlich auch Postgres mit installiert (was bei mir komischerweise auch nicht immer der Fall war)

      Dann gings. Bin zwar der Meinung, das auch vorher schon so gemacht zu haben, aber vielleicht hab ich den Neustart mal vergessen oder nicht alle Dateien entfernt. Was weiß ich.

      Viel Erfolg/Geduld
      werde das jetzt nochmal testen. habe sonst keinen neustart gemacht.
    • Romance22
      Romance22
      Bronze
      Dabei seit: 28.12.2007 Beiträge: 295
      wichtig ist, daß nach einer Deinstallation von Postgres noch vorhandene Dateien und Ordner manuell gelöscht werden (zumindest der Ordner 'data')

      Außerdem sollte Postgres als Service / Dienst installiert sein, damit es sich automatisch beim Hochfahren startet
    • fando67
      fando67
      Bronze
      Dabei seit: 05.02.2006 Beiträge: 364
      habe den elephant und sql so eben deinstalliert. alle ordner und datein von hand gelöscht. neustart. elephant installiert. die gleiche fehlermeldung. keine verbindung zum datenbankserver.
      habe dann im ps ordner nachgeschaut ob sql installiert wurde. die installer pakete von sql sind im ordner. meine frage: muss der elephant nicht die sql software automatisch installieren? ist das das problem?
    • Romance22
      Romance22
      Bronze
      Dabei seit: 28.12.2007 Beiträge: 295
      kann die Verbindung nicht hergestellt werden, weil keine Datenbank gefunden wurde (also Postgres nicht vorhanden / gestartet ist) oder sind Benutzername / Passwort falsch?
    • fando67
      fando67
      Bronze
      Dabei seit: 05.02.2006 Beiträge: 364
      Original von Romance22
      kann die Verbindung nicht hergestellt werden, weil keine Datenbank gefunden wurde (also Postgres nicht vorhanden / gestartet ist) oder sind Benutzername / Passwort falsch?
      wie gesagt: sql wurde nicht vom elephant installiert.
      Benutzername / Passwort falsch? kann sein.
      was passiert wenn ich verschiedene pw/bn verwende?
    • tone
      tone
      Black
      Dabei seit: 01.05.2006 Beiträge: 1.764
      lass mich wissen wenns bei dir klappt, hab das selbe problem aber bisher noch keine lösung gefunden
    • fando67
      fando67
      Bronze
      Dabei seit: 05.02.2006 Beiträge: 364
      wieder alles deinstalliert, neustart und neu installiert. das selbe problem.
      habe aber diesmal sql manuell installiert. keine verbindung zu datenbankserver. ?( ?( ?(
      ich bin überfordert
    • Romance22
      Romance22
      Bronze
      Dabei seit: 28.12.2007 Beiträge: 295
      Die Datenbank gewährt nur Zugriff, wenn sich ein User ordnungsgemäß mit Login / PW anmeldet. Der Elephant ist in diesem Fall der User, der Zugriff auf die Datenbank benötigt, um Daten abzulegen bzw. abzurufen

      mein Verdacht ist, daß entweder Postgree nicht gründlich genug entfernt wurde oder Ihr habt es nicht als Service installiert

      Wenn Ihr mögt, kann ich mir das via RemoteSession mal anschauen
    • fando67
      fando67
      Bronze
      Dabei seit: 05.02.2006 Beiträge: 364
      Original von Romance22
      Die Datenbank gewährt nur Zugriff, wenn sich ein User ordnungsgemäß mit Login / PW anmeldet. Der Elephant ist in diesem Fall der User, der Zugriff auf die Datenbank benötigt, um Daten abzulegen bzw. abzurufen

      mein Verdacht ist, daß entweder Postgree nicht gründlich genug entfernt wurde oder Ihr habt es nicht als Service installiert

      Wenn Ihr mögt, kann ich mir das via RemoteSession mal anschauen

      Skype: walldorf001
      ICQ: 323 089 838

      sql ist bei mir vollständig gelöscht. da bin ich mir sicher.
      als sevice hatte ich es auch installiert.
      ich habe ein verdacht. werde es nochmal testen.
    • fando67
      fando67
      Bronze
      Dabei seit: 05.02.2006 Beiträge: 364
      ich habe es geschaft. :D

      also jungs aufgepasst!

      elephant und sql über systemsteuerung/software deinstallieren
      elephant entpacken und installieren und dann schliessen.
      wenn der elephant sql nicht mit installiert,
      was ja offenbar das problem ist, in den elephant ordner und sql manuell installieren. doppelklick installer sql.
      sql wird installiert. jetzt kommt das wichtige. das anlegen der konten.
      das dienstkonto: benutzer: postgres und ein pw *****
      der nutzer der datenbank: elephant und ein pw *****
      die ps müssen verschieden sein
      nach der installation elephant öffnen.
      dann wird die neu datenbank erstellt. ihr müsst als nutzer elephant und
      das pw eintragen. das selbe pw wie bei der sql installation
      fertisch :D
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Also grundsätzlich würde ich euch empfehlen unsere Deinstallationsanleitung ans Herz legen, wenn ihr die wirlkich befolgt sollte der ELephant postgreSQL wieder problemlos installieren.
    • fando67
      fando67
      Bronze
      Dabei seit: 05.02.2006 Beiträge: 364
      bei mir läuft der elephant jetzt tadellos. =)
      endlich
    • tone
      tone
      Black
      Dabei seit: 01.05.2006 Beiträge: 1.764
      na endlich, danke man, hat auch bei mir geklappt.

      aber noch eine frage, nach der manuellen sql installation hat sich noch eine installation "stack-builder" oder so ähnlich gestartet. hab die einfach abgebrochen. war die eventuell für irgendwas gut?
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Wenn alles funktioniert würde ich mir da keine Sorgen machen ;) Ansonsten würd ich wenn was automatisch startet das immer auch durchlaufen lassen. Das was du meinst ist abernet so wichtig.

      Gruß Seabstian
    • XardasPokerKing
      XardasPokerKing
      Bronze
      Dabei seit: 14.03.2008 Beiträge: 138
      @ fando67: Vielen Dank, es funktioniert perfekt. Sehr gute Anleitung, sollte in die FAQ rein.
    • kaefer
      kaefer
      Bronze
      Dabei seit: 29.01.2006 Beiträge: 365
      edit: hat sich erledigt, es funzt endlich =)
    • 1
    • 2