Und immer wieder die Datenbank

    • karamasow
      karamasow
      Silber
      Dabei seit: 11.02.2007 Beiträge: 1.501
      Hallo, als erstes möchte ich sagen, dass ich mit dem Elephant alles in allem sehr zufrieden bin. Was mich aber immer wieder stört, ist dass ich regelmäßig(~1x /4 Wochen) aufgefordert werde meine DB neu anzulegen. Hab das auch immer gemacht, aber dann die Probleme, die auch schon in anderen Posts häufig angemerkt wurden, dass die HH nicht komplett, leer, etc. ist. Beim letzten mal habe ich dann zwar eine neue angelegt, danach aber einfach die alte DB wieder aktiviert. Das hat einwandfrei geklappt und alles läuft. Warum also muss eine neue DB überhaupt angelegt werden, wenn die alte doch funktioniert? Ist das ein Bug? Danke für die Antworten.
  • 21 Antworten
    • Insaniac
      Insaniac
      Bronze
      Dabei seit: 17.09.2007 Beiträge: 3.398
      hab ich auch ständig, total nervig
      wird hoffentlich mit der nächsten version gefixt
    • selected88
      selected88
      Silber
      Dabei seit: 08.04.2007 Beiträge: 128
      hab das problem auch gerade, hinzu kommt noch dass ich jetzt noch nicht mal mehr ne neue DB anlegen kann
    • domman40
      domman40
      Silber
      Dabei seit: 09.03.2006 Beiträge: 688
      Ja, genau dasselbe Problem habe ich auch: "Es konnte keine Verbindung zum Datenbankserver hergestellt werden..." ;(

      Erscheint immer wieder, auch eine De- und Neuinstallation brachte keine Veränderung. Bitte die Programmierer sich sofort dieses Problems anzunehmen! ;)
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Also das mit der Datenbank ist in der Tat merkwürdig, normalerweise kannst du auch einfach deine Daten eingeben und dann über die Lupe deine alte auswählen dann funktioniert alles wieder.

      @die anderen bitte eigenen Thread mit euren Problemen aufmachen.
    • karamasow
      karamasow
      Silber
      Dabei seit: 11.02.2007 Beiträge: 1.501
      Original von galam
      Daten eingeben und dann über die Lupe deine alte auswählen dann funktioniert alles wieder.
      Ja aber das ist ja genau der Punkt. Die Begründung ist irgendwie immer sowas wie Datenbankversion hat sich geändert, ist nicht mehr kompatibel. Diese Meldung steht auch meiner Einschätzung nach nicht in Verbindung mit updates, also dass sie bspw. immer nach einem update auftreten würde. Wenn das aber so wäre, dass die DB nicht mehr kompatibel ist, könnte ich ja dann nicht einfach wieder die Alte aktivieren und alles funktioniert normal weiter! @domman40 Dein Problem ist bei mir so noch nicht aufgetreten. Habe den Elephant auch noch nie deinstalliert.
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Komisch kann ich mir gar nicht erklären. Steht denn was im Logfile? Startest du den Elephant mit Adminrechten?
    • karamasow
      karamasow
      Silber
      Dabei seit: 11.02.2007 Beiträge: 1.501
      Das kann ich so aus dem Stehgreif nicht beantworten. Werde das gerne mal überprüfen. Wo kann ich sehen, dass ich mit Adminrechten starte, bzw. nicht starte?
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Nunja versuchs mal über rechte Maustaste und dann ausführen als. Evtl. musst du dabei die Shift-Taste gedrückt halten.

      Gruß Sebastian
    • karamasow
      karamasow
      Silber
      Dabei seit: 11.02.2007 Beiträge: 1.501
      Habe mal nachgeschaut, ja ich starte mit Adminrechten. Habe mitlerweile 4 DBs alle wegen besagter Aufforderung angelegt, alle funktionieren wenn ich sie manuell aktiviere. So jetzt zur Logdatei, da steht zum senden auf Optionen und dann Fehlerbericht senden auswählen. Wenn ich im Debug Fenster aber auf Optionen click, habe ich nur die Auswahl log leeren und schließen -sorry ich bin echt kein IT Spezialist- also wie muss ich weiter verfahren? Danke für deine Geduld.
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Also in der Logdatei einfach alles makieren und hier hin posten würde mich ausreichen. Notfalls erstellst du einfach nen Screenshot davon ;)
    • karamasow
      karamasow
      Silber
      Dabei seit: 11.02.2007 Beiträge: 1.501
      Hier der logfile vom letzten mal als das Problem auftrat:

      2008-09-26 00:42:33 CEST LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2008-09-26 00:42:33 CEST LOG: database system was shut down at 2008-09-25 20:52:46 CEST
      2008-09-26 00:42:33 CEST FATAL: the database system is starting up
      2008-09-26 00:42:34 CEST LOG: database system is ready to accept connections
      2008-09-26 00:42:34 CEST LOG: autovacuum launcher started
      2008-09-26 00:42:34 CEST LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2008-09-26 00:44:29 CEST LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2008-09-26 00:44:39 CEST LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2008-09-26 00:44:39 CEST FATAL: database "elephantdb5959" does not exist
      2008-09-26 00:44:39 CEST LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2008-09-26 00:44:39 CEST FATAL: database "elephantdb5959" does not exist
      2008-09-26 00:44:39 CEST LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2008-09-26 00:44:48 CEST LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2008-09-26 00:44:49 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "id" for table "archive"
      2008-09-26 00:44:49 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "category_pkey" for table "category"
      2008-09-26 00:44:49 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "comment_pkey" for table "comment"
      2008-09-26 00:44:49 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "comment_on_player_pkey" for table "comment_on_player"
      2008-09-26 00:44:49 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "hh_id" for table "fullhh"
      2008-09-26 00:44:50 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "game_pkey" for table "game"
      2008-09-26 00:44:50 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "gamechat_pkey" for table "gamechat"
      2008-09-26 00:44:50 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "gameplayer_pkey" for table "gameplayer"
      2008-09-26 00:44:51 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "gametable_pkey" for table "gametable"
      2008-09-26 00:44:51 CEST NOTICE: CREATE TABLE will create implicit sequence "gametype_game_type_id_seq1" for serial column "gametype.game_type_id"
      2008-09-26 00:44:51 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "gametype_pkey" for table "gametype"
      2008-09-26 00:44:51 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "media_content_pkey" for table "media_content"
      2008-09-26 00:44:51 CEST NOTICE: CREATE TABLE will create implicit sequence "player_player_id_seq" for serial column "player.player_id"
      2008-09-26 00:44:51 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "player_pkey" for table "player"
      2008-09-26 00:44:52 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "playerstat_pkey" for table "playerstat"
      2008-09-26 00:44:52 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "playlist_pkey" for table "playlist"
      2008-09-26 00:44:52 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "playlist_item_pkey" for table "playlist_item"
      2008-09-26 00:44:52 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "portal_pkey" for table "portal"
      2008-09-26 00:44:52 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "quiz_pkey" for table "quiz"
      2008-09-26 00:44:53 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "quiz_answer_pkey" for table "quiz_answer"
      2008-09-26 00:44:53 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "realplayer_pkey" for table "realplayer"
      2008-09-26 00:44:53 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "sorted_cards_pkey" for table "sorted_cards"
      2008-09-26 00:44:53 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "tournament_pkey" for table "tournament"
      2008-09-26 00:44:53 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "trmt_payoutstructure_pkey" for table "trmt_payoutstructure"
      2008-09-26 00:44:53 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "trmt_player_pkey" for table "trmt_player"
      2008-09-26 00:44:53 CEST NOTICE: CREATE TABLE will create implicit sequence "unclear_id_seq1" for serial column "unclear.id"
      2008-09-26 00:44:53 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "unclear_pkey" for table "unclear"
      2008-09-26 00:44:54 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "uploader_pkey" for table "uploader"
      2008-09-26 00:44:54 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "version_pkey" for table "version"
      2008-09-26 00:44:54 CEST NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "triggstop_pkey" for table "triggstop"
      2008-09-26 00:46:41 CEST LOG: could not receive data from client: Unknown winsock error 10061
      2008-09-26 00:46:41 CEST LOG: unexpected EOF on client connection
      2008-09-26 00:46:41 CEST LOG: could not receive data from client: Unknown winsock error 10061
      2008-09-26 00:46:41 CEST LOG: unexpected EOF on client connection
      2008-09-26 00:46:56 CEST LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2008-09-26 00:46:56 CEST LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2008-09-26 00:47:12 CEST LOG: could not receive data from client: Unknown winsock error 10061
      2008-09-26 00:47:12 CEST LOG: unexpected EOF on client connection
      2008-09-26 00:47:22 CEST LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2008-09-26 00:47:32 CEST LOG: could not receive data from client: Unknown winsock error 10061
      2008-09-26 00:47:32 CEST LOG: unexpected EOF on client connection
      2008-09-26 01:06:08 CEST LOG: could not receive data from client: Unknown winsock error 10061
      2008-09-26 01:06:08 CEST LOG: unexpected EOF on client connection
      2008-09-26 01:07:02 CEST LOG: received fast shutdown request
      2008-09-26 01:07:02 CEST LOG: aborting any active transactions
      2008-09-26 01:07:02 CEST LOG: autovacuum launcher shutting down
      2008-09-26 01:07:03 CEST LOG: shutting down
      2008-09-26 01:07:03 CEST LOG: database system is shut down

      Ich habe auch schon gesehen, dass da steht "does not exist" aber am Tag zuvor hat sie existiert, oder vielleicht auch 2 Tage vorher.
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Ist das Betriebssystem Vista?
    • karamasow
      karamasow
      Silber
      Dabei seit: 11.02.2007 Beiträge: 1.501
      Nope, XP mit Service Pack 3.
    • DokSnyder
      DokSnyder
      Bronze
      Dabei seit: 01.11.2006 Beiträge: 42
      Jarp,

      hab genau das selbe Problem, bei mir XP und Service Pack1.
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      SP1 wird wohl nicht mehr wirklich unterstütz ich denke, SP2 brauchst du schon.
    • karamasow
      karamasow
      Silber
      Dabei seit: 11.02.2007 Beiträge: 1.501
      Hatte das Problem auch mit SP 2. Habe erst seit kurzem SP 3 installiert.
    • PepiUrlaub
      PepiUrlaub
      Bronze
      Dabei seit: 03.11.2006 Beiträge: 740
      heut wurd ich auch erstmals aufgefordert eine neue db anzulegen, hab einfach auf OK weitergeklickt und jetzt sind einfach mal so eben alle Daten weg und kann sie auch nicht irgendwie zurückholen, oder vielleicht doch?

      aber vielleicht hab ich mit dem neuen Anlegen genau denselben Namen verwendet wie bei der alten und somit alles überschrieben... gibts das?

      EDIT: Daten wieder da
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Also sprich du wirst aufgefordert die neu zu erstellen, nach dem manuellen aktivieren funktionieren die aber trotzdem?
    • karamasow
      karamasow
      Silber
      Dabei seit: 11.02.2007 Beiträge: 1.501
      Es ist mal wieder soweit. Am nachmittag habe ich noch gespielt und alles lief normal. Jetzt kommt diese Nachricht: "Bitte erzeugen eine neue Datenbank. Die Datenbankversion hat sich geändert, aber ein Patch ist leider nicht möglich." Nachdem die neue Datenbank erstellt war, habe ich wieder die Alte aktiviert. Alles klappt wie vorher. Also was ist der Grund für diese Aufforderung?
    • 1
    • 2