Datenbankproblem

    • Joker69
      Joker69
      Black
      Dabei seit: 22.01.2006 Beiträge: 74
      Habe vorgestern den elephant installiert und ein paar Hände gespielt.

      Gestern habe ich ihn dann wieder gestartet und wurde aufgefordert eine neue Datenbank anzulegen. (Keine Ahnung wo die von Vorgestern abgeblieben ist.) Das hat erstmal nicht funktioniert.
      Meldung:
      Es konnte keine Verbindung zum Datenbankserver aufgebaut werden. Erweiterte Information: Unable to read data from the transport connection: Eine vorhandene Verbindung wurde vom Remotehost geschlossen.

      Habe hier im Forum rumgestöbert und von jemandem einen Link über postgreSQL gefunden. Habe mit dieser Hilfe über Einstellungen -> Systemsteuerung -> Verwaltung -> Dienste postgreSQL neu gestartet und konnte daraufhin eine neue Datenbank anlegen. Habe dann gestern den elephant wieder voll nutzen können.

      Heute dann wieder das gleiche Problem. Meine gestrige Datenbank ist verschwunden und ich soll wieder eine neue anlegen. Geht wieder nicht und leider läßt sich postgreSQL jetzt auch nicht mehr starten. Bei dem Versuch dies zu tun erhalte ich als Meldung:
      Dienst PostgreSQL Database Server 8.3 wurde auf Lokaler Computer gestartet und dann angehalten. Einige Dienste werden automatisch angehalten, wenn sie sich im Leerlauf befindet, wie z.B. Leistungsprotokoll und Alarmdienste.

      Kann mir jemand helfen?

      Gruß
  • 4 Antworten
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Letztendlich ist deine Datenbank nicht weg sondern einfach PostgreSQL läuft nicht mehr. Normalerweise sollte es reichen den wieder zu starten bzw den auf "automatisch" zu stellen, dann sollte der eigtl automatisch mit starten. Bist du denn mit einem Adminaccount angemeldeT? Geht das starten über Start -> Programme -> PostgreSQL 8.3 -> Dienst starten.

      Gruß Sebastian
    • Joker69
      Joker69
      Black
      Dabei seit: 22.01.2006 Beiträge: 74
      Beim Versuch PostgreSQL wie von Dir beschrieben zu starten erhalte ich zunächst in einem schwarzen Fenster die Info PostgreSQL Database Server 8.3 wird gestartet. Es scheint dann der Startvorgang zu laufen und das Fenster schließt sich nach einiger Zeit.
      Starte ich anschließend deden Elephant erhalte ich die Meldung. Bitte richten Sie als esrtes einen neue Datenbank ein, in der von Ihnen und anderen gespielte Pokerhände gespeichert werden können. Geben Sie dazu ihre zuvor gewählte Kombination aus Benutzername und Paßwort ein und bestätigen sie anschließend mit OK.
      Nach dem OK-Klick öffnet sich das Fenster " Neue Datenbank erstellen". Nach Eingabe der verlangten Daten und Bestätigung erhalte ich als Informationsfenster immer noch:
      "Es konnte keine Verbindung zum Datenbankserver aufgebaut werden. Erweiterte Information. Unable to read data from the transport connection: Eine vorhandene Verbindung wurde vom Remotehost geschlossen.

      Kurzum, ich komme nicht weiter.

      Aufgefallen ist mir, dass ich wenn ich über die Systemsteuerung -> Verwaltung -> Dienste reingehe neben postgreSQL 8.3 auch eine Zeile postgreSQL 8.0 aufgeführt wird. Wo dieses Programm liegt weiß ich nicht. Ich habe es deaktiviert, während ich für PostgreSQL 8.3 als Starttyp "automatisch" eingestellt habe.

      ... und während ich diese Zeilen schreibe habe ich nach PostgreSQL 8.0 über die Suchfunktion geschaut. Habe die Dateien gelöscht (waren in einem Ordner tmp versteckt) und - ich fasse es kaum - ich kann meine vor und meine vorvorgestrige Datenbank wieder anwählen.

      Bin mal gespannt. Aktuell scheint es als würde wieder alles funktionieren.

      Danke für die Unterstützung

      Gruß
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.834
      Sieht so aus als wenn du 2 verschiedene Postgresql Versionen installiert hast, die dann vmtl. auf dem gleichen Port "lauschen" und sich gegenseitig behindern. Dann dürfte es mehr oder weniger Glückssache sein, was funktioniert und was nicht.
    • galam
      galam
      Bronze
      Dabei seit: 06.03.2005 Beiträge: 11.136
      Am besten deaktivierst du andere PostgreSQL komplett bzw. deinstallierst es wenn du es nicht mehr benötigst. Damit sollten die Probleme dann auch verschwinden.

      Gruß Sebastian