Netzwerkfrage

    • MrNike
      MrNike
      Bronze
      Dabei seit: 13.03.2005 Beiträge: 2.826
      Hola,

      ich hab ein WLAN Netzwerk (54 Mbit) zuhause an dem bis zu 4 Rechner hängen. Ich würde allerdings gerne 2 Rechner davon mittels einem Crossoverkabel verbinden und damit mehr Geschwindigkeit bei Transfers zwischen den 2 PCs erreichen.
      Eine Kiste ist Linux (Ubuntu) die anderen läuft mit XP.

      Sollte das ohne Probleme möglich sein ?
      Lege ich einfach ein weiteres Netz mit neuen IPs für die 2 Netzwerkkarten an ?

      Greetings,
      MrNike
  • 20 Antworten
    • Kilania
      Kilania
      Bronze
      Dabei seit: 23.04.2007 Beiträge: 7.880
      Sollte das ohne Probleme möglich sein ?
      Lege ich einfach ein weiteres Netz mit neuen IPs für die 2 Netzwerkkarten an

      Jop, sollte so kein Problem darstellen
    • Inkog
      Inkog
      Bronze
      Dabei seit: 20.05.2008 Beiträge: 844
      #2
      Evtl werden die Pakete der Kommunikationspartner danach erstmal weiter über den Acesspoint geleitet, aber das kann man dann notfalls beheben indem man die Routing-tabellen verändert.
      Aber ich denke auch es sollte auf Anhieb laufen.
      Falls die Pakete weiterhin über den Acesspoint laufen obwohl das Netz steht meld dich einfach und ich sag dir, wie du die Routingtabellen in Win / Linux veränderst.
    • Kilania
      Kilania
      Bronze
      Dabei seit: 23.04.2007 Beiträge: 7.880
      Original von Inkog
      #2
      Evtl werden die Pakete der Kommunikationspartner danach erstmal weiter über den Acesspoint geleitet, aber das kann man dann notfalls beheben indem man die Routing-tabellen verändert.
      Aber ich denke auch es sollte auf Anhieb laufen.
      Falls die Tabelle weiterhin über den Acesspoint laufen obwohl das Netz steht meld dich einfach und ich sag dir, wie du die Routingtabellen in Win / Linux veränderst.
      Sollte eigentlich nicht passieren - würde halt anraten den Zielrechner gezielt über die IP aufzurufen und nicht über den Hostname
    • MrNike
      MrNike
      Bronze
      Dabei seit: 13.03.2005 Beiträge: 2.826
      Thx. Versuch in die Tage dann mal ... ich berichte ob es geklappt hat.
    • MrNike
      MrNike
      Bronze
      Dabei seit: 13.03.2005 Beiträge: 2.826
      Hola,

      war klar das es auf anhieb natürlich nicht geht ......

      Hab die 2 Rechner verkabelt und an beiden leuchtet hinten am anschluss die lampe die anzeigt das ein kabel verbunden ist.

      Nun sagt mir meine XP Kiste gleich mal das kein Netzwerkkabel angeschlossen ist ... obwohl wie gesagt die anzeige am anschluss leuchtet und damit alles okay sein sollte.

      Wo kann ich da ansetzen ?

      Die Windows Kiste hat ne 1GB Onboard Karte und die Linux Kiste n 100MBit onboard ... kann es da zu problemen kommen ?

      Greetings,
      MrNike
    • baderth
      baderth
      Bronze
      Dabei seit: 16.11.2007 Beiträge: 1.423
      bei beiden hast du das netzwerkinterface manuell konfiguriert(also manuell eine ip gesetzt, subnetmask usw)?

      die beiden sind sich grundsätzlich egal, ist ja kein DHCP im spiel der da adressen vergeben würde, wenn sie adressen im selben subnet haben und dein kabel ein gekreuztes ist sollte es aber insta funktionieren über die IPs den direkten wired weg gehn zu können.
    • MrNike
      MrNike
      Bronze
      Dabei seit: 13.03.2005 Beiträge: 2.826
      Original von baderth
      bei beiden hast du das netzwerkinterface manuell konfiguriert(also manuell eine ip gesetzt, subnetmask usw)?

      die beiden sind sich grundsätzlich egal, ist ja kein DHCP im spiel der da adressen vergeben würde, wenn sie adressen im selben subnet haben und dein kabel ein gekreuztes ist sollte es aber insta funktionieren über die IPs den direkten wired weg gehn zu können.
      Genauso hab ich gemacht. Aber das Prob ist das die Karten sich wohl net verständigen können. Auf der Linux Kiste verschwinden die IP einstellungen nach einiger zeit von alleine und unter windows wird wie gesagt angezeigt das kein Kabel angeschlossen ist, obwohl es der Fall ist.

      Gruesse,
      Markus
    • Kilania
      Kilania
      Bronze
      Dabei seit: 23.04.2007 Beiträge: 7.880

      war klar das es auf anhieb natürlich nicht geht ......
      Ne, eigentlich nicht klar.. Die Lösung klingt zwar simpel, aber ist aufjedenfall ausreichend...

      Falls noch nicht getan würde ich überprüfen ob beide Netzwerkkarten richtig funktionieren.
      Hatte das Problem übrigens auch mal, damals war das Kabel schuld..
    • MrNike
      MrNike
      Bronze
      Dabei seit: 13.03.2005 Beiträge: 2.826
      Anscheined kann die neue 1GB onboard keine connection zur alten Karte in der Linuxkiste herstellen. Hab jetzt ne 100er Karte in meinen PC jetzt gehts.

      Frage ist nur wie ich meine Linuxkiste dazu überrede eine IP anzunehmen ....

      code:
      ifconfig eth0 10.1.1.2 netmask 255.255.255.0 broadcast 10.1.1.1


      Damit sollte IP gesetzte werden ... funtzt auch .... da ergebniss:

      code:
       eth0      Link encap:Ethernet  HWaddr 00:30:05:0E:49:DC  
                inet addr:10.1.1.2  Bcast:10.1.1.1  Mask:255.255.255.0
                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
                RX packets:289 errors:0 dropped:0 overruns:0 frame:0
                TX packets:550 errors:0 dropped:0 overruns:0 carrier:0
                collisions:0 txqueuelen:1000 
                RX bytes:35694 (34.8 KiB)  TX bytes:168576 (164.6 KiB)


      Problem nun ... diese einstellungen verschwinden nach ein paar sekunden ...

      code:
      eth0      Link encap:Ethernet  HWaddr 00:30:05:0E:49:DC  
                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
                RX packets:292 errors:0 dropped:0 overruns:0 frame:0
                TX packets:555 errors:0 dropped:0 overruns:0 carrier:0
                collisions:0 txqueuelen:1000 
                RX bytes:35874 (35.0 KiB)  TX bytes:170286 (166.2 KiB) 


      Woran kann des liegen ?
    • Kilania
      Kilania
      Bronze
      Dabei seit: 23.04.2007 Beiträge: 7.880
      Schreibs mal als fixen Eintrag ins Config File
      /etc/networking

      Sollte zwar keinen Unterschied machen aber vlt hilfts... Hatte das Problem auch mal, konnte damals erst garnicht eine IP zuweisen. (damals scheiterte es an einem Kernelmodul)
    • elbarto132
      elbarto132
      Bronze
      Dabei seit: 24.03.2008 Beiträge: 4.622
      oben rechts bei der uhr haste son netzwerk config tool was dir deine settings im normalfall immer wieder überschreibt. entweder das teil deinstallieren, oder da in den eigenschaften den roaming mode deaktivieren, denn sollte er es auch netmehr überschreiben, bzw halt direkt damit die ip festlegen
    • dusterl
      dusterl
      Bronze
      Dabei seit: 14.07.2006 Beiträge: 2.090
      Original von Kilania
      Schreibs mal als fixen Eintrag ins Config File
      /etc/networking

      Sollte zwar keinen Unterschied machen aber vlt hilfts... Hatte das Problem auch mal, konnte damals erst garnicht eine IP zuweisen. (damals scheiterte es an einem Kernelmodul)
      Config Dateien für Netzwerke bei Ubuntu ist: /etc/network/interfaces
      Eintrag für das Interface mit dem crossover-Kabel sollte ungefähr so aussehen:
      code:
      auto eth0
      
      iface eth0 inet static
      address 10.1.1.2
      netmask 255.255.255.0
      broadcast 10.1.1.255
      

      btw: hast du was gegen den klassischen IP Raum für class C netze(also 192.168.x.x). 10.1.1.0/8 sieht irgendwie seltsam aus. ^^
    • MrNike
      MrNike
      Bronze
      Dabei seit: 13.03.2005 Beiträge: 2.826
      code:
      auto eth0
       iface eth0 inet static
              address 10.1.1.2
              netmask 255.255.255.0
              network 10.1.1.0
              broadcast 10.1.1.255 


      So schaust bei mir in der interfaces aus ... sollte gehen ?! Tut e saber net .. problem wie oben beschrieben. Dann stellt sich die Frage wie ich dem PC sagen er soll fuer die IP 10.1.1.1 nicht übers WLAN routen sondern über die LAN Karte.

      Die lokalen IP Ranges die verwendet werden sidn ja recht egal .. solange sie sich in den für lokale Netze freigegebene befinden ... 10.x.x.x ist besser als 192.168.x.x ;)
    • MrNike
      MrNike
      Bronze
      Dabei seit: 13.03.2005 Beiträge: 2.826
      Original von elbarto132
      oben rechts bei der uhr haste son netzwerk config tool was dir deine settings im normalfall immer wieder überschreibt. entweder das teil deinstallieren, oder da in den eigenschaften den roaming mode deaktivieren, denn sollte er es auch netmehr überschreiben, bzw halt direkt damit die ip festlegen
      Ahja ... ich hab kein X Windows installiert .... daher auch keien Uhr ;) also nur ne Konsole ... da smit dem überschreiben hab ich auch gedacht ... wuesste nur net welches tool das macht.
    • DerIch
      DerIch
      Bronze
      Dabei seit: 25.02.2007 Beiträge: 1.331
      Original von MrNike
      10.x.x.x ist besser als 192.168.x.x ;)
      Aha, warum? Hast du tausende PCs daheim?

      Btw. diese Unterscheidung in Class A/B/C Netzwerke findet schon einige Zeit nicht mehr statt, sondern gibts eigentlich nur noch aus rein akademischen Gründen...
    • MrNike
      MrNike
      Bronze
      Dabei seit: 13.03.2005 Beiträge: 2.826
      Original von DerIch
      Original von MrNike
      10.x.x.x ist besser als 192.168.x.x ;)
      Aha, warum?
      Darum eben ... siehe ;) am ende ... ist doch wurscht und off topic hier ...
    • dusterl
      dusterl
      Bronze
      Dabei seit: 14.07.2006 Beiträge: 2.090
      Bevor du am routing rumspielst:
      Hast du mal das WLAN interface runtergefahren und geschaut ob er dann verbindung zum anderen rechner übers LAN aufbauen kann?
      $ ifdown wlan0(oder wie auch immer dein wlan interface heisst)
    • MrNike
      MrNike
      Bronze
      Dabei seit: 13.03.2005 Beiträge: 2.826
      Also update. Connection funtzt. Ich kann von beiden Seiten pingen. allerdings verschwindet die IP adresse nach einigen Sekunden wieder und 'eth0' auf linux seite ist unkonfiguriert.
      Starte ich das netzwerk wieder neu .. geht es wieder fuer ein paaar sek.

      code:
      auto eth0
       iface eth0 inet static
              address 10.1.1.2
              netmask 255.255.255.0
              network 10.1.1.0
              broadcast 10.1.1.255
              route add -net 10.1.1.0 netmask 255.255.255.0 gw 10.1.1.2 eth0 


      sind die aktuellen interface settings. ich hab im gefühl irgendwas löscht die gesetzten wert nach ein paar sekunden ....
    • elbarto132
      elbarto132
      Bronze
      Dabei seit: 24.03.2008 Beiträge: 4.622
      wie bereits geschrieben, das macht das "tolle" network manager tool, also:
      sudo apt-get remove network-manager
      ;)
    • 1
    • 2