Elephant nach Neuinstallation nicht brauchbar

    • doomian
      doomian
      Bronze
      Dabei seit: 23.06.2007 Beiträge: 925
      Also ich versuche mal, mein Problem zu erklären:
      Ich hatte Elephant einige Wochen nicht benutzt.
      Jetzt habe ich ihn deinstalliert und wollte ihn dann neu installieren und quasi von Null anfangen.
      Postgresql habe ich auch nach anleitung deinstalliert und auch sonst alles gelöscht, was mit elephant oder postgre zu tun hatte.

      Jetzt habe ich also den Elephant neu installiert.
      Musste allerdings bei der Installation feststellen, dass sich nur der Elephant installiert hat. Keine Meldung von postgre, wie es damals bei der ersten Installation der Fall war.

      Beim Start des Elephant sollte ich dann das Passwort für den alten benutzer eingeben, also der mit dem ich Elephant vor ein paar Wochen benutzt habe.
      Das Passwort weiss ich nicht mehr.

      Also wieso ist mein alter Benutzer trotzdem noch da, obwohl ich alles gelöscht habe?

      Wie kriege ich Elephant wirklich wieder von null an installiert, sodass auch bei der Installation der Postgre-Benutzer erstellt wird?
  • 12 Antworten
    • MrFloppyHH
      MrFloppyHH
      Bronze
      Dabei seit: 25.10.2006 Beiträge: 222
      Gleiches Problem wäre auch dankbar für Antworten!
    • cLue
      cLue
      Bronze
      Dabei seit: 04.06.2005 Beiträge: 2.186
      Keine Ahnung, ob das damit geht, aber generell kann in man in der pg_hba.conf einstellen, dass man für lokale Datenbankzugriffe kein Passwort benötigt.

      orginal:
      host all all 127.0.0.1/32 md5


      neu: (für IPv4)
      host all all 127.0.0.1/32 trust


      Löst das das Problem ?
      - anderenfalls gibt es noch einen work-around

      cLue
    • MrFloppyHH
      MrFloppyHH
      Bronze
      Dabei seit: 25.10.2006 Beiträge: 222
      Wo findet man denn diese
      pg_hba.conf

      sorry falls die Frage blöd ist hab nicht wirklich viel Ahnung
    • cLue
      cLue
      Bronze
      Dabei seit: 04.06.2005 Beiträge: 2.186
      Im Ordner deiner psql installation unter: /data/pg_hba.conf
    • dardanos
      dardanos
      Bronze
      Dabei seit: 26.07.2007 Beiträge: 633
      hallo doomian, freut mich, dass du wieder online bist.
      du hast offenbar unser Freundeswerbungsprogramm vergessen:

      suche jemanden der mich auf FullTilt wirbt und mir 20€ von seinen $100 abgibt

      Ich habe bereits über 5000 FTP erspielt^^ Nicht alzu schlimm, doch freue ich mich nun auf eine rasche Überweisung

      sorry für Offtopic

      wünsche dir alles gute mit dem Elephant und vor Allem gute Hände!
    • doomian
      doomian
      Bronze
      Dabei seit: 23.06.2007 Beiträge: 925
      das geld ist unterwegs ;)

      back to topic:
      ich kann keine dateien von postgre editieren, weil das ja gar nicht mitinstalliert wird.
      ich installiere wie gesagt nur den elephant, die automatische postgreinstallation erscheint erst gar nicht.

      edit:
      hab jetzt postgre mal manuell installiert und die datei editiert.
      das problem ist das gleiche:
      wenn ich den elephant starte bekomme ich eine info in der steht, dass ich zuerst eine neue Datenbank anlegen soll.
      Dazu soll ich die gewählte kombination aus passwort und benutzername eingeben.

      nach dem klick auf ok öffnet sich ein fenster mit dem bereits eingetragenen benutzernamen doomian (der von der ersten installation vor ein paar wochen)
      und dem leeren passwort-feld.

      also wieso steht da immer noch dieser alte benutzername obwohl ich doch alles was mit elephant und postgre zu tun hat gelöscht habe.
      ich denke mal, weil da irgendwo noch was vorhanden ist, wird postgresql bei der neuinstallation von elephant auch nicht mitinstalliert und somit kein benutzername und kennwort festegelegt.

      also wer hat ne idee?
      kann ich den alten benutzernamen irgendwie löschen?
      kann ich das passwort für den irgendwie rausfinden?
      kann ich das ganze umgehen und einen neuen benutzernamen und passwort anlegen?
    • cLue
      cLue
      Bronze
      Dabei seit: 04.06.2005 Beiträge: 2.186
      Sorry, hatte den Text anders verstanden...

      Hast du schon versucht die Datenbank manuell zu installieren (http://www.postgresql.org/)?
      - dann solltest du einen neuen Nutzer anlegen können und diesen dann auch im Elephant nutzen.

      Okay, nach deinem Edit zieht dann wohl dieser Teil:
      Und nur um Missverständnisse zu vermeiden: Hast du den Windows User (Computerverwaltung ==> Locale Benutzer und Gruppen ==> Benutzer), der von postgres angelegt wurde gelöscht ?

      Edit: Als PC Admin, solltest du diesem auch ein neues Passwort zuweisen können.

      cLue
    • doomian
      doomian
      Bronze
      Dabei seit: 23.06.2007 Beiträge: 925
      ja, wie gesagt ich hatte alles gelöscht.
      also ganz normal über systemsteuerung-software
      den benutzer, die restlichen dateien, einträge in der registry...
    • cLue
      cLue
      Bronze
      Dabei seit: 04.06.2005 Beiträge: 2.186
      urgs, dann bin ich mir auch nicht sicher - sorry.
      Werde nochmals drüber schauen wenn ich am privaten PC bin ...
    • Iceley78
      Iceley78
      Bronze
      Dabei seit: 23.10.2007 Beiträge: 982
      Hallo, hatte auch so meine probleme mit postgres nach der De-Inst. X(

      http://www.pg-forum.de/h-ufig-gestellte-fragen-faq/939-entfernen-de-installation-von-postgresql-unter-windows.html

      Mit der Batchdatei sollte es klappen. Einfach den Code kopieren in ein neues Textdokument einfügen abspeichern und Umbenennen in"postgres.delete.bat" Danach sollte die Installation wieder problemlos klappen:-)
    • doomian
      doomian
      Bronze
      Dabei seit: 23.06.2007 Beiträge: 925
      danke für die antwort, aber die batchdatei hatte ich gestern abend auch schon 3 mal durchlaufen lassen.
      jedes mal mit dem oben beschriebenen ergebniss.
    • doomian
      doomian
      Bronze
      Dabei seit: 23.06.2007 Beiträge: 925
      hab mich jetzt nochmal dran gewagt, nochmal alles durchsucht etc...
      es hat jetzt endlich funktioniert.
      hab jetzt die neue version vom elephant und ne frische datenbank.
      danke nochmal für die tipps.