Kann keine Datenbank erstellen, bitte um Hilfe!!

    • Dragonheart
      Dragonheart
      Bronze
      Dabei seit: 23.09.2006 Beiträge: 747
      Hallo,

      ich habe Elephant installiert. Wie lege ich denn eine Datenbank an? Das funktioniert bei mir überhaupt nicht. Immer kommt die Fehlermeldung: Es konnte Keine Verbindung zum Datenserver aufgebaut werden. Failes to establish a connection to 127.0.0.1

      Was soll ich den tun, es ist zum Verzweifeln.

      Danke für eure Hilfe
  • 14 Antworten
    • yoyo87
      yoyo87
      Bronze
      Dabei seit: 05.01.2007 Beiträge: 59
      exakt das selbe problem bei mir!! siehe mein thread^^
    • michback06
      michback06
      Bronze
      Dabei seit: 18.03.2008 Beiträge: 4
      Das gleiche problem hab ich auch!!! brauche hilfe!!! hab postgre SQL 8.3 mittlerweile schon seperat installiert so das ich die datenbank hab,aber dann steh ich vor dem problem das er das passwort nicht akzeptiert
      ( Fatal: 28000:password authentcation failed for user "elephant")
      ansonsten echt schon einige variationen ausprobiert, irgendwas haut da echt nicht hin...


      hoffe das jemand eine lösung hat ??!!??


      Mfg Mic
    • royalstreet
      royalstreet
      Bronze
      Dabei seit: 09.04.2008 Beiträge: 660
      same problem here.
    • Zerberus1985
      Zerberus1985
      Silber
      Dabei seit: 14.07.2006 Beiträge: 1.089
      An Dragonheart und yoyo einfach mal im verzeichnis von pokerstrategy postgre SQl 8.3 seperat installieren.
      So hat es bei mir geklappt. Wenn es dann zu Passwortproblemen kommt hier weiterlesen.

      Michiback und royalstreeet gebt mal als benutzernamen nicht elephant sondern postgres und euer Passwort an. Dann sollte das auch klappen.

      Sagt mal bitte ob es bei euch geklappt hat. Haben wahrscheinlich noch ein paar Leute hier und so funktioniert es bei mir.
    • karouchi
      karouchi
      Bronze
      Dabei seit: 14.12.2008 Beiträge: 3
      versuchen Sie es denn so:
      start=>Alle Programme =>PostgreSQL 8.3 => Stop Device
      und dann:
      start=>Alle Programme =>PostgreSQL 8.3 => Start device
      danach können Sie Ihre datenbank problemlos erstellen, bei mir hat es geklappt.
      viel Glück ;)
    • Dragonheart
      Dragonheart
      Bronze
      Dabei seit: 23.09.2006 Beiträge: 747
      Zuerst einmal Danke für eure Antworten.

      Habe nun alles probiert start-stop von postgres. Deinstalliert-Installiert

      Nicht tut sich. Gibt es denn niemanden von PS-Support der einem weiter helfen kann.

      Für was wird mir so ein Tool angeboten und es funktioniert einfach nicht.

      Grüße

      D
    • yoyo87
      yoyo87
      Bronze
      Dabei seit: 05.01.2007 Beiträge: 59
      Original von Zerberus1985
      An Dragonheart und yoyo einfach mal im verzeichnis von pokerstrategy postgre SQl 8.3 seperat installieren.
      So hat es bei mir geklappt. Wenn es dann zu Passwortproblemen kommt hier weiterlesen.

      Michiback und royalstreeet gebt mal als benutzernamen nicht elephant sondern postgres und euer Passwort an. Dann sollte das auch klappen.

      Sagt mal bitte ob es bei euch geklappt hat. Haben wahrscheinlich noch ein paar Leute hier und so funktioniert es bei mir.
      wie du sagtest, es kommt zu passwortproblemen, ich werd erneut nach den login daten gefragt kenne diese aber nicht mehr. den weg über windows das rauszufinden hab ich auch schon versucht (vgl anderer thread) aber da fand ich nichts :(
    • Zerberus1985
      Zerberus1985
      Silber
      Dabei seit: 14.07.2006 Beiträge: 1.089
      Das Passwort steht bei dir nicht unter Benutzer->dein Konto->AppData->Local->Pokerstrategy Elephant->PokerStrategy_Elephant.ex_Url_f2wbchtgfc2j0vhccoz2ew5vs5kofupk-> 0.67.0.0->user. config ??

      Du solltest da nochmal nach deinem Passwort gucken. Steht in der Datei bei mir fast am Ende.

      Wenn du es gefunden hast einfach mit dem Benutzernamen postgres versuchen elephant zu starten.
    • Phillemon
      Phillemon
      Bronze
      Dabei seit: 08.12.2008 Beiträge: 1.093
      Ich habe noch eine alternative Lösungsvariante, die hoffentlich all denen helfen sollte, die noch Probleme haben. Die Probleme, welche hier geschildert sind traten bei mir auch auf und ich hab sie folgendermaßen behoben (Die Anleitung hab ich über etwas experimentieren und das Internet gefunden :D ):

      Name der Datenbank: elephantdb (die ist glaube ich, wenn ihr postgreSQL über elephant installiert schon angelegt bzw wird angelegt - alternativ lässt sich der name auch über den postgreSQL admin service rausfinden, wobei man dafür aber das pw braucht :o )


      Passwort: an dieser Stelle ist das ganze bei mir gescheitert, da bei der elephant/postgresql installation mir kein pw genannt wurde, wie anscheinend bei einigen.
      1. Startmenü>postgreSQL>Configuration files>pg_hba.conf (Diese Datei mit Texteditor öffnen)
      2. die letzten Zeilen der pg_hba.conf sehen ungefähr so aus:

      # TYPE DATABASE USER CIDR-ADDRESS METHOD

      # IPv4 local connections:
      host all all ---.-.-.-/-- md5
      # IPv6 local connections:
      host all all ::-/--- md5

      hier habe ich den Wert md5 in den Wert trust verändert, es sah danach also bei mir ca so aus:

      # TYPE DATABASE USER CIDR-ADDRESS METHOD

      # IPv4 local connections:
      host all all ---.-.-.-/-- trust
      # IPv6 local connections:
      host all all ::-/--- trust

      Bitte beachten, ob die Datei schreibgeschützt ist, bei mir war dem so, ich hoffe es ist jeder soweit fähig das auszuschalten bzw zu umgehen.
      3. Startmenü>PostgreSQL>Pgadmin ausführen
      4. im Admin die Datenbank öffnen
      5. im Admin oben Datei>Password ändern> altes passwort braucht ihr nichts eingeben, bzw wenn es nicht ohne geht ist es irrelevant, was man eingibt neues passwort, welches man selber wählt eingeben und bestätigen
      6. Admin schließen nach dem setzen des neuen pw
      7. die werte trust in der Datei pg_hba.conf wieder auf md5 ändern
      8. elephant starten, datenbankname siehe oben eingeben, das neue passwort eingeben
      9. sich freuen wenn es geht und mir hier bitte bescheid geben, damit ich bescheid weiß, dass es funktioniert, ansonsten trotzdem bescheid geben, damit wir weiter an dem problem arbeiten können
    • AndreSch
      AndreSch
      Bronze
      Dabei seit: 20.09.2007 Beiträge: 47
      HI zusammen!

      Ich hab mich gerade mit dem Admin-tool rumgeprügelt und jetzt funzt es, ich hatte auch den Passwortfehler. Kommen wir nun zu dem was ich gemacht hab ;-)

      Adminkonsole öffnen-> PostgreSQL Database Server 8.3 anwählen und auf verbinden gehen -> nun Login-Rolle... unter neues Objekt hinzufügen -> ich hab als default einfach "postgre" als Rollen-name verwendet -> passwort reinschreiben -> hacken bei kann Datenbanken anlegen und kann weitere Rollenanlegen -> zu letzt noch den OK butten und nun sollte es gehen. danach kann man ganz normal mit dem Elephant dantenbanken erstellen
    • michback06
      michback06
      Bronze
      Dabei seit: 18.03.2008 Beiträge: 4
      halllo,

      danke für die vielen tipps!!!

      hat mir leider nichts von geholfen, hab jetzt letztendlich eine Systemwiederherstellung gemacht,ele neu installiert, jetzt läuft er wieder:-)

      trotzdem danke...

      mfg mic
    • suinha
      suinha
      Bronze
      Dabei seit: 31.12.2007 Beiträge: 7
      Hallo Zusammen,

      ich könnte das Probeem bei mir lösen indem ich die v61 installiert habe, hierbei wird die Option die DB zu installieren angezeigt inkl. PW-Vergabe.
      Nach der Installation von v61 einfach das PW für den elephant Benutzer neu angegeben, DB erstellen lassen und anschliessend v61 einfach einmal starten lassen. Somit war alles wieder eingerichtet. Daraufhin habe ich v67 installiert und alles funktioniert wieder.

      Ich hoffe es hilft Euch weiter.
      gruss
      suinha
    • Dragonheart
      Dragonheart
      Bronze
      Dabei seit: 23.09.2006 Beiträge: 747
      Hallop Phillemon,

      wollte mit deinen Punkten angfangen. Nur wenn ich auf mein Startmenü gehe so finde ich kein postgres, da ich elephant mit postgres von PS runtergeladen habe.

      Sehe ich das richtig?

      Oder wie könnte ich das noch finden.

      Danke für die Hilfe
    • Phillemon
      Phillemon
      Bronze
      Dabei seit: 08.12.2008 Beiträge: 1.093
      naja postgres müsste ja bei dir installiert sein, das geschieht normalerweise spätestens mit der elephant installation, deshalb müsstest du auch einen postgres ordner haben, wenn du keinen startmenü link hast musst du vllt mal so auf der festplatte suchen und sollte es gar nicht installiert sein vermute ich mal liegt es daran