PostgreSQL startet nicht

    • Coldfac3
      Coldfac3
      Bronze
      Dabei seit: 10.10.2008 Beiträge: 58
      Habe seit der letzten nutzung des elephants nur ein windowsupdate gezogen und plözlich kann der elephant nicht mehr auf meine Datenbank zugreifen. Bei einem blick auf die prozesse musste ich feststellen, dass PostgreSQL nicht startet. Beim schließen des Elephants kam noch folgende Debug message:

      OS: Microsoft Windows NT 5.1.2600 Service Pack 3
      .NET Runtime: 2.0.50727.832
      RAM: 2GB
      Processors: 1
      CPU: x86 Family 15 Model 12 Stepping 0: 0/32/2, 2210

      Software version: 0.67

      (10) Log: 11:45:11.50 -- Logfile set: C:\Documents and Settings\Henne\Local Settings\Application Data\PokerStrategy\Elephant\log.txt
      (10) Log: 11:45:11.50 -- Logfile cleared: C:\Documents and Settings\Henne\Local Settings\Application Data\PokerStrategy\Elephant\log.txt
      (10) Log: 11:47:37.70 -- , line 0: System.NullReferenceException: Object reference not set to an instance of an object.
      at PokerStrategyElephant.DatabasesForm.Init()
      (10) , line 0: System.NullReferenceException: Object reference not set to an instance of an object.
      at PokerStrategyElephant.DatabasesForm.Init()


      Was kann ich tun?? Bitte sagt mir nicht ich muss Postgre neu installieren, weil dann meines wissens nach die alten DBs weg sind!

      Mfg
  • 17 Antworten
    • Coldfac3
      Coldfac3
      Bronze
      Dabei seit: 10.10.2008 Beiträge: 58
      Auch das Erstellen einer neuen DB geht nicht (wie auch, ohne das sich PostgreSQL aktiviert).
      Gibt es einen Lösungsvorschlag oder muss ich alles neu installieren??

      Ein wenig Support wäre echt eine feine Sache!!

      MFG
    • Iarwe
      Iarwe
      Bronze
      Dabei seit: 04.02.2006 Beiträge: 785
      Hast Du versucht den PostgreSQL Service zu starten und dann nochmal den Elephant probiert?
    • Coldfac3
      Coldfac3
      Bronze
      Dabei seit: 10.10.2008 Beiträge: 58
      Keine Ahnung wo ich den manuell starten soll. Aber das ist ja auch nicht im Sinne des Erfinders?
      Wo starte ich den Service?? (dachte mit ner .exe im PostgreSQL Ordner, nur da ist iwie keine passende zu finden)
    • Iarwe
      Iarwe
      Bronze
      Dabei seit: 04.02.2006 Beiträge: 785
      Start->Programme->PostegreSQL 8.3->Start service
    • Coldfac3
      Coldfac3
      Bronze
      Dabei seit: 10.10.2008 Beiträge: 58
      Ok ich habs gefunden. Der Service versucht zu starten (DOS Fenster popt auf aber nach ner weile schließt es sich und kein prozess im Taskmanager zu finden, der auf Postgre deuten könnte).

      Wo sind eigentlich die DBs gespeichert?? Kann ich die sichern?? Im Datenbankmanager vom Elephant werden keine angezeigt.
    • Iarwe
      Iarwe
      Bronze
      Dabei seit: 04.02.2006 Beiträge: 785
      Die Datenbanken speichert Postgres. Deswegen kannst Du sie auch nicht im Datenbankmanager vom Elephant sehen, wenn Postgres aktiv ist.

      Mach mal bitte folgendes:

      - Starte deinen Rechner neu.
      - Guck nach, ob postgres aktiv ist
      - Wenn nicht, dann starte den Postgres Service manuell
      - Wenn er wieder nicht startet, würde ich gerne wissen, was in der LogDatei steht im Verzeichnis: C:\Programme\PostgreSQL\8.3\data\pg_log (nur die von heute)
    • Coldfac3
      Coldfac3
      Bronze
      Dabei seit: 10.10.2008 Beiträge: 58
      Sorry aber er legt kein Logfile an. Das letzte ist vom 23.01.09 (da ging alles noch soweit ich mich erinnere). Kannst du damit was anfangen??
    • Iarwe
      Iarwe
      Bronze
      Dabei seit: 04.02.2006 Beiträge: 785
      Was steht da denn drin?
    • Coldfac3
      Coldfac3
      Bronze
      Dabei seit: 10.10.2008 Beiträge: 58
      2009-01-23 11:19:52 CET LOG: database system was shut down at 2009-01-22 23:47:52 CET
      2009-01-23 11:19:52 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-23 11:19:52 CET FATAL: the database system is starting up
      2009-01-23 11:19:52 CET LOG: database system is ready to accept connections
      2009-01-23 11:19:53 CET LOG: autovacuum launcher started
      2009-01-23 11:19:53 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-23 11:29:52 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-23 11:29:54 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-23 11:29:55 CET LOG: could not receive data from client: No connection could be made because the target machine actively refused it.


      2009-01-23 11:29:55 CET LOG: unexpected EOF on client connection
      2009-01-23 12:10:10 CET WARNING: nonstandard use of \' in a string literal at character 27
      2009-01-23 12:10:10 CET HINT: Use '' to write quotes in strings, or use the escape string syntax (E'...').
      2009-01-23 12:10:10 CET WARNING: nonstandard use of \' in a string literal at character 200
      2009-01-23 12:10:10 CET HINT: Use '' to write quotes in strings, or use the escape string syntax (E'...').
      2009-01-23 12:10:12 CET WARNING: nonstandard use of \' in a string literal at character 27
      2009-01-23 12:10:12 CET HINT: Use '' to write quotes in strings, or use the escape string syntax (E'...').
      2009-01-23 12:10:12 CET WARNING: nonstandard use of \' in a string literal at character 200
      2009-01-23 12:10:12 CET HINT: Use '' to write quotes in strings, or use the escape string syntax (E'...').
      2009-01-23 12:21:11 CET WARNING: nonstandard use of \' in a string literal at character 27
      2009-01-23 12:21:11 CET HINT: Use '' to write quotes in strings, or use the escape string syntax (E'...').
      2009-01-23 12:21:11 CET WARNING: nonstandard use of \' in a string literal at character 200
      2009-01-23 12:21:11 CET HINT: Use '' to write quotes in strings, or use the escape string syntax (E'...').
      2009-01-23 12:21:11 CET LOG: could not receive data from client: No connection could be made because the target machine actively refused it.


      2009-01-23 12:21:11 CET LOG: unexpected EOF on client connection
      2009-01-23 12:24:21 CET LOG: received fast shutdown request
      2009-01-23 12:24:21 CET LOG: aborting any active transactions
      2009-01-23 12:24:21 CET LOG: autovacuum launcher shutting down
      2009-01-23 12:24:21 CET LOG: shutting down
      2009-01-23 12:24:21 CET LOG: database system is shut down



      2009-01-23 18:01:08 CET LOG: database system was shut down at 2009-01-23 12:24:21 CET
      2009-01-23 18:01:08 CET LOG: database system is ready to accept connections
      2009-01-23 18:01:08 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-23 18:01:08 CET FATAL: the database system is starting up
      2009-01-23 18:01:08 CET LOG: autovacuum launcher started
      2009-01-23 18:01:09 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"



      + eine weiter datei mit 560 bytes in der aber nix drin steht :(
    • Coldfac3
      Coldfac3
      Bronze
      Dabei seit: 10.10.2008 Beiträge: 58
      Wenn die DBs in PostgreSQL verwaltet werden, muss ich die doch iwie finden und sichern können oder nicht?? Was sagt das Logfile? Würde ja auch einfach Postgre neu installieren, wenn ich vorher die DBs noch retten kann, dann sagt mir bitte wie.

      Thx und MFG
    • sledgeDaemmer
      sledgeDaemmer
      Bronze
      Dabei seit: 07.09.2006 Beiträge: 151
      habe seit gestern das selbe Problem.. habe nichts neu installiert oder aehnliches.

      Postgres laesst auch nicht manuell ueber Dienste Starten.

      Mein Log:

      2009-01-27 05:30:48 CET ERROR: prepared statement "hhexecute" already exists
      2009-01-27 05:30:48 CET STATEMENT:

      ....

      2009-01-27 06:58:58 CET LOG: could not receive data from client: Unknown winsock error 10061
      2009-01-27 06:58:58 CET LOG: unexpected EOF on client connection
      2009-01-27 06:58:58 CET LOG: could not receive data from client: Unknown winsock error 10061
      2009-01-27 06:58:58 CET LOG: unexpected EOF on client connection
      2009-01-27 06:59:05 CET LOG: received fast shutdown request
      2009-01-27 06:59:05 CET LOG: aborting any active transactions
      2009-01-27 06:59:05 CET LOG: autovacuum launcher shutting down
      2009-01-27 06:59:05 CET LOG: shutting down
      2009-01-27 06:59:05 CET LOG: database system is shut down
    • Benido
      Benido
      Bronze
      Dabei seit: 14.04.2006 Beiträge: 13.853
      2009-01-26 15:30:25 CET LOG: database system was shut down at 2009-01-26 15:30:20 CET
      2009-01-26 15:30:25 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-26 15:30:25 CET FATAL: the database system is starting up
      2009-01-26 15:30:25 CET LOG: database system is ready to accept connections
      2009-01-26 15:30:25 CET LOG: autovacuum launcher started
      2009-01-26 15:30:26 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-26 15:30:28 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-26 15:30:29 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-26 15:30:30 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-26 15:36:06 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-26 15:36:07 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-26 15:36:07 CET FATAL: database "elephantdb" does not exist
      2009-01-26 15:36:07 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-26 15:36:07 CET FATAL: database "elephantdb" does not exist
      2009-01-26 15:36:07 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-26 15:36:07 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "id" for table "archive"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "category_pkey" for table "category"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "comment_pkey" for table "comment"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "comment_on_player_pkey" for table "comment_on_player"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "hh_id" for table "fullhh"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "game_pkey" for table "game"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "gamechat_pkey" for table "gamechat"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "gameplayer_pkey" for table "gameplayer"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "gametable_pkey" for table "gametable"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE will create implicit sequence "gametype_game_type_id_seq1" for serial column "gametype.game_type_id"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "gametype_pkey" for table "gametype"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "media_content_pkey" for table "media_content"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE will create implicit sequence "player_player_id_seq" for serial column "player.player_id"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "player_pkey" for table "player"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "playerstat_pkey" for table "playerstat"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "playlist_pkey" for table "playlist"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "playlist_item_pkey" for table "playlist_item"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "portal_pkey" for table "portal"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "quiz_pkey" for table "quiz"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "quiz_answer_pkey" for table "quiz_answer"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "realplayer_pkey" for table "realplayer"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "sorted_cards_pkey" for table "sorted_cards"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "tournament_pkey" for table "tournament"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "trmt_payoutstructure_pkey" for table "trmt_payoutstructure"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "trmt_player_pkey" for table "trmt_player"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE will create implicit sequence "unclear_id_seq1" for serial column "unclear.id"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "unclear_pkey" for table "unclear"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "uploader_pkey" for table "uploader"
      2009-01-26 15:36:08 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "version_pkey" for table "version"
      2009-01-26 15:36:09 CET NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "triggstop_pkey" for table "triggstop"
      2009-01-26 15:36:09 CET LOG: could not receive data from client: Unknown winsock error 10061
      2009-01-26 15:36:09 CET LOG: unexpected EOF on client connection
      2009-01-26 15:39:31 CET LOG: could not receive data from client: Unknown winsock error 10061
      2009-01-26 15:39:31 CET LOG: unexpected EOF on client connection
      2009-01-26 15:39:31 CET LOG: could not receive data from client: Unknown winsock error 10061
      2009-01-26 15:39:31 CET LOG: unexpected EOF on client connection
      2009-01-26 15:40:03 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-26 15:40:03 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-26 15:40:26 CET LOG: could not receive data from client: Unknown winsock error 10061
      2009-01-26 15:40:26 CET LOG: unexpected EOF on client connection
      2009-01-26 16:29:55 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-26 16:29:55 CET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
      2009-01-26 16:42:33 CET LOG: checkpoints are occurring too frequently (27 seconds apart)
      2009-01-26 16:42:33 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 16:42:40 CET LOG: checkpoints are occurring too frequently (7 seconds apart)
      2009-01-26 16:42:40 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 16:42:53 CET LOG: checkpoints are occurring too frequently (13 seconds apart)
      2009-01-26 16:42:53 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 16:43:02 CET LOG: checkpoints are occurring too frequently (9 seconds apart)
      2009-01-26 16:43:02 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 16:43:17 CET LOG: checkpoints are occurring too frequently (15 seconds apart)
      2009-01-26 16:43:17 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 16:43:26 CET LOG: checkpoints are occurring too frequently (9 seconds apart)
      2009-01-26 16:43:26 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 16:44:08 CET LOG: checkpoints are occurring too frequently (11 seconds apart)
      2009-01-26 16:44:08 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 16:44:19 CET LOG: checkpoints are occurring too frequently (11 seconds apart)
      2009-01-26 16:44:19 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 16:45:43 CET LOG: checkpoints are occurring too frequently (8 seconds apart)
      2009-01-26 16:45:43 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 16:58:40 CET LOG: checkpoints are occurring too frequently (9 seconds apart)
      2009-01-26 16:58:40 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 16:59:54 CET LOG: checkpoints are occurring too frequently (9 seconds apart)
      2009-01-26 16:59:54 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 17:00:04 CET LOG: checkpoints are occurring too frequently (10 seconds apart)
      2009-01-26 17:00:04 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 17:00:12 CET LOG: checkpoints are occurring too frequently (8 seconds apart)
      2009-01-26 17:00:12 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 17:00:21 CET LOG: checkpoints are occurring too frequently (9 seconds apart)
      2009-01-26 17:00:21 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 17:00:33 CET LOG: checkpoints are occurring too frequently (12 seconds apart)
      2009-01-26 17:00:33 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 17:00:44 CET LOG: checkpoints are occurring too frequently (11 seconds apart)
      2009-01-26 17:00:44 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 17:00:54 CET LOG: checkpoints are occurring too frequently (10 seconds apart)
      2009-01-26 17:00:54 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 17:01:03 CET LOG: checkpoints are occurring too frequently (9 seconds apart)
      2009-01-26 17:01:03 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 17:01:13 CET LOG: checkpoints are occurring too frequently (10 seconds apart)
      2009-01-26 17:01:13 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 17:01:24 CET LOG: checkpoints are occurring too frequently (11 seconds apart)
      2009-01-26 17:01:24 CET HINT: Consider increasing the configuration parameter "checkpoint_segments".
      2009-01-26 17:05:13 CET LOG: could not receive data from client: Unknown winsock error 10061
      2009-01-26 17:05:13 CET LOG: unexpected EOF on client connection
      2009-01-26 17:05:46 CET LOG: received fast shutdown request
      2009-01-26 17:05:46 CET LOG: aborting any active transactions
      2009-01-26 17:05:46 CET LOG: autovacuum launcher shutting down
      2009-01-26 17:05:47 CET LOG: shutting down
      2009-01-26 17:05:47 CET LOG: database system is shut down


      hi leute!

      hier das log von nem spanischem user, kann seit heute morgen nicht mehr auf die DBs zugreifen... soll eine neue DB einrichten und kann nicht, der manuelle start von PSQ hat nichts gebracht.

      haben die anderen da mittlerweile ihre probleme lösen können?


      gruß

      benido
    • Nosenada
      Nosenada
      Bronze
      Dabei seit: 15.10.2008 Beiträge: 84
      Ok soy spanish
    • Coldfac3
      Coldfac3
      Bronze
      Dabei seit: 10.10.2008 Beiträge: 58
      push


      Antworten???
    • ZipfelHH
      ZipfelHH
      Bronze
      Dabei seit: 18.12.2008 Beiträge: 81
      Habe das gleich Problem. Der Elephant will ne neue DB anlegen. Geht aber nicht... PostgresAQL lässt sich nicht manuell starten. Habe heute mein XP auf SP3 geupdatet. dachte das hätte evtl. damit zu tun?! aber einige haben hier ja das selber problem ohne update....
      hat jemand noch nen guten rat???

      Außerdem habe bin ich von IE6 auf IE7 gewechselt. Blockt der vllcht irgendwelche ports???
    • Timon832
      Timon832
      Bronze
      Dabei seit: 27.02.2007 Beiträge: 1.190
      Habe gleiches Problem!
      Ich habe letztens das SP3 installiert.
      Scheint wohl daran zu liegen.
    • xxxTiCaLxxx
      xxxTiCaLxxx
      Bronze
      Dabei seit: 28.06.2007 Beiträge: 1.973
      hatte auch grad wieder das prob.

      lösung: postmaster.pid löschen + neustart