Server doesn't listen

    • baschin
      baschin
      Global
      Dabei seit: 08.11.2007 Beiträge: 879
      Server doesn't listen The server doesn't accept connections: the connection library reports konnte nicht mit dem Server verbinden: Connection refused (0x0000274D/10061) Läuft der Server auf dem Host »127.0.0.1« und akzeptiert er TCP/IP-Verbindungen auf Port 5432? If you encounter this message, please check if the server you're trying to contact is actually running PostgreSQL on the given port. Test if you have network connectivity from your client to the server host using ping or equivalent tools. Is your network / VPN / SSH tunnel / firewall configured correctly? For security reasons, PostgreSQL does not listen on all available IP addresses on the server machine initially. In order to access the server over the network, you need to enable listening on the address first. For PostgreSQL servers starting with version 8.0, this is controlled using the "listen_addresses" parameter in the postgresql.conf file. Here, you can enter a list of IP addresses the server should listen on, or simply use '*' to listen on all available IP addresses. For earlier servers (Version 7.3 or 7.4), you'll need to set the "tcpip_socket" parameter to 'true'. You can use the postgresql.conf editor that is built into pgAdmin III to edit the postgresql.conf configuration file. After changing this file, you need to restart the server process to make the setting effective. If you double-checked your configuration but still get this error message, it's still unlikely that you encounter a fatal PostgreSQL misbehaviour. You probably have some low level network connectivity problems (e.g. firewall configuration). Please check this thoroughly before reporting a bug to the PostgreSQL community.


      kA muss wohl was falsch sein mit dem localhost...
      hab da die postmaster.pid bereits gelöscht, kann den server aber trotzdem nich starten...
      any ideas ?
  • 1 Antwort