PT2 und PAH Performanceprobleme

    • freeheelstar
      freeheelstar
      Bronze
      Dabei seit: 06.10.2006 Beiträge: 63
      Hallo,

      ich hab da ein paar Fragen, weil die Performance von PT leider immer schlechter wird. Ich nutze 2 Datenbanken. Datenbank A in der ich meine eigenen gespielten Hände importiere und Datenbank B für die observed Hands (bei Full Tilt geöffnete Tische an denen ich nicht sitze). Beide Datenbanken habe ich in SQL umgewandelt. Alle 2 Wochen komprimiere ich die beiden SQL Datenbanken.

      Wenn ich die Ring Game Player Statistic von A aufrufe, dann befinden sich in der Datenbank ca. 10.000 Player. In Datenbank B sind ca. 14.000 Player. Komisch ist, dass die Datenbank A 290 MB hat und die Datenbank B nur 1MB. Beide Datenbanken haben die Endung .mdb. Sind die dann im SQL Format? Ich kenn mich da leider nicht so gut aus.

      Möchte ich in A meine eigene Statistik von ca. 300.000 gespielten Händen anzeigen, dann dauert das über 30 Minuten. Ist das normal?

      Es dauert auch immer länger bis die Werte von PAH an den Tischen angezeigt bzw. aktualisiert werden. Ich spiele an 4 Tischen und 10 weitere Tische habe ich zum observen geöffnet. So werden pro Minute ca. 25 Hände von PT in die Datenbank importiert. Das müsste PT2 doch problemlos schaffen.
      Bei Use Database Cache habe ich einen Haken gesetzt. In welchen Zeitabständen sollte ich denn ein Update ausführen?

      Ich nutze einen Laptop Baujahr 2007 mit Arbeitsspeicher 512 MB DDR2 SDRAM. Ist der zum Pokern mit diesen Datenbanken zu schlecht?

      Kann mir vielleicht jemand ein paar Tipps geben, wie ich die Performance steigern kann? Danke.
  • 1 Antwort
    • Ajezz
      Ajezz
      Black
      Dabei seit: 19.07.2005 Beiträge: 10.245
      1. Die *mdb-Dateien sind die Access-Datenbanken. Die SQL-Datenbanken sind im Data-Ordner der Postgres-Installation.
      2. SQL-Datenbanken kann man nicht komprimieren, nur vacuumen und clustern. Die Option "Compress DB" ist nur für Access-DB.
      3. Cache updatet normal automatisch nach jedem Start von PA. Wenn du das nicht eingestellt hast, mußt du halt immer selber drauf klicken.
      4. 30 Minuten ist inakzeptabel, 30 Sekunden würde ich mir gerade noch eingehen lassen.

      Vorschläge:
      Stell sicher, daß du wirklich in eine SQL-Datenbank importierst und nicht (immer noch) in Access. Stell auch sicher, daß du in PA die SQL- und nicht die Access-DB ausgewählt hast. Benutze den Cache.