Elephant klappt nicht, PostgreSQL als Hindernis

    • LORDbobby89
      LORDbobby89
      Bronze
      Dabei seit: 23.10.2008 Beiträge: 11.165
      Nach mittlerweile einigen vergeblichen Versuchen den Elephant zum laufen zu bringen, ersuche ich hier um Hilfe. Das Problem ist, dass mein PC scheinbar Reste einer PostgreSQL-Version enthält, die ich nicht lokalisieren kann, die aber bei der Elephant-Installation die automatische PostgreSQL-Installation verhindern. Somit überspringt das Programm diesen Schritt immer, am Ende habe ich aber dann natürlich keine Datenbank, die die Grundlage des Elephants darstellt. Hier bei PS habe ich eine Anleitung zur kompletten Entfernung von PostgreSQL gefunden und durchgeführt. Danach jedoch wollte mich die Elephant-Installation immer noch nicht nach einer PostgreSQL-Installation fragen. Eine Idee von mir wäre, PostgreSQL manuell herunterzuladen und dann manuell eine Datenbank anzulegen, die ich bei der Elephant-Installation dann angeben könnte. Ich weiß jedoch weder, ob das möglich ist, solange scheinbar noch Reste dieses Programms vorhanden sind und auch nicht welche Version ich ziehen müsste. Ich hoffe, jemand kann mir helfen, falls es Vorschläge gibt, dann bitte möglichst leicht und ausführlich erklärt, mein Verständnis in dieser Hinsicht ist sehr beschränkt :P Danke. =)

      Mit freundlichen Grüßen
      bobby89
  • 13 Antworten
    • LORDbobby89
      LORDbobby89
      Bronze
      Dabei seit: 23.10.2008 Beiträge: 11.165
      ;(
    • karlatiger
      karlatiger
      Bronze
      Dabei seit: 09.02.2007 Beiträge: 116
      Ich kenne das Problem. Lade dir mal folgendes Programm runter.
      http://www.revouninstaller.com/revo_uninstaller_free_download.html

      Mit dem Tool deinstallierst du den Elephant, PostgreSQL und startest dann deinen Pc neu. Das Programm löscht halt auch übrig gebliebene Registry Einträge und sorgt dafür, dass du den Elephant danach erneut "sauber" installieren kannst.
      Mir hat das Tool auf jeden Fall geholfen. Ist eh zu empfehlen.
    • mirostalle
      mirostalle
      Bronze
      Dabei seit: 22.09.2007 Beiträge: 205
      Ich hab das selbe Problem wie bobby, nämlich, dass der elephant jedes mal die installation von PostreSQL nicht startet und ich so keine Datenbank anlegen kann. Wenn ich dann versuche PgSQL manuel zu installieren komme ich auch nie weiter, da ich den Dienst konfigurieren soll und ich nichtweiß wie das geht und was das überhaupt soll.
      Bitte helft uns
    • michlveit
      michlveit
      Bronze
      Dabei seit: 28.11.2008 Beiträge: 679
      bei mir hat er bis jetzt einwandfrei funktioniert
      ab heute kommt bei mir der fehler, dass er nicht zum postgre connecten kann...
      bitte um aufklärung
    • Timmel
      Timmel
      Bronze
      Dabei seit: 10.10.2007 Beiträge: 1.209
      Original von michlveit
      bei mir hat er bis jetzt einwandfrei funktioniert
      ab heute kommt bei mir der fehler, dass er nicht zum postgre connecten kann...
      bitte um aufklärung
      #2

      Bei mir genau das gleiche. Bis heute hat der Elefant gespurt und zack - inzwischen geht nichtsmehr. Hab den 127.0.0.1 Fehler aber der FAQ Lösungsweg bringt keine Abhilfe.
    • LORDbobby89
      LORDbobby89
      Bronze
      Dabei seit: 23.10.2008 Beiträge: 11.165
      Danke für die Beiträge :)
      Ich habe es mal mit der Methode von karlatiger versucht, sprich den Revo Uninstaller heruntergeladen. Danach stoße ich jedoch schon auf das erste Problem. Im Uninstaller-Menü kann man jedes auf dem PC installiertes Programm auswählen um es vollständig entfernen zu lassen. Das Problem ist aber doch, das PostgreSQL ja nicht wirklich installiert ist. Jedenfalls wird es nicht als installiertes Programm geführt. Wie mir der Uninstaller also beim Entfernen dieser lästigen Software hilft, ist mir noch unklar. Vielleicht kannst du ja mal erklären, wie du das verwendet hast.
    • karlatiger
      karlatiger
      Bronze
      Dabei seit: 09.02.2007 Beiträge: 116
      Hi LORDbobby89,

      ich habe Revo Uninstaller gerade eben geöffnet und bei mir wird PostgreSQL 8.3 gelistet. Kann es so also ohne weiters deinstallieren. Hm, dazu fällt mir dann im Moment auch nichts weiter ein... sry
    • Rollswap
      Rollswap
      Bronze
      Dabei seit: 01.07.2008 Beiträge: 183
      liegt am Vista Update wohl HM geht auch nicht.
      Macht erstmal nichts mit anderen Programmen, sonst gehts später gar nichts mehr.
      [Guide] Datenbank Probleme

      Dort wird euch dann geholfen, wenn es eine Lösung dann gibt.
    • Rollswap
      Rollswap
      Bronze
      Dabei seit: 01.07.2008 Beiträge: 183
      Und hört auf eure DB zu löschen!!!!!! Das bringt nichts.
    • mergelina
      mergelina
      Bronze
      Dabei seit: 28.03.2008 Beiträge: 2.653
      ist eigentlich nicht so schwierig. elephant deinstallieren, postgre deinstalolieren (über systemst. software), manuell noch alle verzeichnisse löschen, obwohl das glaube ich nicht mal unbedingt nötig ist. Aber nun das allerwichtigste. Es wurde bei installation ein benutzerkonto angelegt, normalerweise "postgre" oder was ihr halt bei installation angegeben habt. Dieses benutzerkonto müsst ihr nun unbedingt löschen. Das geht wunderbar über systemsteuerung / verwaltung /computerverwaltung/ gruppen und benutzer oder per direkteingabe
      start - ausführen: (und nun muss ich leider passen, ist schon solange her, den genauen laut des befehls habe ich vergessen - geht aber wunderbar über systemsteuerung)
      danach elephant neu installieren. Wahrscheinlich wird die postgre dann nicht automatisch neuinstalliert, das müsst ihr dann manuell machen.

      C:P rogrammePokerStrategyPokerStrategy Elephant

      Dort startest du die Datei: postgresql-8.3.msi

      nicht doppelklicken/öffnen sondern rechte maustaste, dann nur "entpacken"
    • LORDbobby89
      LORDbobby89
      Bronze
      Dabei seit: 23.10.2008 Beiträge: 11.165
      Danke für deinen Eintrag, klingt eigentlich einfach =) Ein Problem taucht bei mir jetzt aber auf, wenn ich das Benutzerkonto von Postgre löschen möchte. Habe es mit deinem Pfad versucht, komme jedoch nach Computerverwaltung nicht mehr weiter. Habe Vista, vielleicht ist das dort anders!? Hier einfach mal der Screen der geöffneten Computerverwaltung:




      Jetzt komme ich nicht mehr weiter, wäre schön, wenn du oder jemand anderes jetzt noch weiterhelfen könnte.
    • LORDbobby89
      LORDbobby89
      Bronze
      Dabei seit: 23.10.2008 Beiträge: 11.165
      up

      Keiner mehr eine hilfreiche Idee? :(
    • michlveit
      michlveit
      Bronze
      Dabei seit: 28.11.2008 Beiträge: 679
      ich seh du hast vista also schau dir ma den thread an:
      DB-Problem mit Vista

      Bei mir hats geholfen
      Lg