@ROLLSWAP HILFE Problem ist wieder gekehrt! ELEPHANT nach VISTA update

  • 8 Antworten
    • Iarwe
      Iarwe
      Bronze
      Dabei seit: 04.02.2006 Beiträge: 785
      Was ist denn genau das Problem?
    • VikiSimi
      VikiSimi
      Bronze
      Dabei seit: 17.08.2006 Beiträge: 1.751
      ich beschreibs mal am besten mit hilfe dieses threadS:
      LÖSUNG fur DB-Problem nach VISTA update (weiter unten bzw. in der mitte beschriebt rollswap die lösung)

      kurz: es gab ja n vista update, seitdem konnte man nicht zur datenbank connecten; mit hilfe des threads kann man das problem halt lösen.....leider ging das nur einen tag lang gut, am nächsten tag konnte ich wieder nciht zru DB connecten; auch nachdem ich alle schritte nochmal gemacht hab, ging es nicht...
    • Iarwe
      Iarwe
      Bronze
      Dabei seit: 04.02.2006 Beiträge: 785
      Was kommt denn für eine Meldung?
    • Rollswap
      Rollswap
      Bronze
      Dabei seit: 01.07.2008 Beiträge: 183
      Eben, was für eine Fehlermeldung bekommst du?
      Bekommst du die gleiche wieder? Die "Failed establishing connection to 127.0.0.1" ?
      Hast du nochmal PgSQL mal im CMD neugestartet (musst CMD mit Rechtsklick als Admin ausführen)?
      Befehle:
      Beenden: net stop pgsql-8.3
      Start: net start pgsql-8.3

      Dann solltest du eigentlich die Meldung Posgres SQL Database erfolgreich gestartet, oder so ähnlich, bekommen.

      Dann öffne nochmal die Host Datei und überprüfe, ob die richtige Adresse noch drinsteht, sprich 127.0.0.1. Am Besten du löscht alles andere aus der Datei raus. so das nur noch:
      127.0.0.1 localhost
      drinsteht.

      Und wenn das nich geht, dann müssen wir mal schauen, woran er sich aufhängt.

      EDIT: Ohh, hab jetzt erst deinen 2. post gesehen. Also, wenn du die "host" datei, nach einem Neustart öffnest, steht der
      Befehl: 127.0.0.1 localhost
      noch in der Datei drin?
      Wenn ja, quote hier doch mal die Fehlermeldung vom Elephant bitte.


      EDIT#2: Sollte der Befehl noch drinstehen, und die Standard-Fehlermeldung kommen. Dann geh doch mal bitte in die Datei:
      hba_file C:/Program Files/PostgreSQL/8.3/data/pg_hba.conf

      Öfnne diese Datei mit dem Editor und poste doch mal den letzten Block aus der Datei. Danke


      Und wtf, warum ist die Forumuhr 14h hinterher? :0
    • kingkevin8887
      kingkevin8887
      Bronze
      Dabei seit: 03.09.2006 Beiträge: 1.761
      habe das gleiche problem... hab alles gemacht wie es beschrieben war und es kommt immer noch die selbe fehlermeldung "failed establishing...."

      das hier steht in meiner hba_file:
      # PostgreSQL Client Authentication Configuration File
      # ===================================================
      #
      # Refer to the "Client Authentication" section in the
      # PostgreSQL documentation for a complete description
      # of this file. A short synopsis follows.
      #
      # This file controls: which hosts are allowed to connect, how clients
      # are authenticated, which PostgreSQL user names they can use, which
      # databases they can access. Records take one of these forms:
      #
      # local DATABASE USER METHOD [OPTION]
      # host DATABASE USER CIDR-ADDRESS METHOD [OPTION]
      # hostssl DATABASE USER CIDR-ADDRESS METHOD [OPTION]
      # hostnossl DATABASE USER CIDR-ADDRESS METHOD [OPTION]
      #
      # (The uppercase items must be replaced by actual values.)
      #
      # The first field is the connection type: "local" is a Unix-domain socket,
      # "host" is either a plain or SSL-encrypted TCP/IP socket, "hostssl" is an
      # SSL-encrypted TCP/IP socket, and "hostnossl" is a plain TCP/IP socket.
      #
      # DATABASE can be "all", "sameuser", "samerole", a database name, or
      # a comma-separated list thereof.
      #
      # USER can be "all", a user name, a group name prefixed with "+", or
      # a comma-separated list thereof. In both the DATABASE and USER fields
      # you can also write a file name prefixed with "@" to include names from
      # a separate file.
      #
      # CIDR-ADDRESS specifies the set of hosts the record matches.
      # It is made up of an IP address and a CIDR mask that is an integer
      # (between 0 and 32 (IPv4) or 128 (IPv6) inclusive) that specifies
      # the number of significant bits in the mask. Alternatively, you can write
      # an IP address and netmask in separate columns to specify the set of hosts.
      #
      # METHOD can be "trust", "reject", "md5", "crypt", "password", "gss", "sspi",
      # "krb5", "ident", "pam" or "ldap". Note that "password" sends passwords
      # in clear text; "md5" is preferred since it sends encrypted passwords.
      #
      # OPTION is the ident map or the name of the PAM service, depending on METHOD.
      #
      # Database and user names containing spaces, commas, quotes and other special
      # characters must be quoted. Quoting one of the keywords "all", "sameuser" or
      # "samerole" makes the name lose its special character, and just match a
      # database or username with that name.
      #
      # This file is read on server startup and when the postmaster receives
      # a SIGHUP signal. If you edit the file on a running system, you have
      # to SIGHUP the postmaster for the changes to take effect. You can use
      # "pg_ctl reload" to do that.

      # Put your actual configuration here
      # ----------------------------------
      #
      # If you want to allow non-local connections, you need to add more
      # "host" records. In that case you will also need to make PostgreSQL listen
      # on a non-local interface via the listen_addresses configuration parameter,
      # or via the -i or -h command line switches.
      #



      # TYPE DATABASE USER CIDR-ADDRESS METHOD

      # IPv4 local connections:
      host all all 127.0.0.1/32 md5
      # IPv6 local connections:
      host all all ::1/128 md5


      wenn ich bei cmd die befehle eingebe, kommt das der befehl nicht bekannt ist o0? hoffe du kannst helfen. (habe auch mal nur "127.0.0.1 localhost" in die datei reingeschrieben... bringt auch nix, steht nachm neustarten immernoch genauso drinnen...) thx
    • Rollswap
      Rollswap
      Bronze
      Dabei seit: 01.07.2008 Beiträge: 183
      naja, die Adressen sind dann richtig eingetragen. Also kann es dann nur noch am Elephant liegen. Aber echt seltsam.
      Und einfach den Elephant mal neuinstallieren? die DB bleibt ja erhalten. Ist doch in wenigen Minuten erledigt.

      Edit: Ach ja, vergiss den lizenzschlüssel nicht zu behalten ;)
    • kingkevin8887
      kingkevin8887
      Bronze
      Dabei seit: 03.09.2006 Beiträge: 1.761
      hab ich auch schon gemacht... kommt immernoch das gleiche problem... kann mir da jemand evtl über teamviewer und skype helfen? viell. mache ich auch was falsch. meine icq: 161820466
    • Rollswap
      Rollswap
      Bronze
      Dabei seit: 01.07.2008 Beiträge: 183
      Du benützt Windows Vista oder?
      Hast du vor kurzen ein paar Ports blockiert? Ist bei dir das Problem auch wegen dem Update von Vista aufgetreten?

      Versuche doch mal hier Hilfe zu bekommen:
      Bei Elephant Abstürzen - Skype+ICQ Support

      Vielleicht hast ja Glück und der Support ist mal online.


      Ich könnte dich schon mal unterstützen mit ICQ und TeamView, ich könnte aber erst am Montag wieder, weil ich bis dahin unterwegs bin und nur immer sporadisch Zeit hab um ins Netz zu schauen. Also vielleicht findet sich noch ein anderer.