Postgres installation wie?

    • Sahni1
      Sahni1
      Bronze
      Dabei seit: 13.12.2008 Beiträge: 1.486
      Moinmoin!

      Möchte hier erneut alles installieren beim elephant. Hab sowohl den elephant deinstalliert als auch postgres. Da meine Datenbank ja kaputt war und hier keiner Hilfe wusste.
      Nun möchte ich postgres wieder installieren, nur wenn ihc nun den installieren elephant starte, um eine neue datenbank anzulegen und postgress zu installieren, kommt dauernd eine Fehlermeldung wärend dieser installation.



      Dann kommt dieses hier -->



      Zudem muss ich jedesmal nen neuen namen mir ausdenken, weil er daraufhin immer sagt, dass der von mir vorher halt installeire benutzername schon exsistiert.

      lg Sahni
  • 8 Antworten
    • Iarwe
      Iarwe
      Bronze
      Dabei seit: 04.02.2006 Beiträge: 785
      Versuchst Du deinen Windows Benutzernamen zu verwenden?
    • Sahni1
      Sahni1
      Bronze
      Dabei seit: 13.12.2008 Beiträge: 1.486
      Soll ich den verwenden?
      Also ich verwende irgendeinen namen...
      Dann kommt die Fehlermeldung, dann kann ich wieder einen neuen Namen eintippen, tippe ich den gleichen aber, wie zuvor ein folgt: "Der Benutzername/Account existiert schonn)

      Unabhängig davon ob ich postgres, elephant, elephantuser, Sahni verwende.
    • Iarwe
      Iarwe
      Bronze
      Dabei seit: 04.02.2006 Beiträge: 785
      Nein, den Windowsbenutzernamen darfst Du natürlich nicht verwenden.

      Was für Benutzer existieren denn bereits bei Dir in Windows?
    • Sahni1
      Sahni1
      Bronze
      Dabei seit: 13.12.2008 Beiträge: 1.486
      Ein paar, aber das hat ja nichts mit dem Fehler zu tun, soweit ich dsa erkennen kann. Da wird ja eindeutig ein anderer Error angemerkt. Gibt einige benutzernamen bei windows. Aber hab auch welche verwendete, die ich defitnitiv nicht bei windows verwende...
    • Sahni1
      Sahni1
      Bronze
      Dabei seit: 13.12.2008 Beiträge: 1.486
      So hab wie gesagt postgres deinstalliert und das neuinstallieren funktioniert nicht. Hoffe, dass Euch noch was einfällt. Ich suche noch einwenig im Forum nahc Infos, bin aber bissle enttäuscht. Find den elephant halt klasse und muss sonst wieder auf pt2 + Pokerace umsteigen...

      Also freu mich for information... :)
    • Rollswap
      Rollswap
      Bronze
      Dabei seit: 01.07.2008 Beiträge: 183
      mmh, ich bin mir jetzt nicht ganz sicher, ob ich dein Problem richtig verstanden habe, aber ich glaube das liegt an dem klassichen Problem der unsauberen Deinstallation von postgreSQL.
      Windows richte wie eine Art User für posgreSQL ein. Dieser heißt für gewöhnlich
      "postgres" bzw. mit dem Namen, wie du dich bei der 1. Installation von PgSQL angemeldet hast. Diesen musst du entfernen:
      Öffne dazu
      1. Computerverwaltung (Rechtsklick als Admin ausführen)/Lokale Benutzer und Gruppen\Benutzer
      Dort siehst du einen Benutzer mit der Beschreibung PostgreSQL-Service Account. Diesen musst du löschen.

      Das sollte es eigentlich gewesen sein.

      2. Kannst dann noch nachschauen ob unter c: Programme der PostgeSQL Ordner gelöscht ist.

      Hoffe ich konnte dir helfen.

      so long Rollswap


      Hier noch der Ordner mit der Deinstallations-Anleitung von PgSQL
      How-To: Deinstallation von PostgreSQL
    • Sahni1
      Sahni1
      Bronze
      Dabei seit: 13.12.2008 Beiträge: 1.486
      Danke Dir Rollswap :-). Hab alle deine Anweisungen befolgt und es klappt wieder :-). Sowohl der Ordner als auch unter der Verwaltung war wieder ein Benutzeraccount. (Dachte ich hätte alles sauber entfernt)
    • Rollswap
      Rollswap
      Bronze
      Dabei seit: 01.07.2008 Beiträge: 183
      Original von Sahni1
      Danke Dir Rollswap :-). Hab alle deine Anweisungen befolgt und es klappt wieder :-). Sowohl der Ordner als auch unter der Verwaltung war wieder ein Benutzeraccount. (Dachte ich hätte alles sauber entfernt)
      Gern geschehen.

      greetz
      Rollswap