Update auf 3.17 Error