new database

    • sultan89
      sultan89
      Bronze
      Dabei seit: 04.11.2008 Beiträge: 54
      hallo leute,ich soll eine neue database errichten und drücke dann auch bestätigen bzw. ''OK'' jedoch findet er keine verbindung zum server.
      da steht immer:

      Connection to database server lost!

      Further informations:

      failed to establish a connection to '127.0.0.1'.


      was soll ich jetzt machen ?
      besten dank schon mal sultan89
  • 7 Antworten
    • cLue
      cLue
      Bronze
      Dabei seit: 04.06.2005 Beiträge: 2.186
      Hier gibt es einen Guide dazu:

      [Guide] Datenbank Probleme

      meist reicht ein System-Neustart (und dann etwas warten bis man den Elephanen anwirft) oder das Manuelle Starten der Datenbank!

      mfg felix
    • sultan89
      sultan89
      Bronze
      Dabei seit: 04.11.2008 Beiträge: 54
      bei schritt drei wird mir immer gesagt:zugriff verweigert...
      komme dort nicht weiter. weiß jemand weiter ??
      besten dank im vorraus.
    • cLue
      cLue
      Bronze
      Dabei seit: 04.06.2005 Beiträge: 2.186
      Jo ich ;)

      Du musst die cmd.exe im windows explorer suchen und diese dann als Admin ausführen (rechtsklick - ausführen als - Administrator).

      Dann sollte das gehen!

      felix
    • sultan89
      sultan89
      Bronze
      Dabei seit: 04.11.2008 Beiträge: 54
      das mache ich ja auch...er sagt mir dann aber, dass es nicht gestartet werden kann.
      dann soll man ja wie in schritt drei steht folgendes machen:
      Achtung:
      Kann der Dienst nicht gestartet werden deutet das daraufhin, dass die Datenbank nicht (korrekt) installiert wurde.
      Im Elephant Odner muss dann die Datei "postgresql-8.3.msi" ausgeführt und installiert werden (notiert euch den Benutzernamen und das Passwort, welches ihr anlegen sollt)!

      Ich öffne dann den elephant ordner jedoch ist da die datei ''postgresql-8.3.msi'' bei mir gar nicht gelistet-da sind nur postgresql-8.3 und postgresql-8.3-int
    • cLue
      cLue
      Bronze
      Dabei seit: 04.06.2005 Beiträge: 2.186
      naja dann nimm die ohne ".msi" denn dann hast du die Dateiendungen ausgeblendet bei bekannten Dateiformaten!

      Aber davor musst du die Datenbank nach Anleitung komplett deinstallieren (siehe How-To: Deinstallation von PostgreSQL )

      mfg felix
    • sultan89
      sultan89
      Bronze
      Dabei seit: 04.11.2008 Beiträge: 54
      besten dank, dass du so geduldig mit mir warst;) funktioniert wieder!!!
      zwei fragen habe ich noch:muss ich den ganzen spaß irgendwann nochmal wieder machen ?kommt das regelmäßig vor oder nicht ?
      und die sachen die ich bei der systemsteuerung verstellen musste,müssen die jetzt so bleiben oder kann ich die wieder zurückstellen ?
      besten dank nochmal sultan89
    • cLue
      cLue
      Bronze
      Dabei seit: 04.06.2005 Beiträge: 2.186
      Ich gehe davon aus, dass das nicht nochmals durchgeführt werden muss, ausser es treten schwerwiegende Fehler auf!

      Die Einstellungen würde ich aber so lassen - schaden zuz es nicht.

      felix