Mein Elefant streikt !!

    • xVdVx
      xVdVx
      Bronze
      Dabei seit: 27.12.2007 Beiträge: 2.906
      Durch das FT-Update habe ich nun auch Probleme bekommen. Ich beschreibe kurz was passiert ist und was ich brauche damit ich weiterkomme.

      Habe zunächst wohl meinen Elefanten wie empfohlen deinstalliert. Beim Entfernen dieses V67 Updates oder so, ahbe ich bestimmt zu viel gelöscht und alles kaputt gemacht. Vorher habe ich aber kein Backup oder sowas gemacht. Naja, Daten scheinen alle weg zu sein. Dann habe ich die aktuelle Ele-Version neu installiert. Mit den alten Daten ist aber nicht so tragisch, da ich erst vor kurzem mit Aufzeichnungen im Elefanten begonnen habe. Wenn ich auf meine alte Datenbank zugreifen will, dann faselt er was von "keine Verbindung zum Server möglich".

      Aber es gelingt mir jetzt nichtmal ne neue Datenbank anzulegen. Er sagt ich würde mich nicht mit Adminrechten am meinem Elefanten anmelden !

      Frage 1: Wie mache ich das denn mit den Adminrechten ?

      Frage 2: Gibt es vielleicht doch noch ne Chance an meine alten Daten zu kommen ?

      Bitte helft mir in Kindergartensprache, ich bin kein Computerfreak, würde aber den Ele so gerne für meine Aktivitäten nutzen. Ach ja, mein PS-Ticket sagt, ich solle mir im Forum selber helfen ! :-)

      Danke !!!!
  • 24 Antworten
    • cLue
      cLue
      Bronze
      Dabei seit: 04.06.2005 Beiträge: 2.186
      Hallo,

      um zunächst die Frage nach den Admin-Rechten zu beantworten:
      Elephant unter Vista

      Ich kann dir leider nicht sagen was du alles gelöscht hast und was noch da ist, da musst du schon etwas beisteuern.
      - Hast du den Elephant über die Software deinstalliert ?
      - Hast du irgendetwas in Richtung der postgreSQL gelöscht oder deinstalliert ?

      felix
    • xVdVx
      xVdVx
      Bronze
      Dabei seit: 27.12.2007 Beiträge: 2.906
      so, das mit den Admin-Rechten habe ich geklärt. Das passt jetzt dank des Links den du mir gepostet hast.

      Ich kann dir nicht sagen welche Datein ich kaputtgemacht oder deinstalliert habe.

      Ist vielleicht auch nicht so schlimm. Ich würde ja gerne auch komplett neu starten. Aber da lässt er mich ja nicht. Er will ja immer Datenbankname und Passwort. Gebe ich das ein, funktioniert es nicht mehr.

      Kann ich keine neue DB anlegen die meine Daten sammelt und aufzeichnet ?
    • cLue
      cLue
      Bronze
      Dabei seit: 04.06.2005 Beiträge: 2.186
      Doch eigentlich kannst du das schon machen, aber auch für das neue Anlegen einer Datenbank benötigst du das Passwort und den Benutzernamen der SQL, den du bei der Installation angegeben hast.

      Da nicht die Meldung "Keine Verbindung zu ... " erscheint, gehe ich aber davon aus, dass die Datenbank noch funktioniert.

      felix
    • xVdVx
      xVdVx
      Bronze
      Dabei seit: 27.12.2007 Beiträge: 2.906
      Original von cLue

      Da nicht die Meldung "Keine Verbindung zu ... " erscheint, gehe ich aber davon aus, dass die Datenbank noch funktioniert.

      felix
      doch, doch, genau dieser Hinweis kommt wenn ich was neu anlegen will. Ich habe den Datenbanknamen und das Passowort notiert. Und ich bin mir sehr sicher dass ich das auch korrekt in Groß-Kleinschrift eingebe etc. ! Aber genau da liegt der Hase im Pfeffer.

      Soll ich weitere Daten posten ?
    • cLue
      cLue
      Bronze
      Dabei seit: 04.06.2005 Beiträge: 2.186
      Kannst du mal in der eingabeaufforderung (start - ausfühelen - cmd.exe) prüfen ob der Dienst läuft (mit dem Befehl: net start) ?

      felix
    • xVdVx
      xVdVx
      Bronze
      Dabei seit: 27.12.2007 Beiträge: 2.906
      hab ich gemacht. wenn ich das richtig hinbekommen habe - bin leider ein geborener Computerfehler ! Er sagt mir dass das Ding läuft !
    • Tarkon72
      Tarkon72
      Bronze
      Dabei seit: 24.07.2006 Beiträge: 14.675
      Also ich kann auch keine Verbindung zum Datenbankserver aufbauen. Bekomme immer die Fehlermeldung: FATAL: 280000: passaword authentication failed...

      Die Meldung erscheint auch, wenn ich eine neue DB erstellen will.

      Ich nutze auch Vista und der Elephant lief vor dem Update ohne Probleme.
    • xVdVx
      xVdVx
      Bronze
      Dabei seit: 27.12.2007 Beiträge: 2.906
      Original von Tarkon72
      Also ich kann auch keine Verbindung zum Datenbankserver aufbauen. Bekomme immer die Fehlermeldung: FATAL: 280000: passaword authentication failed...

      Die Meldung erscheint auch, wenn ich eine neue DB erstellen will.

      Ich nutze auch Vista und der Elephant lief vor dem Update ohne Probleme.
      exakter Fehlerhinweis bei mir ! Zum Glück bin ich da schonmal nicht alleine unterwegs ! :-)

      Die werden uns schon helfen Tarkon. Vorher geben wir nicht auf ! :D
    • Tarkon72
      Tarkon72
      Bronze
      Dabei seit: 24.07.2006 Beiträge: 14.675
      Das hat mir geholfen.

      If you can’t remember your password you will need to disable authentication temporarly, login and reset the password.

      Go into your pgdata directory.

      Open pg_hba.conf

      The lines that say “md5” near the bottom, change to “trust”

      Restart your database instance.
      Login and set your password.

      alter user vu2131 with password 'foobar';

      Quit psql.

      Change the lines back to md5 in your pg_hba.conf file

      Restart your instance again.

      Try logging in and see if your change worked!

      Habe immer die Programme mit "Rechtsklick" als Admin geöffnet.
    • xVdVx
      xVdVx
      Bronze
      Dabei seit: 27.12.2007 Beiträge: 2.906
      äh, verstehe jetzt nur Bahnhof !

      Kannst du mir das kanpp auf Deutsch übersetzen und mir genau sagen wo ich hin muss ?
      Ich bin ein Computerbehindi und habe echt wenig Plan !

      Vor allem muss ich nochmal wissen wie ich zu diesem Config-Ding da komme !

      Thänks
    • cLue
      cLue
      Bronze
      Dabei seit: 04.06.2005 Beiträge: 2.186
      Die datei pg_hba.conf findest du im "data" ordner unter dem Ordner, in welchem deine Postgres installiert ist.
      Diese Datei einfach mit dem Editor öffnen und md5 durch trust ersetzen unten.

      felix
    • xVdVx
      xVdVx
      Bronze
      Dabei seit: 27.12.2007 Beiträge: 2.906
      ok, soweit verstanden ! Also einfach überschreiben und dann neu speichern, ja ?
    • cLue
      cLue
      Bronze
      Dabei seit: 04.06.2005 Beiträge: 2.186
      öffnen - ändern - speichern, ja!
    • xVdVx
      xVdVx
      Bronze
      Dabei seit: 27.12.2007 Beiträge: 2.906
      och menno.

      jetzt hab ich die Datei gefunden und habe das überschrieben. Aber er lässt mich das nicht abspeichern. Kommt immer der Hinweis: "stellen sie sicher das der Pfad richtig ist" - hab ich ja, ist richtig, ich bin ja nicht blöd. Aber es fluppt nicht.
    • xVdVx
      xVdVx
      Bronze
      Dabei seit: 27.12.2007 Beiträge: 2.906
      ok, ich habe einen Weg gefunden die geänderte Datei zu ersetzen.

      Aber was muss ich dann tun ?

      WAs muss ich wo starten ...... ?

      Bitte nicht nachlassen und weiterhelfen !
    • cLue
      cLue
      Bronze
      Dabei seit: 04.06.2005 Beiträge: 2.186
      Den PC neustarten zur Sicherheit und den Elephanten wieder starten.
      Aber sicherstellen, dass die Datenbank läuft.

      Dann sollte jedes Passwort funktionieren.

      felix
    • xVdVx
      xVdVx
      Bronze
      Dabei seit: 27.12.2007 Beiträge: 2.906
      Funktioniert leider nicht !

      ... ich komme langsam an den Punkt wo ich verzweifle .... entschuldige wenn ich mich so doof anstelle, aber es klappt einfach nicht.

      Wie kann ich denn sicherstellen dass die Datenbank läuft ?

      Den Neustart mit der geändeten Conf-DAtei habe ich gemacht. Als Fehler bekomme ich wieder diesen dummen Hinweis mit "keine Verbindung zum Server ... FATAL 28000 ach leck mich doch in de Täsch "
    • cLue
      cLue
      Bronze
      Dabei seit: 04.06.2005 Beiträge: 2.186
      Du darfst das pwd feld nicht leer lassen - irendetwas muss drin stehen.

      Kannst du die pg_hab.conf hier mal rein pasten.

      felix
    • xVdVx
      xVdVx
      Bronze
      Dabei seit: 27.12.2007 Beiträge: 2.906
      # PostgreSQL Client Authentication Configuration File
      # ===================================================
      #
      # Refer to the "Client Authentication" section in the
      # PostgreSQL documentation for a complete description
      # of this file. A short synopsis follows.
      #
      # This file controls: which hosts are allowed to connect, how clients
      # are authenticated, which PostgreSQL user names they can use, which
      # databases they can access. Records take one of these forms:
      #
      # local DATABASE USER METHOD [OPTION]
      # host DATABASE USER CIDR-ADDRESS METHOD [OPTION]
      # hostssl DATABASE USER CIDR-ADDRESS METHOD [OPTION]
      # hostnossl DATABASE USER CIDR-ADDRESS METHOD [OPTION]
      #
      # (The uppercase items must be replaced by actual values.)
      #
      # The first field is the connection type: "local" is a Unix-domain socket,
      # "host" is either a plain or SSL-encrypted TCP/IP socket, "hostssl" is an
      # SSL-encrypted TCP/IP socket, and "hostnossl" is a plain TCP/IP socket.
      #
      # DATABASE can be "all", "sameuser", "samerole", a database name, or
      # a comma-separated list thereof.
      #
      # USER can be "all", a user name, a group name prefixed with "+", or
      # a comma-separated list thereof. In both the DATABASE and USER fields
      # you can also write a file name prefixed with "@" to include names from
      # a separate file.
      #
      # CIDR-ADDRESS specifies the set of hosts the record matches.
      # It is made up of an IP address and a CIDR mask that is an integer
      # (between 0 and 32 (IPv4) or 128 (IPv6) inclusive) that specifies
      # the number of significant bits in the mask. Alternatively, you can write
      # an IP address and netmask in separate columns to specify the set of hosts.
      #
      # METHOD can be "trust", "reject", "md5", "crypt", "password", "gss", "sspi",
      # "krb5", "ident", "pam" or "ldap". Note that "password" sends passwords
      # in clear text; "md5" is preferred since it sends encrypted passwords.
      #
      # OPTION is the ident map or the name of the PAM service, depending on METHOD.
      #
      # Database and user names containing spaces, commas, quotes and other special
      # characters must be quoted. Quoting one of the keywords "all", "sameuser" or
      # "samerole" makes the name lose its special character, and just match a
      # database or username with that name.
      #
      # This file is read on server startup and when the postmaster receives
      # a SIGHUP signal. If you edit the file on a running system, you have
      # to SIGHUP the postmaster for the changes to take effect. You can use
      # "pg_ctl reload" to do that.

      # Put your actual configuration here
      # ----------------------------------
      #
      # If you want to allow non-local connections, you need to add more
      # "host" records. In that case you will also need to make PostgreSQL listen
      # on a non-local interface via the listen_addresses configuration parameter,
      # or via the -i or -h command line switches.
      #



      # TYPE DATABASE USER CIDR-ADDRESS METHOD

      # IPv4 local connections:
      host all all 127.0.0.1/32 trust
      # IPv6 local connections:
      host all all ::1/128 trust
    • 1
    • 2