Superuserpasswort für SQL 8.3?

    • ErikNick
      ErikNick
      Bronze
      Dabei seit: 10.07.2006 Beiträge: 5.921
      Hallo,

      ich will paralell zu Postgres 8.0 die 8.3 installieren - der will noch vor der Installation ein PW - password for the postgres windows user account - aber er akzeptiert keins ... woran kann das liegen? Was will er? Das PW von der alten Installation geht nicht ... nu bin ich ratlos ... beim Googeln kriege ich immer nur irgendwelchen Programmierer-Kram ...
  • 8 Antworten
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.836
      Normalerweise müsste das von der ursprünglichen Postgresinstallation gehen.
      Du kannst alternativ auch einen neuen User z.B. postgresuser als "Superuser" definieren.

      Bitte beachte, dass du die 2. Postgresql Version auf einem anderen Port laufen lassen musst.
    • ErikNick
      ErikNick
      Bronze
      Dabei seit: 10.07.2006 Beiträge: 5.921
      Soweit komme ich ja leider gar nicht erst ... ich starte die Installation, dann wird nach dem Pfad gefragt und dann kommt schon die Passwortabfrage.
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.836
      Tja, dann musst du das richtige suchen oder Postgresql 8.0 runterschmeissen und den User löschen.

      Mit welchem Programm arbeitest du denn zur Zeit?
    • ErikNick
      ErikNick
      Bronze
      Dabei seit: 10.07.2006 Beiträge: 5.921
      Ich hab jetzt eine andere Installationsdatei gefunden, keine *.exe sondern eine *.msi - mit der komme ich bis zu "Dienstekonfiguration", da wird dann allerdings wieder das Passwort verlangt.

      Ich kenne mein PW ja, ich habe die Registry durchsucht, in pgadminIII nachgeguckt ... ich habe in Dienste nachgeguckt und alles probiert - nimmt er halt nicht. Keine Ahnung, was der will.

      Zur Zeit habe ich PT2 mit einer 2-Mio-Hände-DB über postgres 8.0, jetzt will ich HM auf 8.3 dazunehmen und erstmal beide paralell probieren, bis ich mich festlege ... wenn ich postgres 8.0 runterschmeisse und das mit HM nicht so funzt wie ich mir das vorstelle, dann stehe ich ja erstmal blöde da ... wer weiß, ob ich PT2 dann hinterher wieder ans Laufen kriege ...
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.836
      Versuch doch mal den HM mit Postgresql 8.0 zu verbinden. Ich bin mir nicht ganz sicher aber ich glaube das läuft. Also die Postgresql 8.0 Verbindungsdaten angeben und eine neue Datenbank anlegen.
    • ErikNick
      ErikNick
      Bronze
      Dabei seit: 10.07.2006 Beiträge: 5.921
      Na, ich wollte ja keinesfalls die alte DB nutzen, aber mein Problem ist geklärt (danke an Galam). Läuft jetzt alles :)

      Danke noch mal an alle!
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.836
      Wodran lags denn?
    • ErikNick
      ErikNick
      Bronze
      Dabei seit: 10.07.2006 Beiträge: 5.921
      Keine Ahnung warum der alte Benutzername nicht akzeptiert wurde, aber über 'neuer Benutzer' gings dann ... das hatte ich natürlich auch schon probiert, aber natürlich stumpf 'Erik' genommen - war aber halt schon belegt und ich habs nicht gemerkt, deshalb wurde das PW nicht akzeptiert ... Galam hat auch stumpf seinen Standard genommen, aber der war bei mir natürlich noch nicht belegt :D

      Also faktisch laufen jetzt die Version 8.0 und die 8.3 paralell ... auf die 8.0 greift PT2 zu bis ich ihn kicke und die 8.3 wird gerade von HM zum Einlesen meiner exportierten Hände verwendet. Schönes Ding. Beide Versionen habe bei mir je eine eigene Partition.