PostgreSQL kein Start nach Tunning

    • promyk82
      promyk82
      Bronze
      Dabei seit: 22.08.2006 Beiträge: 1.281
      Hey.

      Ich habe nach dem manuellen Tunning (nicht mit Tunning Wizzard) das Problem, dass PostgreSQL nicht mehr startet. Habe bei den Punkten 2 und 3 die # entfernt, den Rechner neugestartet. PostgreSQL muss ich danach selbst starten, obwohl autostart eingestellt ist. Wenn ich das mache kommt die Meldung das es wegen Zeitüberschreitung nicht möglich ist und bei den Diensten zeigt es mir an SQL "wird gestartet". Das passiert aber nicht, auch nach längerer Wartezeit wird nichts gestartet. Habe Windows Vista.

      Hat jmd eine Idee wie ich dieses Problem beheben kann? Bzw ist das Tunning mit dem TunningWizzard genauso gut?

      Vielen Dank promyk.
  • 11 Antworten
    • Mtoy
      Mtoy
      Bronze
      Dabei seit: 02.04.2007 Beiträge: 1.242
      config datei posten, sonst wird dir keiner helfen können(denke ich :D )
    • promyk82
      promyk82
      Bronze
      Dabei seit: 22.08.2006 Beiträge: 1.281
      Die Dateien, welche ich geändert habe? Kann ich erst morgen früh, da ich auf Arbeit bin und jetzt nicht an meinen Rechner ran komme...
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.835
      Änderungen wieder rückgängig machen ...
    • promyk82
      promyk82
      Bronze
      Dabei seit: 22.08.2006 Beiträge: 1.281
      Habe ich denn mit dem TunningWizzard eine ähnlich gute Performance? Dann würde ich alles wieder rückgängig machen und diesen nutzen. Muss mann den TunningWizzard regelmäßig anwenden oder reicht einmal?
    • netsrak
      netsrak
      Gold
      Dabei seit: 11.03.2006 Beiträge: 36.835
      Ich habe auch schon von einigen gelesen bei denen der Tuning Wizzard zum gleichen Ergebnis geführt hat.

      Du hast mit Sicherheit irgendwas falsch geändert so dass der Dienst nicht mehr starten konnte. Also such dir eine Anleitung und mach die Änderungen richtig.
    • DoubleU007
      DoubleU007
      Bronze
      Dabei seit: 24.11.2008 Beiträge: 2.081
      Bei mir führte seinerzeit das auskommentieren dieser beiden parameter zum Erfolg. Der "Vorschlag" kam auch vom tuning wizard und war der einzige der trouble machte resp. den Start des Dienstes verhinderte:

      max_fsm_pages = 20000
      max_fsm_relations = 1000
    • promyk82
      promyk82
      Bronze
      Dabei seit: 22.08.2006 Beiträge: 1.281
      Hm, hatte es sogar 2x gemacht und soviel falsch machen kann man da ja eigentlich nicht. (Anleitung ist ja vorhanden/danke dafür). Die 3 Zahlen ersetzen, sowie bei Punkt zwei und drei das "#" entfernen....

      @DoubleU007 kannst du das etwas genauer ausführen? Bin nicht gerade jmd der sich mit der Materie auskennt und verstehe deinen Post leider gar nicht.
    • DoubleU007
      DoubleU007
      Bronze
      Dabei seit: 24.11.2008 Beiträge: 2.081
      Aso, kp. :-)

      Öffne die postgresql.conf mit einem editor (Standardmäßig in diesem Pfad C:\Programme\PostgreSQL\8.4\data )

      und mache vor die oben erwähnten zeilen jeweils ein doppelkreuz #

      Sollte das nicht funken oder es nicht an den Einträgen liegen nehme stattdessen erst einmal die originale postgresql.conf, die vom tuning wizard i.d.R. in Kopie im selben Verzeichnis abgelegt wurde.


      Kannst die Datei bzw. deren Inhalt hier auch mal posten wie oben glaube ich schon vorgeschlagen wurde.
    • promyk82
      promyk82
      Bronze
      Dabei seit: 22.08.2006 Beiträge: 1.281
      So, hatte PT und PG nochmal komplett neu installiert. Das Tunning durchgeführt und es lief... Nach einem Neustart des Computers kommen allerdings wieder die Fehler, dass PG nicht gestartet werden kann....
      Kann ich in PG irgendwo finden woran das liegt und hier posten, damit mir jmd Rat zur Abhilfe geben kann?

      Tritt Fehler Nr 1053 auf, falls das weiter hilft.

      PS: Wie poste ich Screenshots von dem Tunning bzw der Fehlermeldung?
    • Mtoy
      Mtoy
      Bronze
      Dabei seit: 02.04.2007 Beiträge: 1.242
      Einfach "Druck" auf dem Keyboard drücken -> Einfügen in z.B. Paint -> Speichern als *.jpg -> Bild hochladen z.B. imageshack.us
    • promyk82
      promyk82
      Bronze
      Dabei seit: 22.08.2006 Beiträge: 1.281
      So, hatte mir professionelle Hilfe geholt und es klappt alles =)
      Falls noch jmd dieses Prob haben sollte, werde ich versuchen dieses laienhaft darzulegen (zu mehr reicht es von meiner Seite aus nicht....)
      Der Typ vom Computerladen meinte man die Einstellungen (bei 6 GB Arbeitsspeicher) nicht auf das Maximale stellen, sondern nur bis max 3 GB angleichen. (die Begründung dafür habe ich schon wieder vergessen/war etwas länger). Also hat er das Tunning für 3 GB Arbeitsspeicher gemacht und es funktioniert endlich...

      Falls es relevant ist, habe Vista64...