Datenbak weg?

    • bumblebeebee
      bumblebeebee
      Bronze
      Dabei seit: 06.06.2006 Beiträge: 2.021
      Hallo,
      als ich gerade den elephant starten wollte, kam so ne Meldung: "Die Datenbankvesion hat sich geändert, bitte erstellen sie eine neue Datenbank". Ich habe abbrechen gemacht und den elephant geschlossen. Wenn ich ihn jetzt wieder starte kommt direkt die Meldung: "Bitte erstellen sie zuerst eine neue Datenbank" Im Datenbankmanagemant kann ich meine Datenbank nicht mehr sehen.

      Ich habe Version 0.67 und kein update oder ähnliches gemacht. Gestern hat der elephant funktioniert, hatte ihn ganz normal geschlossen und heute gestartet.

      Wie komme ich wieder an meine DB oder ist sie weg?
  • 5 Antworten
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Huhu,

      Läuft der postgreSQL Dienst? Systemsteuerung -> Verwaltung -> Dienste. Mal nachgucken bitte, und den Dienst mal neustarten, klappts dann?


      Ansonsten würde ich folgendes vorschlagen.

      Du lädst dir zuerst PgAdmin herunter: http://wwwmaster.postgresql.org/download/mirrors-ftp/pgadmin3/release/v1.8.4/win32/pgadmin3-1.8.4.zip

      Das instalierst du, verbindest dich dann zu deiner Datebank (Doppelklick links im Menü auf die Datenbank). Dann gibst du dein Passwort ein, dann solltest du die Elephant Datenbank sehen.

      Jetzt machst du auf die nen rechtsklick und wählst erstmal Backup.

      Ist das Backup erstellt, schließt du pgAdmin und deinstallierst mal den Elephant.

      Danach lädst du dir die neueste Elephant Version herunter: http://static.pokerstrategy.com/software/9/download/setup_elephant-0.69.exe

      Anleitung gibts im Blog: http://elephant.pokerstrategy.com

      Wenn es danach funktioniert, einfach das Backup zurückspielen, bzw. der Elephant sollte die Datenbank erkennen und die Daten sollte noch alle da sein.

      Wenn das noch nicht hilft, dann musst du noch postgreSQL neu installieren.

      Infos dazu hier: How-To: Deinstallation von PostgreSQL
    • bumblebeebee
      bumblebeebee
      Bronze
      Dabei seit: 06.06.2006 Beiträge: 2.021
      der dienst läuft und neustarten hat nichts gebracht. habe also das backup gemacht, das hat eine ".backup" datei erzeugt, richtig?
      hab 0.67 deinstalliert und 0.69 installiert. Wie spiele ich nun das backup ein? beim start werde ich wieder aufgefordert eine neue DB zu erstellen.
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Dazu gehst du im pgAdmin den selben Weg wie vorhin nur wählst dann statt Backup, Wiederherstellen aus.

      Danach startest du den ELephant und wenn du aufgefordert wirst eine neue Datenbank anzulegen, dann gibst du die Daten der alten Datenbank ein, dann sollte er sich verbinden.
    • bumblebeebee
      bumblebeebee
      Bronze
      Dabei seit: 06.06.2006 Beiträge: 2.021
      Hey, bin erst jetzt wieder dazu gekommen mich den elephant zu kümmern.

      Ich habe also den elephant deinstalliert und sql nach dieser Anleitung deinstalliert http://de.pokerstrategy.com/home/959

      Dann habe ich Version 0.69 vom elephant installiert. Wenn ich den nun starte ershalte ich die Meldung "Die Verbindung mir der Datenbak konnte nich hergestellt werden! Bitte stellen sie sicher, das PostgreSQL läuft und die Einstellungen korrekt sind."

      Die gleiche Meldung, wenn ich versuche im elephant eine neue DB zu erstellen.

      Hm, eigentlich hätte doch sql mit dem ele neu installiert werden müssen, oder?

      P.S. Hans meint, dass man "das" in dieser Meldung mit 2 "s" schreibt.


      edit: Hab mal bei "Dienste" nachgeguckt und der postgreSQL dienst läuft nicht.
    • mrk1988
      mrk1988
      Bronze
      Dabei seit: 04.02.2007 Beiträge: 13.337
      Hast du PostgreSQL zu irgendeinem Zeitpunkt neu installiert? Konnte das nicht rauslesen.
      Bitte PostgreSQL mal neu installieren, die notwendige Datei dafür findest du im Installations Ordner vom Elephant.